WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't log in: localhost/wordpress/wp-login.php, Error 401 (2 posts)

  1. TomR.
    Member
    Posted 1 year ago #

    Hi- I have searched Google, and also this support forum for a solution to no avail. Maybe this post will help someone in the same situation. Here's my setup:

    Remote server side=
    Linux-hosted, WP 3.4.2 site with these plugins...

    - Akismet

    - Duplicator

    - HTTP Authentication

    - Role Scoper

    - WordPress Importer

    I can log into the remote site without a hitch via WP admin account.

    Now on localhost:
    I used the duplicator plugin to download a full WP copy on a MacBook 10.6.8 laptop running XAMPP 1.7.3.

    I moved the HTTP Authentication plugin directory to a different location so it does not load on my localhost copy.

    If I do one of these two things the error 401 (below) appears on Chrome, Safari, and Firefox:

    -I tried to update my permalinks using duplicator by accessing http://localhost/wordpress/wp-admin/options-permalink.php

    -and/or I tried to log into the localhost site, which seems to work at first with my remote-site admin account but quickly errors out by accessing
    http://localhost/wordpress/wp-admin/

    Result is this error on all browsers with passwords cleared:
    Authentication required!

    This server could not verify that you are authorized to access the URL "/wordpress/wp-admin/". You either supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

    In case you are allowed to request the document, please check your user-id and password and try again.

    If you think this is a server error, please contact the webmaster.
    Error 401

    Cheers,
    Tom

  2. TomR.
    Member
    Posted 1 year ago #

    This error was caused by a faulty .htaccess file in the [web root]/wordpress/wp-admin/ directory.

    Duplicator did not change this from my remote site, I manually edited the .htaccess file to read:
    AuthName "WordPress"
    AuthType Basic

    Problem solved.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags