WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't log in as anything but admin? (5 posts)

  1. belderiver
    Member
    Posted 2 years ago #

    Hi there,

    I've got a wordpress.com account I've associated with my blog that is set to an administrator. However, when I try to log in with it, it will not accept the username and password - the username and password are correct, and work just fine on wordpress.com. Does anyone know how I might correct this problem? The only account I can login with is the default "admin" one which isn't to be used for posting.

    Thanks.

  2. patv
    Member
    Posted 2 years ago #

    When using WordPress.com and creating a new user, does that user need to confirm by email before that account can be used?

  3. ceo
    Member
    Posted 2 years ago #

    If you're blog is on WordPress.COM you are in the wrong place.

    Are you talking about a blog you moved off of WP.com to self-host? If so "admin" is the default user account created if you didn't set it to be something else. (Why can't you post with the admin account?) Or did you create a second account that is not granting you access?

    If you're having trouble getting WP to send you a password reset, you can go in through phpMyAdmin or the like and change things in the wp_users table.

  4. ceo
    Member
    Posted 2 years ago #

    When using WordPress.com and creating a new user, does that user need to confirm by email before that account can be used?

    To register with WordPress.COM, you have to validate your email yes. If you need support for a WordPress.COM account, you need to go here. This forum is for WordPress.ORG or self-hosted WP and doesn't provide support for the WP.com.

  5. belderiver
    Member
    Posted 2 years ago #

    Thanks for the responses guys, but problem resolved; Needed to manually set a password in the admin panel for the account, though I don't know why.

    (For the sake of more background/posterity: This is a validated wordpress.com account for a wordpress.org blog. I imported the account as an author to the blog along with several associated posts. I have done this with a few other blogs/accounts and never encountered a problem before, but this worked.)

Topic Closed

This topic has been closed to new replies.

About this Topic