WordPress.org

Ready to get started?Download WordPress

Forums

Can't log in after 2.8 upgrade (31 posts)

  1. splorpuk
    Member
    Posted 5 years ago #

    Hello all, I'm at the end of my tether with this one so any ideas much appreciated!

    I did a manual update from 2.7.1 to 2.8 this morning. After the install the main site works but when I try to log in with either of the two account with full adminsitrator access I get two different errors:

    1. Log in as Admin#1 - White Screen of Death, no error messages
    2. Log in as Admin#2 - I get "ERROR: Incorrect password. Lost your password?"

    In terms of solutions, I've tried the usual password reset stuff at http://codex.wordpress.org/Resetting_Your_Password and the WSOD solutions, including renaming the plugins folder, etc., but all to no avail.

    I'm running mySQL 5.0.45 through pair.com hosting and I've checked it in Firefox, IE and Chrome for good measure.

    Anyone have any ideas? Even just new things to try would be appreciated!

  2. splorpuk
    Member
    Posted 5 years ago #

    [Update] I've put the files up again and I'm getting the following message after logging in as either admin:

    Parse error: syntax error, unexpected T_LNUMBER in /usr/www/users/splorp/shoot/wp-includes/class-phpass.php on line 50

    As I recall, phpass.php is something to do with the log on and passwords. Not helpful, but at least it's progress of sorts.

  3. Ryan Paul
    Member
    Posted 5 years ago #

    I can't log in either - just did the auto upgrade, tried getting a new password sent to me and that doesn't work either.

    Someone help please?

  4. splorpuk
    Member
    Posted 5 years ago #

    @othellobloke - are you getting any errors messages, or just blank screen?

  5. compounder
    Member
    Posted 5 years ago #

    so im not the only one then. my site is down and it just has this error:

    Fatal error: Call to undefined method WordPress_Module::_weak_escape() in /home/frieders/public_html/wp-includes/wp-db.php on line 487

    also, cannot log in

  6. Ryan Paul
    Member
    Posted 5 years ago #

    My problem was the 'limit-login-attempts' plugin.

    I renamed the plugin install and created a new one via ftp and then I could login fine. So I enabled the plugins one one by one - I disabled that particular plugin and everything was cool.

  7. bh_WP_fan
    Member
    Posted 5 years ago #

    Try renaming the plugins folder again then do a manual update to 2.8 again, making sure to upload all of the files. Also try increasing your memory_limit.
    1. Increase the memory limit setting in php.ini (e.g. memory_limit = 64M ;). Many hosts may not allow this.
    2. Increase the memory limit via .htaccess (e.g. php_value memory_limit 64M). Many hosts may not allow this.
    3. Increase the memory limit via wp-config.php (e.g. define('WP_MEMORY_LIMIT', '64MB');)

  8. Carmen D
    Member
    Posted 5 years ago #

    I am having the same problem - cannot log in post 2.8 upgrade-when I try to log in I get this message:

    Fatal error: Call to undefined function: is_site_admin() in /home/.mollye/allaboutrace/allaboutrace.com/wp-content/plugins/sem-google-analytics-admin.php on line 20

    Any suggestions will be much appreciated. I am panicking. In advance, thank you

  9. bh_WP_fan
    Member
    Posted 5 years ago #

    google analytics is broken in WordPress 2.8. Deactivate that plugin by renaming it in your wp-content/plugins directory. If that doesn't fix it, rename the whole plugins directory.

  10. Carmen D
    Member
    Posted 5 years ago #

    Thanks bh. Renaming the directory worked. whew.

  11. simondelliott
    Member
    Posted 5 years ago #

    I have this problem, just upgraded to 2.8 i get WSOD on the site and the admin pages. I have also tried all the tricks, renaming plugins, altering the config file etc,,,
    the site is http://www.simondelliott.com/blog

    Any idea to try?

  12. jonahcoyote
    Member
    Posted 5 years ago #

    I noticed this same issue after updating a site running 2.7.1 to 2.8 I could not reach the admin at all unless I renamed the plugins folder. But, even after renaming it back it still didn't work. So I renamed it, then re-copied the 2.8 files and added the 'php_value memory_limit 64M' to the .htaccess (the host supports it) and this seemed to solve the issue.

    I hope this helps. Maybe this will be fixed in 2.8.1?

    - Jonah

  13. toddklein
    Member
    Posted 5 years ago #

    My problem is a little different but very annoying. I can log in to my admin page, but all the editing and posting links are gone! I just upgraded to 2.8, my site is on Lunarpages. Does anyone know a way to reinstall 2.7? At the moment I can't do anything with my blog, though it's still there. The only link that is still active is to Askimet spam, but that goes to "you do not have correct permissions to access this page". I've tried getting help from Lunarpages, and they duplicated my problem, but say it's not something they can do, I have to get help from WordPress. WordPress won't help since my site is not with them. Argh!

    Mentions of renaming the plugins folder: what do you rename it to? I can try to find that on my site using FTP.

    Thanks for any help!

  14. simondelliott
    Member
    Posted 5 years ago #

    @jonahcoyote thanks for the help, Unfortunately it has not fixed the issue that Im finding, Ive tried the php_value memory limit and its giving me a 500 so I guess that my ISP does not support it.
    Im going to try recreating the whole thing from the distro and seeing if it works.

  15. simondelliott
    Member
    Posted 5 years ago #

    Ive just tried installing 2.8.1 and no joy,

  16. theorist
    Member
    Posted 5 years ago #

    To bh_WP_fan: Does one need to try all three of those options, or just one? I changed the memory in my config.php file, but it didn't help. I get a white screen on my site and log-in page after upgrading.

  17. Robinoz
    Member
    Posted 5 years ago #

    My Admin Module won't work either. I get password errors. I've reset my password several times, but still no luck. Obviously the module that processes the passwords is stuffed.

    I'll try some of the solutions above and see what happens.

  18. exitstencil
    Member
    Posted 5 years ago #

    i can't login either. i get the "no input file specified" message. my provider won't help. i've even upgraded to WP 2.8.1 and still it doesn't work. i'm going mad with this!

  19. darielacruz
    Member
    Posted 5 years ago #

    I just installed 2.8 and it wont let me login either, it gives me the forgot your password? I press this and then it sends me a new password which I come back and use and it just brings me back to the same screen which says please login again. Please advice, what should I do?

  20. bh_WP_fan
    Member
    Posted 5 years ago #

    @theorist: All three don't need to be set at the same time, but if one doesn't work for you, the next should be tried, and then the next.

    @others: The first thing to try when you experience login problems or errors is to rename your plugins folder. It doesn't matter what you rename it to, just pick something other than plugins like pluginsbackup or something.

    If you have access to phpmyadmin through your host(which you should) then check the tables and repair them in case there is any corruption in them causing login problems. http://helpdesk.bluehost.com/kb/index.php/kb/article/000496

    If you still cannot login, update your password through the database, again using phpmyadmin. http://tamba2.org.uk/wordpress/phpmyadmin/

    If you are getting memory errors and none of the three memory changing methods work, contact your host to see what their value is set as and see if they can increase it for you.

  21. simondelliott
    Member
    Posted 5 years ago #

    Okay, Ive just tried the password reset and the database repair and I am still having the same issue. However I can get a vanilla 2.8 running on the same setup. If change the data base settings of the vanilla working application to the old upgraded datase then the vanilla application shows the same defect.
    It looks like a defect must have ocured during the upgrade.

  22. simondelliott
    Member
    Posted 5 years ago #

    I Fixed it !

    so I was reading through this thread and I noticed that there were some 2.8 upgrades that hang, due to code that is out of place in the theme.
    so I renamed the folder of the active theme.
    This got me into the admin screen.
    The admin screen told me that the upgrade was successful (yeah right) and that it now needed to upgrade the database, which all went fine.

    Thank you all for your help, getting this sorted.

  23. lone walker
    Member
    Posted 5 years ago #

    Hi all, been reading this thread with interest.
    Not sure if my issue is related as most of the folk here are talking about 2.8.1
    I recently updated to 2.7 and now get a white screen when I try to login to manage the site. The browser just sits there trying to load the page - but nothing ever happens.
    I did manage to login several times after the initial upgrade, so it's not like it never worked.
    I can still post new entries to the blog using other software of course, but I just can't get in to manage the site.
    I tried renaming the plugin folder but that hasn't worked. Are the solutions in this thread appropriate to my issue or should I be working from another set of potential fixes for this issue?

    Thanks
    LW

  24. lone walker
    Member
    Posted 5 years ago #

    An update to my issue ...

    It turns out that if I leave the login page running for long enough I do eventually get logged in - its just taking an exceedingly long time - probably over an hour.

    Once I login every action I take also takes an inordinate amount of time to complete - i.e. to edit a post.

    Reluctant to upgrade to 2.8 while this is still a problem in case that makes things worse.

    Any suggestions?

    Thanks
    LW

  25. bh_WP_fan
    Member
    Posted 5 years ago #

    Try increasing your memory_limit, changing your theme to the default theme, renaming your plugins folder, make sure you're running php5 and mysql5 as older versions of these can make WordPress run slow. (Do all of this at the same time, it won't do to rename your plugins folder, and then rename it back, then change your theme, etc., your theme should be default and your plugins should be renamed at the same time, etc.)

    Ways to increase your memory limit:
    1. Increase the memory limit setting in php.ini (e.g. memory_limit = 64M ;). Many hosts may not allow this.
    2. Increase the memory limit via .htaccess (e.g. php_value memory_limit 64M). Many hosts may not allow this.
    3. Increase the memory limit via wp-config.php (e.g. define('WP_MEMORY_LIMIT', '64MB');)

    If all of the above fails, contact your host.

  26. frazzledmama
    Member
    Posted 5 years ago #

    HELP! I upgraded to 2.8 today with the automatic upgrade plug-in. I've never had a problem before, but now I can't log in to my admin site. I have tried all of the suggestions here, changed my password, changed the plugin folder name, I even used php myadmin to make sure the password was set correctly. Right now, when I type in a wrong password, it will tell me it is wrong, but when I type in the correct PW it basically just reloads the page. HELP!

    http://www.thefrazzledmama.com

  27. frazzledmama
    Member
    Posted 5 years ago #

    Not knowing what else to do, I manually upgraded tonight, no dice. Anyone have any thoughts????

  28. splorpuk
    Member
    Posted 5 years ago #

    Finally worked out what my problem was - the FTP client (Filezilla) was messing up the transfer of class-phpass.php to my hosting provider even though it was set to auto-detect the method of uploading.

    I uploaded class-phpass.php using a different FTP client and it's all working now. A similar thing might work with these other problems above - worth a try I guess!

  29. leolucas
    Member
    Posted 5 years ago #

    I was able to login when I performed these steps:
    1. Attempted to login
    2. Changed the name of the themes folder to themes-rename
    3. Attempted to login again (got a white screen)
    4. Changed the name of the themes folder back to themes (the original name)
    5. Logged in successfully

  30. mharrisr
    Member
    Posted 5 years ago #

    Tried with all the sources above but still no luck, renamed themes and plugins folder, increasing memory limit though it does'nt work, any solution to solve this issue? if anyone can help on this I can give the blog login details to sort this out.

Topic Closed

This topic has been closed to new replies.

About this Topic