WordPress.org

Ready to get started?Download WordPress

Forums

Can't load index.php from site root after upgrade (28 posts)

  1. esasse
    Member
    Posted 9 years ago #

    I just upgraded my WP from 1.2 to 1.5 and now when I try to open my site using only the domain (www.ericksasse.com.br) I got a page not found error. But if I type http://www.ericksasse.com.br/index.php it opens, but if I click in a post title I got another page not found error.

    What's is wrong? I followed all the instructions to upgrade.

  2. Joshua Sigar
    Member
    Posted 9 years ago #

    If you haven't done it, run wp-admin/upgrade.php.
    If you have permalink set up, try to unset it and delete .htaccess.

  3. esasse
    Member
    Posted 9 years ago #

    I did run upgrade.php.
    I don't have permalink set up.
    I don't have .htaccess. My site is hosted in Windows and IIS.

  4. Kafkaesqui

    Posted 9 years ago #

    Same issue here:

    http://wordpress.org/support/topic.php?id=23962

    Not sure of a resolution as yet.

  5. esasse
    Member
    Posted 9 years ago #

    I hope someone finds a solution quickly, I don't want to downgrade to 1.2.

  6. Joshua Sigar
    Member
    Posted 9 years ago #

    Let's do this.
    Create a subdirectory of any name
    Create an index.php and put some random stuff
    Go to that subdirectory with your browser
    Is index.php loaded automatically?

  7. esasse
    Member
    Posted 9 years ago #

    Yes, it is.
    Just like it was in WP 1.2.

  8. Kafkaesqui

    Posted 9 years ago #

    Actually, going to http://www.ericksasse.com.br/ duplicates what you're asking for alphaoide.

    This may sound a little strange esasse, but could you grab the index.php file sitting in your root directory, and place <html> </html> tags around the entire content of it. Just a hunch...

  9. esasse
    Member
    Posted 9 years ago #

    Take a look! Now I got a different error, but the site is partially loaded. http://www.ericksasse.com.br

  10. Joshua Sigar
    Member
    Posted 9 years ago #

    Backup/rename the current index.php in root
    Put custom index.php in root
    Is the custom index.php loaded automatically?

  11. esasse
    Member
    Posted 9 years ago #

    If I type http://www.ericksasse.com.br/index.php the posts are shown.

  12. esasse
    Member
    Posted 9 years ago #

    Now my index.php is like this:

    <html>
    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>
    </html>

  13. Nick Momrik
    Member
    Posted 9 years ago #

    esasse,
    For some reason, most of the links on your site are missing the index.php in them. The category links have them though. When you upgraded, did you delete all of the files on your site and upload all of the new ones?

  14. esasse
    Member
    Posted 9 years ago #

    I moved all my old files to another dir. It is enough, isn't it?

  15. Kafkaesqui

    Posted 9 years ago #

    Hmm.

    I'm trying to duplicate this from my IIS machine, but can only do so under a very specific circumstance (meaning not in WordPress, I don't see the problem from the root of the site as you do, and have no issue with query-strings not run off index.php).

    A couple more things to try:

    1. Run wp-admin/upgrade.php again. There's an issue (a thread for which I presently can't locate) related to a missing setting (html_type) this helps solve. Perhaps there's a relationship here.

    2. Instead of placing the <html> tags in the index.php of your root, you could try removing them from header.php and footer.php of your theme, and adding them to the theme's index.php.

    Again, just going on hunches.

  16. Kafkaesqui

    Posted 9 years ago #

    MtDewVirus: See this for more on the index.php issue:

    http://wordpress.org/support/topic.php?id=23962

  17. esasse
    Member
    Posted 9 years ago #

    Kafkaesqui,

    1. Did several times before, didn't work.

    2. Did it now, didn't work.

  18. Joshua Sigar
    Member
    Posted 9 years ago #

    Hmm, what MtDewVirus pointed out is reasonable. On your site, Archives by month links show no index.php, while Categories links with index.php.
    On mine, I got no index.php for both.

    When dealing with corrupted files, people would re-download WP package, someone would also download the .tar.gz instead to replace the old one. Have you done it?

    I still have one suspicion, but I need some time to refine it.

  19. esasse
    Member
    Posted 9 years ago #

    I've just downloaded the .tar.gz and replaced all files. Didn't work. The same problem.

    Any new ideas? :)

  20. esasse
    Member
    Posted 9 years ago #

    Well, unfortunately I had to return to 1.2 until a solution to this problem is found. :(

  21. rotello
    Member
    Posted 9 years ago #

    Same problem here:
    http://www.genkisound.com/public/blog

    Problem per se is not a major one ( just a bit annoying..)
    real problem is: during a peak of intelligence i changed the uri to
    http://www.genkisound.com/public/blog/index.php ...
    now not only the page need index.php at the end, but lost the gfx ( of coz..)
    and DO CANNOT log in :-/ ( coz url is bad...)
    arg! how can i solve the Second problem... while wrting this i m thinking some workaround (moving files here there, up n down...) but i guess that it would be easier if i kan locate the config and change it... ( no, it s not in the wp-confing...)

    ciao

    rt

  22. Sherman
    Member
    Posted 9 years ago #

    I had the same problem, but it took a back seat to another issue - when I clicked on the comment or category links on my blog page, I got a 404. If I manually inserted "index.php" before the query on the address bar every thing worked fine. Both problems were solved by editing the wp-blog-header.php. See http://wordpress.org/support/topic.php?id=24032#post-138984.

  23. esasse
    Member
    Posted 9 years ago #

    Thanks!!! Now everything is fine and I could upgrade to 1.5!! :)

  24. misfit
    Member
    Posted 9 years ago #

    i was having a similar problem. with 1.2, i had my wordpress files at
    http://www.mydomain.com/wordpress/

    but my blog is located at
    http://www.mydomain.com

    with 1.2, i forget what i did, but it involved setting index.php at my root level, rather than in the wordpress folder, and that worked fine.

    i uploaded to 1.5 today (completely clean, deleted all but my wp-config.php), and found that simply moving index.php to the root of my site wouldn't work.

    my solution, after half an hour of tweaking, was to move wp-blog-header.php to the root of my site as well, and then to open up wp-blog-header.php and (i'm sorry i can't be more specific, i was doing this while my landlord kept knocking on my door harassing me) where it pointed to the wp-config.php file, i modified the path link, so that it read "wordpress/wp-config.php". i'm sorry, again, i can't tell you specifically where, but i know it was just 2 instances, and near the top.

    so now when i pull up, "www.mydomain.com", my blog is there, and it appears that my category links are working correctly. hope this can help some people, and sorry if this particular solution has been repeated elsewhere.

  25. DigitalArchivist
    Member
    Posted 9 years ago #

    Some of this information pertains to an issue I reported regarding Mozilla Firefox displaying blank pages. My IE 5.x browser at work won't display my blog, but my IE 6.x browser at home will (intermittently). I will likely do a new install of 1.5 and see what happens, as that seems the only sensible course at this point, but it sounds as though the new theme-based 1.5 system is breaking sites left and right.

  26. rotello
    Member
    Posted 9 years ago #

    sorry to post again... can someone tell me how to go out from the swamp i create by screwing the URi??
    i kant log in now!!!
    page is visible
    http://www.genkisound.com/public/blog/index2.php

    or ( after i copied the dir in a sub folder...)
    http://www.genkisound.com/public/blog/index.php/index.php

    what file should i change in mysql?

  27. DigitalArchivist
    Member
    Posted 9 years ago #

    I discovered that my problem with Firefox throwing up blank pages was caused by two plugins written by Nick Momrik: moderate pingbacks and moderate trackbacks. Didn't matter which was active, either or both would cause Firefox to display a blank page. I left him a note on his site.

  28. DigitalArchivist
    Member
    Posted 9 years ago #

    Nick Momrik came through with a prompt and easy fix that's now solved my problem with Firefox displaying blank pages. Thanks Nick!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.