WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't Link Properly (7 posts)

  1. Terry
    Member
    Posted 7 years ago #

    Hi there, sorry if I sound really dumb. I've been using WordPress 2 for quite some time, but today is the first time I need to add a link with an address containing a hash (#) in it, i.e. http://www.yourblog.com/p?=999#pic1

    As I add the hyperlink and update the post, the address is automatically changed into "#pic1" instead of "http://www.yourblog.com/p?=999#pic1".

    Any help will be greatly appreciated. Thanks!

  2. Samuel B
    moderator
    Posted 7 years ago #

    Turn off the wysiwyg editor and do it again in edit. Should work fine now.

  3. Terry
    Member
    Posted 7 years ago #

    Sorry again, but I am really new at this. Since I've been overdependent on WYSIWYG editor,I don't know how can I turn it off.

  4. Samuel B
    moderator
    Posted 7 years ago #

    admin -> users -> scroll to bottom left.
    Also, make sure box is unchecked for:
    "WordPress should correct invalidly nested XHTML automatically"
    admin -> options -> writing

  5. Terry
    Member
    Posted 7 years ago #

    Thanks a lot samboll! You're always a helpful person =) Managed to correct the error, thanks!

    P.S. Is it possible for me to edit the Tiny MCE script so that it doesn't aoutomatically remove the characters prevailing the "#" sign in the URL?

  6. Samuel B
    moderator
    Posted 7 years ago #

    I'm sure there is - never had to do it myself. Maybe Kaf or Moshu can jump in here?

  7. Terry
    Member
    Posted 7 years ago #

    Thanks for your help, samboll. I think I'll just stick with non-WYSIWYG wordpress XD

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.