WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
[resolved] Can't link my Facebook account with my WordPress account (26 posts)

  1. liam
    Member
    Posted 2 years ago #

    Hi everyone,

    After installing the plugin I have been stopped in my tracks by an unspecified error Facebook's part.

    After I enter the app information, and set it up as specified, I click on "Link your Facebook account to your WordPress account to enable." It brings up a Facebook screen that says "An error occurred. Please try again later."

    I have tried:
    1. Waiting a few hours.
    2. Deleting the plug-in and reinstalling.
    3. Deactivating all other plugins that use Facebook.
    4. Creating a new app (the one I'd prefer to use is from another plugin).

    None of it has worked. The app won't let me proceed without going through this step (for obvious reasons!) but I can't get past a roadblock!

    Any help you can give is appreciated.

    Thanks,

    Liam.

    http://wordpress.org/extend/plugins/facebook/

  2. Jedge
    Member
    Posted 2 years ago #

    I'm having similar trouble

  3. designrf
    Member
    Posted 2 years ago #

    Hi There,

    I'm having the same issue!

    Any thought?

  4. frankstratmann
    Member
    Posted 2 years ago #

    I recognized the following coder in the file facebook/fb-login.php

    Shouldn´t it be a correct URL to match facebook with my wordpress installation?

    else {
    			fb_admin_dialog( __('Facebook social publishing is enabled. <a href="#" onclick="authFacebook(); return false;">Link your Facebook account to your WordPress account</a> to get full functionality, including adding new Posts to your Timeline.', 'facebook' ), true);

    I can´t connect/link my account to facebook. Does anybody have a idea?

  5. jenstorell
    Member
    Posted 2 years ago #

    Same problem here and have tried all the same steps as the original poster.

    I used the Wordbooker plugin in the past and first tried using the same Facebook app to link to this Facebook plugin. When that didn't work, I got rid of Wordbooker and started with a fresh version of the Facebook plugin as well as a fresh app on Facebook.

  6. chemoul
    Member
    Posted 2 years ago #

    When I click the "Link your Facebook account to your WordPress account to enable" link nothing happens, it just seems to link to the top of the Facebook plugin page in WordPress.

  7. mattkelly
    Member
    Posted 2 years ago #

    liam, what's your app id?

  8. liam
    Member
    Posted 2 years ago #

    Mine's started working after I updated to WordPress 3.4. Or maybe it was just the need to leave it overnight. Very weird.

    It doesn't post in the best of formats -- just the link, without any accompanying image or message. I think I just need to play around with it a little and/or wait for a future release...

    Has anyone else's started working?

    L.

  9. liam
    Member
    Posted 2 years ago #

    Hi Matt, thanks for taking the time. It's 375798112477787.

    When publishing to a page is it supposed to just add the title and nothing more? It seems very limited (though perfectly acceptable for a 1.0 release! :)) in its function...

    L.

  10. jenstorell
    Member
    Posted 2 years ago #

    My installation has also started to sort of work after upgrading WordPress to 3.4. It would not allow me to link to Facebook with version 3.1.3.

    Now I have new problems. WordPress seems to think my account is linked to Facebook, but it disables the option to auto-post to timeline whenever I try to create a new post.

  11. infoxicated
    Member
    Posted 2 years ago #

    I had the same problem this morning. Despite being on WordPress 3.4, when I clicked on the URL to link the two accounts it would not work.

    Out of curiosity I logged into my dashboard using IE instead of Chrome and it turned out that Chrome had been blocking the authorisation pop-up that appeared when I clicked the link in IE.

    Hope that helps some people. :)

  12. k8khz
    Member
    Posted 2 years ago #

    I am having the same issue to where as it believes that the APP ID is not found still. I am not sure. I have a Mac so I am using Safari and Safari and Chrome are very similar in the way they perform verse Explorer.

    Sean
    http://www.seandfleming.com
    http://www.barringtonstreetpodcast.com

  13. k8khz
    Member
    Posted 2 years ago #

    well I give up. I have made 3 apps reinstalled the plug in and it is still broken.

    API Error Code: 191
    API Error Description: The specified URL is not owned by the application
    Error Message: Invalid redirect_uri: Given URL is not allowed by the Application configuration.

  14. miketheblogger
    Member
    Posted 2 years ago #

    Mine does not work either when I try to link them I get this

    API Error Code: 191
    API Error Description: The specified URL is not owned by the application
    Error Message: Invalid redirect_uri: Given URL is not allowed by the Application configuration.

    My site is http://crosscampusministry.com

    Please help

  15. miketheblogger
    Member
    Posted 2 years ago #

    I got mine working. I took the app url out completely. Also I changed my url from crosscampusministry.com to videobible.powweb.com since that is the actual url for the pages within my site

  16. k8khz
    Member
    Posted 2 years ago #

    how do I find my apps url?

  17. Burnt Offering
    Member
    Posted 2 years ago #

    Been fighting with this for two days now. I have installed it and unistalled it 3-4 times. The WordPress app shows up fine in my FaceBook/Account Settings/apps. I have tried every setting in the book. No joy. For the love of God I cannot get this to post to my FaceBook Page. Anyone had any luck getting this to work......at all?

  18. krowland08
    Member
    Posted 2 years ago #

    Same problem here.... Go through all the hoops, still can't get that first post on my timeline. You're not alone. if I find the trick, I'll certainly post my results. Anyone else who finally got it working, please post your solutions.

  19. Burnt Offering
    Member
    Posted 2 years ago #

    OK Everyone. I have a ground breaking discovery. I am ecstatic.I got it working! I have found the solution at least for me. First let me say that if the soltion that I came up with was a "I should have known" issue, then so be it. The point I am going to make here is I think this is a problem that a LOT of people will be able to fix. OK, here goes.
    The mistake I was making was I was trying to post to my FaceBook Timeline frm an EXISTING POST. You cannot do this! What do I mean? My Theme came with several existing posts in the blog area. This is a brand new website and I hadn't cleared them out yet I kept trying to post from there as I saw my FaceBook comment box. Nothing would happen. Here's what you do. Delete ALL EXISTING POSTS if your theme is new and has the stock ones. Do the same with yor "Categories". Create a new category and a BRAND NEW POST. When you do this all of the FaceBook plugin info will be dangling right there in front of you. I tested this with 3 different NEW POSTS and it showed up briliantly in a WordPress dialoge box on my FaceBook timeline. Good Luck!

    Kevo

  20. krowland08
    Member
    Posted 2 years ago #

    I have been creating NEW posts. A ton of them, none will post. I'm not deleting all my posts in my blog. That should NOT be a requirement.

    But yes, EDITING an existing post doesn't even give you the Facebook comments entry blank on the EDIT post screen, it only shows up when creating a NEW post....

    ....so I don't understand what you really did to fix the problem, looks like you never had a problem. You just figured out how it's supposed to work.

    Congratulations in getting yours to work.

  21. Burnt Offering
    Member
    Posted 2 years ago #

    Sorry krowland, I was referring to people with a new theme. I didn't actally mean for people to delete hundreds of posts. Again, I stress only for a new theme. I had zero of my own existing posts.

  22. Matt Kelly (Facebook)
    Member
    Plugin Contributor

    Posted 2 years ago #

    liam, it sounds like your original issue of not being able to connect accounts has been resolved.

    For any other issues, please open new support threads. Thanks

  23. liam
    Member
    Posted 2 years ago #

    It has. Thanks very much Matt.

  24. Thallios
    Member
    Posted 2 years ago #

    When I click the link to link my facebook account to my wordpress account, nothing happens at all.

    App ID: 414495301921765
    Namespace: the-auditorium-blog

    Using the most updated version of WordPress.

  25. Matt Kelly (Facebook)
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Thallios and others, please open a new thread up. @liam's issue, the original issue, has been resolved. Thanks

  26. Laurie B
    Member
    Posted 1 year ago #

    I blog and recently hooked up my wordpress site to my personal FB page. I had no problems linking my posts to my FB page. Today I decided to create an actual page for my blog. I thought I had covered changing all the correct URL configurations for having it hook to my new FB page, but I continue to get an error code-32700. I have tried several different ways to get this to work, but I do not understand code. Any help would be GREATLY appreciated!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic