WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't keep line breaks in scroll box (4 posts)

  1. TravisBickle17
    Member
    Posted 6 years ago #

    Hi,

    I've searched high and low with all kinds of different word combinations, but I can't find a solution.

    Here's my problem. I'm using a scroll box to contain my blog posts after the jump from the main page. Here's the code I'm using for the scrollbox:

    <p style="padding: 5px; overflow: auto; width: 400px; height: 300px">Blog post content here</p>

    The issue is - if I try to enter a line break between lines of text or pictures inside of the scroll box - either by manually entering
    </br> OR by hitting shift+enter - when the post is submitted, ALL the text that follows the first line break is knocked out of the scroll box. So code that is entered like this:

    <p style="padding: 5px; overflow: auto; width: 400px; height: 300px">(picture here) texttexttext texttexttexttexttexttexttexttexttext texttexttext.
    </br>
    (picture here) texttexttext texttexttexttexttexttexttexttexttext texttexttext.

    </br>
    (picture here) texttexttext texttexttexttexttexttexttexttexttext texttexttext.</p>

    Comes out like this:

    (INSIDE SCROLL BOX)(picture here) texttexttext texttexttexttexttexttexttexttexttext texttexttext.
    (SCROLL BOX ENDS)
    (picture here) texttexttext texttexttexttexttexttexttexttexttext texttexttext.

    (picture here) texttexttext texttexttexttexttexttexttexttexttext texttexttext.

    (picture here) texttexttext texttexttexttexttexttexttexttexttext texttexttext.

    So - I can't get the line breaks to stick from my post entry page to the finished product. The line breaks work fine OUTSIDE the scroll box - but for whatever reason, the first time that line break INSIDE the box shows up - everything else is knocked outside of the box.

    Does that make sense?

    I would greatly, greatly appreciate it if anyone can tell me how to fix this. Thanks!

  2. whistler2020
    Member
    Posted 6 years ago #

    only thing to fix it is turn off the visual editor in your user profile and code your html tags yourself.

  3. TravisBickle17
    Member
    Posted 6 years ago #

    I always code on my own - I never use the Visual Editor, but never bothered to turn it off... I turned it off as you said - and everything works great!!!

    I don't understand why that happens since I don't actually do anything at all with the visual editor - but whatever, it worked!

    Whistler202 - You have NO IDEA how much help you just were to me... I've spent countless hours testing, guessing/checking, and searching the web for answers.

    THANK you. A thousand times thank you. :)

    -TB17

  4. whistler2020
    Member
    Posted 6 years ago #

    visual editors are ebil

Topic Closed

This topic has been closed to new replies.

About this Topic