WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't install plug-ins or themes after upgrading to 3.0.1 (8 posts)

  1. chrisrouse
    Member
    Posted 3 years ago #

    Finally got my blog to upgrade to 3.0.1 from the last release of 2.x. It was quite the challenge this time for some reason. I'm on 1&1 and 1-Click upgrade has never worked, so I always have to manually upgrade.

    I installed everything one thing at a time and it worked fine. Then I logged out, came back and my dashboard was all messed up, so I uninstalled all my themes and plug-ins and figured I'd just install them all fresh. Except I can't get anything to actually download and install automatically. Downloads start, but only get as far as telling me it's downloading. It never gets any further than that now.

    I had that problem with my 2.x installation on some plug-ins and themes in the past, but this is on every plug-in and theme. Is there something I'm missing? I'm disappointed that WP has been such a challenge for me this time. I'm used to having some issues when I upgrade (I partially blame 1&1), but this has been the most painful experience so far.

    Sorry in advance if I missed a related thread. I did some searching on this but couldn't dig anything up. Thanks for any help.

  2. Jason
    Member
    Posted 3 years ago #

    It sounds like something is still in the database even after you disabled the plugins and themes that is causing some issues.

    I think what I would do is start from a fresh install again, create a backup of the working WP install and start getting things installed and tested one by one. There is obviously some plugin or theme that is failing so if you have to track down the "needle in the hay stack" then it may require you to create many backups in between plugins while you test the ability to login and logout of the admin after the installs

    Doing it this way may take a bit more time but will save you when/if it fails again and you have to restore.

    Good luck

  3. Add this to the top of your .htaccess file:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
  4. hammertime79
    Member
    Posted 3 years ago #

    James

    What does that do?

    I was having a similar problem to the orignal poster and tried your fix.

    However now when I click to go to the plugin page I get this.

    ID, 'plugins_last_view', $status); $page = isset($_REQUEST['paged']) ? $_REQUEST['paged'] : 1; //Clean up request URI from temporary args for screen options/paging uri's to work as expected. $_SERVER['REQUEST_URI'] = remove_query_arg(array('error', 'deleted', 'activate', 'activate-multi', 'deactivate', 'deactivate-multi', '_error_nonce'), $_SERVER['REQUEST_URI']); if ( !empty($action) ) { $network_wide = false; if ( ( isset( $_GET['networkwide'] ) || 'network-activate-selected' == $action ) && is_multisite() && current_user_can( 'manage_network_plugins' ) ) $network_wide = true; switch ( $action ) { case 'activate': if ( ! current_user_can('activate_plugins') ) wp_die(__('You do not have sufficient permissions to activate plugins for this site.')); check_admin_referer('activate-plugin_' . $plugin); $result = activate_plugin($plugin, 'plugins.php?error=true&plugin=' . $plugin, $network_wide); if ( is_wp_error( $result ) ) { if ( 'unexpected_output' == $result->get_error_code() ) { $redirect = 'plugins.php?error=true&charsout=' . strlen($result->get_error_data()) . '&plugin=' . $plugin; wp_redirect(add_query_arg('_error_nonce', wp_create_nonce('plugin-activation-error_' . $plugin), $redirect)); exit; } else { wp_die($result); } } $recent = (array)get_option('recently_activated'); if ( isset($recent[ $plugin ]) ) { unset($recent[ $plugin ]); update_option('recently_activated', $recent); } if ( isset($_GET['from']) && 'import' == $_GET['from'] ) { wp_redirect("import.php?import=" . str_replace('-importer', '', dirname($plugin)) ); // overrides the ?error=true one above and redirects to the Imports page, striping the -importer suffix } else { wp_redirect("plugins.php?activate=true&plugin_status=$status&paged=$page"); // overrides the ?error=true one above } exit; break; case 'activate-selected': case 'network-activate-selected': if ( ! current_user_can('activate_plugins') ) wp_die(__('You do not have sufficient permissions to activate plugins for this site.')); check_admin_referer('bulk-manage-plugins'); $plugins = isset( $_POST['checked'] ) ? (array) $_POST['checked'] : array(); $plugins = array_filter($plugins, create_function('$plugin', 'return !is_plugin_active($plugin);') ); // Only activate plugins which are not already active. if ( empty($plugins) ) { wp_redirect("plugins.php?plugin_status=$status&paged=$page"); exit; } activate_plugins($plugins, 'plugins.php?error=true', $network_wide); $recent = (array)get_option('recently_activated'); foreach ( $plugins as $plugin => $time) if ( isset($recent[ $plugin ]) ) unset($recent[ $plugin ]); update_option('recently_activated', $recent); wp_redirect("plugins.php?activate-multi=true&plugin_status=$status&paged=$page"); exit; break; case 'update-selected' : check_admin_referer( 'bulk-manage-plugins' ); if ( isset( $_GET['plugins'] ) ) $plugins = explode( ',', $_GET['plugins'] ); elseif ( isset( $_POST['checked'] ) ) $plugins = (array) $_POST['checked']; else $plugins = array(); $title = __( 'Upgrade Plugins' ); $parent_file = 'plugins.php'; require_once( './admin-header.php' ); echo '
    '; screen_icon(); echo '
    ' . esc_html( $title ) . '
    '; $url = 'update.php?action=update-selected&plugins=' . urlencode( join(',', $plugins) ); $url = wp_nonce_url($url, 'bulk-update-plugins'); echo "

    How do I undo whatever your suggested fix did?

  5. rperrotta
    Member
    Posted 3 years ago #

    I get the same big chunk of code after adding the code to my .htaccess to force 1and1 to use php5. It lasts for about six seconds and then the plugins page loads... but with a notice at the top saying "plugin deactivated."

    Not a total dealbreaker, but annoying. How do I make this go away?

  6. The code, per 1&1's support department, is supposed to enable PHP 5 on your 1&1 hosting account. Of course, it may not properly depending on how your hosting provider has PHP configured. To undo it, just remove the code.

  7. chrisrouse
    Member
    Posted 3 years ago #

    James,
    Thanks for the input. I finally had time tonight to work on my installation again to straighten things out. I think one problem I was having was that the .htaccess file wasn't being generated for some reason. I copied the file from my previous installation and added the lines of code you recommended to force 1&1 to use PHP 5 and it works great now. I installed a handful of themes and plug-ins to test everything out and it works better than ever.

  8. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic