WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't install ANY themes! (9 posts)

  1. doncobb
    Member
    Posted 1 year ago #

    I logged onto my site at http://www.doncobb.com and it tells me "ERROR: The themes directory is either empty or doesn’t exist. Please check your installation." I've tried deleting (through FTP) my existing theme folders and then reinstalling the themes I use and everyone is a failed install. I tried installing WP's twentytwelve theme and a couple other WP themes, they fail too. My page is a white blank page now! Hello! Can anyone help me with this? Thank you!

    Don

  2. ClaytonJames
    Member
    Posted 1 year ago #

    "ERROR: The themes directory is either empty or doesn’t exist.

    It might be helpful if you could tell us if you have recently attempted to change any permissions on any directories, or if you've recently installed any type of security related, or user upload type of plugins, because I'm getting at 403 "access forbidden" error on your /wp-content directory.

  3. doncobb
    Member
    Posted 1 year ago #

    I did delete the wp-symposium folder via FTP this afternoon and uploaded a new wp-symposium folder after upgrading to Bronze. But that had nothing to do with my themes, did it? Thanks.

  4. doncobb
    Member
    Posted 1 year ago #

    I wonder if I should try copying a theme folder from another of my sites hosted on WP. Do you think that might work? I have twentyten and twentyeleven and twentytwelve folders in the wp-content folder, but I am not able to install any themes at all, nor can I switch to one of those themes successfully. It tells me "You only have one theme installed now. Live a little! You can choose from over 1,000 free themes in the WordPress.org Theme Directory at any time: just click on the Install Themes tab above." I even tried to modify twentytwelve, the only theme it's showing. But I can't do anything in there.

    Also, I WAS able to modify/customize the tagline, and save the change. But still, blank white page is all that's showing. I had hoped that making some small customization would put twentytwelve back to working. It didn't. Thanks.

  5. ClaytonJames
    Member
    Posted 1 year ago #

    I did delete the wp-symposium folder via FTP this afternoon and uploaded a new wp-symposium folder after upgrading to Bronze.

    I have no experience with those items.

    The current issue appears to be - like I mentioned - your /wp-content is returning a 403 error - "access forbidden". That means everything inside of /wp-content (/themes, /plugins, /uploads) cannot be accessed by a web browser. Regardless of the reason why it may have happened, you need to inspect the /wp-content directory ownership and permissions, as well as the .htaccess file in your root directory, and any others that might reside elsewhere (/wp-content?) to make sure access hasn't been restricted for some reason.

    [edit]

    I wonder if I should try copying a theme folder from another of my sites hosted on WP. Do you think that might work?

    I do not think that will work.

  6. doncobb
    Member
    Posted 1 year ago #

    Who would restrict my access? I own the domains and I pay for server space on Godaddy for all my sites. Who do you think might have the ability to restrict my access? I'll call Godaddy now. Thank you.

  7. ClaytonJames
    Member
    Posted 1 year ago #

    I think it's most often a simple case of accidental user error, or an unanticipated by-product of a plugin installation.

  8. doncobb
    Member
    Posted 1 year ago #

    Resolved. I can't tell you what happened. I followed the Symposium folks instructions specifically today, deleting one folder via FTP and then replacing it. Somehow, other folders which aren't even CLOSE to where I was working, got deleted. All I deleted was the one folder that I replaced with Symposium's new folder. No one can explain it, but I'm back online and all is well in my world again. Thank you for your time, Clayton. :-)

  9. ClaytonJames
    Member
    Posted 1 year ago #

    You're welcome. Glad you got it sorted out.

Topic Closed

This topic has been closed to new replies.

About this Topic