WordPress.org

Ready to get started?Download WordPress

Forums

Can't install a theme into my wordpress site (5 posts)

  1. Alwyn Smith
    Member
    Posted 3 years ago #

    When i try to install a theme into my WordPress site i get,

    "Downloading install package from http://wordpress.org/extend/themes/download/evolve.1.2.2.zip…

    Unpacking the package…

    Could not create directory. /home7/curediab/public_html/wp-content/upgrade/evolve.tmp/evolve"

    It was suggested by another poster that i try adding an "upgrade" folder into wp-content, which i have done but to no avail. I also contacted my web hosting Co. and they said all permissions look fine etc and they said that normally adding folders is not necessary. I have changed my "table prefix" for security reasons and other modifications in compliance with what "WP Security Scan" told me. I have 4 active plug ins : Ask Apache Password Protect, BackupWordpress, Jetpack by WordPress and WP Security Scan.

    Thanks, Alwyn

  2. futurepocket
    Member
    Posted 3 years ago #

    Try recreating the "upgrade" folder in the wp-content's folder and setting the permissions to 777. If it still doesn't work, you will have to manually install the theme -- which is probably best because I find WordPress's auto-install/upgrade module very buggy. Just download the theme, extract it and upload it to your wp-content/themes folder.

  3. Alwyn Smith
    Member
    Posted 3 years ago #

    Hi futurepocket, thanks for helping me. After doing..."Just download the theme, extract it and upload it to your wp-content/themes folder" then what ? I can see the theme in the folder but how do i get it from filezilla into my wordpress dashboard ? thanks, alwyn

  4. Alwyn Smith
    Member
    Posted 3 years ago #

    I have done your latter suggestion but it is not available in my dashboard. I unzipped it on my computer then uploaded it to wp-content/themes but it does not show up on my dashboard. WTH ?

  5. Alwyn Smith
    Member
    Posted 3 years ago #

    Ooops ! At last i figured it out ! At first I changed the permissions to 777, as you said and tried the auto-install but wham, it didn't work so I then tried your 2nd suggestion and still stucksville. The oops action was using...in filezilla...the upload to.../wp-content/themes and not.../public_html/wp-content/themes. So bingo that was the problem...steep learning curve but I'm gettin' there rapidly !

    It seems the auto-install aint good and I can't even update to the latest wordpress but that's for another day.

    Thanks again for your help, futurepocket.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags