WordPress.org

Ready to get started?Download WordPress

Forums

Can't insert Youtube on Home Page but appears in post (5 posts)

  1. dakudo
    Member
    Posted 3 years ago #

    Hi,

    I'm trying to embed a Youtube video in a post on my homepage. Neither does the link work, underneath 'Click here'. However - it doesn't show on the homepage, but it shows up when you click the link for the article.

    My homepage is http://getyourloverback.com. The article in question is at the very top - Try This 'Opening Move' To Get Your Ex Back...

    If you click on the link to the article on the homepage, then the video and external link appearin the full post:

    So why don't the video and link work on the homepage?????

    Can somebody PLEASE help?

    Thank you.

  2. Ryan Paul
    Member
    Posted 3 years ago #

    This is because you're using the_excerpt(); on the front page which strips all html tags out.

    If you stop using that then your video will show.

  3. dakudo
    Member
    Posted 3 years ago #

    Cool. How do I disable _excerpt();?

    Thanks.

  4. dominoeffect
    Member
    Posted 3 years ago #

    Cool. How do I disable _excerpt();?

    Thanks.

    Open up the theme file index.php in a text editor, do a search for the_excerpt, and change it to the_content. That should sort it out.

  5. dakudo
    Member
    Posted 3 years ago #

    Thanks a lot. Will that alter the other posts on the home page, though? I want to leave them as they are.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags