WordPress.org

Ready to get started?Download WordPress

Forums

Can't insert picture in post with 2.5 (87 posts)

  1. rad_thundercat
    Member
    Posted 6 years ago #

    Ok, finally got it working. What did it was emptying out "/wp-content/uploads/js_cache" and uploading a fresh image to the Gallery.

    So here is everything I did:
    -Glitzfisch's code fix
    -upgraded to the latest flash
    -disabled all plugins (although it works now with the plugins enabled)
    -cleared any files out of "/wp-content/uploads/js_cache"
    -cleared the cache out of firefox, closed the program, rinse and repeat.
    -delete images already uploaded to the gallery and upload new ones.

    Hopefully others get it working!

  2. andysapp
    Member
    Posted 6 years ago #

    I'm getting a similar error that reads:
    "You don't have permission to access /wp-admin/media-upload.php on this server."

    I can upload images fine, and see them in the media dialog... but when I click "Insert into Post"... I get hit with that error ^^.

    I uploaded 8 images earlier this morning... but have not changed anything. I don't understand why it would turn belly-up and not work.

  3. KathEats
    Member
    Posted 6 years ago #

    I'm having the same problem with 2.5.1. When I push "insert image" it's just a blank box and when I close out there's no photo in my post.

    -Tried all browsers, diff. computers, different admin users.

    -Tried no tabs in FF.

    -Tried editing the Media.php.

    -Tried updating flash.

    -Tried deleting URL.

    I am getting the error:

    Error: uncaught exception: Permission denied to get property Window.send_to_editor

    Lastly, I did notice that when I close out of the Media box that the cursor is in the post title box, even though I was typing in the main box. Could that be related??

    Thanks for any help!

  4. andysapp
    Member
    Posted 6 years ago #

    This is so frustrating.

  5. nekro13
    Member
    Posted 6 years ago #

    I'm having the same problem!!!

    I needed to add an image ASAP, luckily I had FLOCK (browser) installed and it worked fine there. I was able to insert the image without a problem.

    Hopefully there would be a reliable solution pretty soon.

    Thanks

  6. crystallinetulip
    Member
    Posted 6 years ago #

    Check out this guy's fix. It worked BEAUTIFULLY for me! Hopefully it will work for you.

  7. Josh Leuze
    Member
    Posted 6 years ago #

    I'm having the same problem with 2.5.1. When I push "insert image" it's just a blank box and when I close out there's no photo in my post.

    KathEats, your problem sounds similar to my problem. My uploaded files are all ending up in the wp-admin folder.

    You should check in there to see if you are having the same problem. There is a work-around, but it doesn't fix anything.

  8. bricksmith
    Member
    Posted 6 years ago #

    After tinkering with various fixes for several days, I ended up reinstalling everything and rebuilding the site. Everything seems to be working now.

    This isn't a great option for some, but it did work in my case since this site was in the set up and test phase and was not yet active.

  9. qwik3r
    Member
    Posted 6 years ago #

    i love open source software don't you? Even though they have over 1 million in the bank they can't fix stupid shit like this? Anyone have a damn solution for this? I get a 404 in the stupid popup window when trying to insert an image.

  10. flatcat
    Member
    Posted 6 years ago #

    For the blank media gallery when inserting images into posts, it appears to be an issue of treating http://www.mydomainname.com different than http://mydomainname.com.

    More info here: http://wordpress.org/support/topic/177108?replies=12#post-780961

  11. CyberWoolf
    Member
    Posted 6 years ago #

    I had a problem with this. When I did a search on the web for the JS error it was throwing, it turned out that it's because I am using the FCK editor. I found people were having similar issues with FCK (non wp).

    Error: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMNSHTMLTextAreaElement.selectionStart]
    wp-includes/js/quicktags.js?ver=3958
    Line: 349

    The htaccess trick worked for the html error part, but now it won't insert the image in to the post unless I disable FCK.

  12. rustyone
    Member
    Posted 6 years ago #

    For those having issues with inserting pictures in Posts this basic javascript tweak may help:-

    The window box goes blank/white as it seems unable to reference the parent window object. So:-

    1) Open the file wp-admin/js/media-upload.js in a text editor

    2) Comment out line 4 so you end up with:-

    // send html to the post editor
    function send_to_editor(h) {
    	var win = window.opener ? window.opener : window.dialogArguments;
    	// hide this line if ( !win )
    		win = top;
    	tinyMCE = win.tinyMCE;
    	if ( typeof tinyMCE != 'undefined' && ( ed = tinyMCE.getInstanceById('content') ) && !ed.isHidden() ) {
    		tinyMCE.selectedInstance.getWin().focus();
    		tinyMCE.execCommand('mceInsertContent', false, h);
    	} else
    		win.edInsertContent(win.edCanvas, h);
    }

    Hope this helps a few folk.

  13. KathEats
    Member
    Posted 6 years ago #

    Rusty,

    I tried that and it didn't seem to work for me. I am still getting this error in my FireFox error console:

    Error: uncaught exception: Permission denied to call method Location.toString

    And I am still manually inserting photos every day!!

    Kath

  14. webjok
    Member
    Posted 6 years ago #

    // send html to the post editor
    function send_to_editor(h) {
    	var win = window.opener ? window.opener : window.dialogArguments;
    	// hide this line if ( !win )
    		win = top;
    	tinyMCE = win.tinyMCE;
    	if ( typeof tinyMCE != 'undefined' && ( ed = tinyMCE.getInstanceById('content') ) && !ed.isHidden() ) {
    		tinyMCE.selectedInstance.getWin().focus();
    		tinyMCE.execCommand('mceInsertContent', false, h);
    	} else
    		win.edInsertContent(win.edCanvas, h);
    }

    oh my god . I tried to failed!

  15. webjok
    Member
    Posted 6 years ago #

    I try again .

    and It's OK!

  16. Niksterg11
    Member
    Posted 6 years ago #

    sorry, but did anyone find a fix to the dead 'show' button for images that are already uploaded?

    also, firebug throws an error when I try to reorder the images (in the AJAX window) after they have all been uploaded.

  17. bula1
    Member
    Posted 6 years ago #

    I got mine working!

    My problem was that I could upload but when inserting to a post, I got a blank screen. The funny thing was it was only happening on my laptop. All my other PC's were working fine.

    What I did:
    I dont know exactly what fixed it, but I can tell you exactly what I did just before I got it working after a whole day wasting trying to fix it:
    1. Changed the permalink by adding "www" in front of the domain name
    2. Logged in once via the log in link in index.php

    Now I can log in using the wp-login.php and it works fine now. Like I said, dont know what the fix is but thats what got mine working.

    Hope that helps others coz I wasted a freakn day getting it to work!

  18. dwwhit
    Member
    Posted 6 years ago #

    I tweaked the solution from this guy as referenced above.

    Change
    Files async-upload.php
    to
    Files media-upload.php

    Seems to be working now.

  19. Anonymous
    Unregistered
    Posted 6 years ago #

    I found that my problem came with my WordPress address (URL) having uppercase letters, and apparently PHP does not like that. I suggest making sure that the URL is all lowercase. It fixed my site, who knows, it could fix yours.

  20. empire29
    Member
    Posted 5 years ago #

    Janathantech's solution worked for me. I am running WP 2.6.2 and i changed my domain from everythingHDTV.com to everythinghdtv.com in the General Settings and it worked like a charm! thanks!

  21. tarasdi
    Member
    Posted 5 years ago #

    The cause of my problem:

    The configuration we're running is from behind a reverse proxy, which means that although you request from http://www.a.com, the site actually resides at http://www.b.com.

    Turns out that some times it would forward us to http://www.a.com:1234, and other times to http://www.a.com (ie: without the port number).

    This was creating X-Domain issues with TinyMCE, as the domains AND ports have to be the same.

    Manually typing in http://www.a.com (deleting the port info) fixed the problem.

    HTH

  22. valleytechnologies
    Member
    Posted 5 years ago #

    WP 2.6.3 here, same problem with XP or Vista, both IE7 and FF3. Safari on my mac also does the same thing. Upload works but as soon as I try to post the image to the page I get the usual blank ajax box. This problem has not been completely fixed even in WP v2.6.3

  23. valleytechnologies
    Member
    Posted 5 years ago #

    I've completed all the steps in the sticky about this WP problem but nothing fixes it.

  24. compujeramey
    Member
    Posted 5 years ago #

    I was able to fix the issue by doing the following.

    * Deleting the /uploads/js-cache/ folder (it'll be recreated)
    * Clearing browser cache
    * Logging out, logging out

    I also modified the domain name in the settings to have only lowercase letters in it, as opposed to ProperNoun.com I switched to propernoun.com. Not sure if that had an effect on it.

    Previous to this I was having the white screen problem after hitting "insert into post" in 2.6.3 randomly. I was getting errors in FF that included permission denied to "location.to_string" and "Window.send_to_editor". Presumably that was a result of something gone wrong in the tinymce javascript cache.

  25. ejk
    Member
    Posted 5 years ago #

    Thank you very much to Anonymous, this fixed my problem!

    I found that my problem came with my WordPress address (URL) having uppercase letters, and apparently PHP does not like that. I suggest making sure that the URL is all lowercase. It fixed my site, who knows, it could fix yours.

  26. JanEhrhardt
    Member
    Posted 5 years ago #

  27. bouwmanaa
    Member
    Posted 5 years ago #

    I found that my problem came with my WordPress address (URL) having uppercase letters, and apparently PHP does not like that. I suggest making sure that the URL is all lowercase.

    Worked for me - WordPress 2.7.1 - thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic