WordPress.org

Ready to get started?Download WordPress

Forums

Can't Insert Photos into Posts!! (9 posts)

  1. Brian in NJ
    Member
    Posted 5 years ago #

    I can't understand why I can't upload photos into my posts! This is the most insanely annoying thing, because it's SHOULD be the easiest thing to do. It doesn't even work when I used absolute references.

    I've read Otto42's help post on this and, no offense intended Otto, it's not written well enough for me to understand.

    Please SOMEONE HELP!

  2. vahanavagyan
    Member
    Posted 5 years ago #

    Having this same exact problem :(

  3. mikem1986
    Member
    Posted 5 years ago #

    you click the little box image at the top and upload it and then click "insert into post"

  4. vahanavagyan
    Member
    Posted 5 years ago #

    Re: mikem1986

    I am in the post (editing it) > and I click on the media button and then from the Media Library I click "show" for one image and there I click on "Insert into Post" button. All i get is that same white window on top of my admin page with nothing but a white background inside.

  5. vahanavagyan
    Member
    Posted 5 years ago #

    wow... something is happening... now it's working just fine... had this issue whole day, couldn't fix it... tried on Windows PCs, my Mac, etc... now after this post - it's working like a charm.

    to: Brian in NJ

    Please let me know if yours is still broken or working?

  6. Hippy81
    Member
    Posted 5 years ago #

    Hi Brian,
    I have/had the same problem!

    I think the problem is that WordPress is looking at the wrong folder for the pictures etc.

    Here is the html path for the picture that I was trying to use:
    <img class="alignnone size-full wp-image-119" title="el-diablo21" src="http://mydomain/wp-content/uploads/el-diablo21.jpg" alt="el-diablo21" width="660" height="475" />

    And then I had a look at my FTP and the folder where the pictures af uploaded to and the path: /wp-content/

    So there is no folder on the WP installation called "uploads"...so it looks the "wrong" place for the picture!

    I just removed the
    src="http://mydomain/wp-content/uploads/el-diablo21.jpg" alt="el-diablo21" width="660" height="475" />

    From the html link in the post and then the picture was ther :o)

    Don't know that is a bug in my WP installation?

    Hope it works for you :o)

    /Brian

  7. lancerkind
    Member
    Posted 5 years ago #

    Crikey! I have the same problem (clicking "insert into post" results in a white screen). I migrated my blog from my old system and now I can't insert photos into the post. Since I kept the same versions (at least at the version X.X level, I don't know about the minor versions), I'm inclined to think it's a PHP problem. I'm on BlueHost, BTW. I was self hosted before.

    I'd like to be able to easily insert images again. :-(

    ==>Lancer---

  8. lancerkind
    Member
    Posted 5 years ago #

    Oh, so I later upgraded from 2.6 to 2.7 and the same problem still occurs. :-(

  9. lancerkind
    Member
    Posted 4 years ago #

    Bluehost supported me extrodinarily well and took the matter off my hands and upgraded me to 2.8.1. Now image insertion works!!!!

    Thank you Bluehost.com!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags