WordPress.org

Ready to get started?Download WordPress

Forums

Slideshow
[resolved] Can't Insert images (13 posts)

  1. Omitus
    Member
    Posted 1 year ago #

    Hey, I just installed the Slideshow-Plugin and it looks really good - as far as I can tell. But I got one big problem: I can't insert any image, text or video to my slideshow. The Buttons don't give any reaction when I click them.

    I tried it with Firefox, Internet Explorer, Windows, Ubuntu. Disabled my Popup- or Ad-blocker... nothing helps. Everything else seems to work fine - again: only as far as I can tell. What else could I try?

    http://wordpress.org/extend/plugins/slideshow-jquery-image-gallery/

  2. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    The insert buttons invoke JavaScript actions on the page. If a JavaScript error is thrown on your admin pages, the buttons may not work.

    You could try disabling the other plugins to see if any of them cause any conflicts with the slideshow plugin.

  3. frock
    Member
    Posted 1 year ago #

    i have the same problem. i'm not seeing any JavaScript error. just nothing happens when i click on any of the insert buttons. have tried different browsers. don't want to disable any other plugins on the site. JavaScript is enabled & functioning in my browsers.

  4. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    It sounds like the slideshow's admin scripts aren't loaded, this may occur when you're working on a WordPress version that's older than version 3.3.

    Another possibility is that the slideshow is missing some files. Removing the slideshow plugin, downloading a new one from WordPress.org and installing it might repair it. This won't delete any of your slideshows.

    If that didn't help, it would be wonderful if I could have a look at the slideshow from the admin pages of your website. Naturally I don't expect you to comply with this rather bold request, it may simply help me get to solving the problem faster. If you do want me to have a look at the back-end of your website, please contact me at wordpress@stefanboonstra.com

  5. frock
    Member
    Posted 1 year ago #

    we have wordpress 3.3.2 which it says is the latest (stable) version of wordpress.

    i've deleted the plugin, downloaded it again, & reuploaded it. same thing - clicking on the insert buttons does nothing.

    i suspect it may be to do with the unorthodox directory structure that we have for wordpress (apparently for very good reasons, but i don't understand them). our plugins directory is outside of the actual wordpress directory. most plugins still work fine, but i have had problems in the past that are maybe also to do with this.

  6. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    The latest WordPress version actually is 3.5.

    The unorthodox directory structure may very well be causing the problem with the slideshow plugin. The plugin uses WordPress' recommended method to check for the right plugin URL, plugins_url.

    The aformentioned link leads to WordPress' information page. This page mentions something about how one can affect the outcome of this function using a filter. Perhaps you can use that information to have the plugin URL point to the right location.

  7. etypewillem
    Member
    Posted 1 year ago #

    Stefan,

    I have got the same problem, can´t insert any image.
    Checked Java, is working. I am very reluctant to shut down any other plug-in as I had quite a lot of work put in them.

    I´d really like your plug in to work,can you help?

    Thanks a lot.

    Willem.

  8. frock
    Member
    Posted 1 year ago #

    hi stefan,
    thanks for your reply. the coding is a bit beyond me, i would probably mess everything up if i tried it. basically the unorthodox structure is causing problems with almost everything i try to do, so i think in the long run we need to find a better solution.

  9. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Willem,

    Could you tell me what browser you're using? Sometimes images can be inserted on one browser, while they can in another.

    Google Chrome and Mozilla Firefox are both very good browsers to try.

    Hi Frock,

    That may indeed be the best solution. I've tried to look for a tutorial on how to move the plugins directory to a different folder, but it doesn't seem to be a very popular habit.

    Best regards,
    Stefan

  10. etypewillem
    Member
    Posted 1 year ago #

    Hi Stefan,

    I used IE, but when I tried Chrome, it worked.

    Thanks a lot!

    Now I have to work out why the height of the slides does seem to have their own way...

  11. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    That's good to hear, although strange that it wouldn't work on Internet Explorer.

    The height of the slides is equal to the height of the slideshow, which can be set manually after setting the 'Shrink slideshow's height when width shrinks' to 'No'. A height setting will appear where you can set the number of pixels you'd like the slideshow to be high.

  12. etypewillem
    Member
    Posted 1 year ago #

    Stefan,

    The problem of setting the height was down to the fact that changes made in general settings will only work in new slideshows, not in the ones already made. Which is great, as long as oyou know it!

    Great plugin, absolutely a 5 star.

    Willem.

  13. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    Great to hear you've figured it out! A lot of people misunderstood that indeed. Thanks for your rating!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic