WordPress.org

Ready to get started?Download WordPress

Forums

Can't insert image in post or page (17 posts)

  1. idearius
    Member
    Posted 8 months ago #

    Hello everybody.

    All of a sudden (apparently) we can't add images to anything. They can be uploaded and/or selected from the media library, but when inserted on any post or page, they just don't show. There's no code nor anything. Not even an error message.

    Tried everything suggested in different support topics from about 5 years till now:

    - deactivate all plugins
    - rename the plugins' folder to reset it
    - check permalinks (even if they were not being used)
    - check WP and website URL
    - check location of uploads folder
    - switch to Twenty Thirteen theme and back
    - reinstall the Gantry Framework and theme (that's what we are using)
    - reinstall WP from the updates section
    - reinstall WP manually
    - optimize tables with overhead (using PHPMyAdmin)

    This is a website on a standard LAMP server with cPanel.
    It's been running for more than a year now. Only ~300 posts/pages.

    Don't really know what else to try except downgrading.
    Any help will be much appreciated.

  2. wen.wainwright
    Member
    Posted 8 months ago #

    Can you post a link to the site?

  3. idearius
    Member
    Posted 8 months ago #

  4. idearius
    Member
    Posted 8 months ago #

    Any help, anybody?

  5. Andrew
    Forum Moderator
    Posted 8 months ago #

    Can you link to a page or post that you've tried to add an image to and it hasn't worked? Can you also link us that image in your WordPress site (e.g http://educacionrural.org/path-to-image/image.png)?

  6. idearius
    Member
    Posted 8 months ago #

    One post is http://www.educacionrural.org/?p=2384

    Tried deleting (from the post, not the library) the image that's already there and inserting it back but couldn't: http://www.educacionrural.org/wp-content/uploads/Invitacionmec-1024x835.jpg

    Also tried inserting this other image that is already used at the footer (via a text widget): http://www.educacionrural.org/wp-content/uploads/logo-creativecommons-by-sa-3-80x15.png

    Tried other posts, pages and images to no avail.

  7. Andrew
    Forum Moderator
    Posted 8 months ago #

    Tried deleting (from the post, not the library) the image that's already there and inserting it back but couldn't:

    Sorry, does that mean you couldn't add it back in or couldn't delete it from the post?

  8. idearius
    Member
    Posted 8 months ago #

    Couldn't add it back to the body of the post.

    It's as if the module in charge of insert images is not working.

  9. Andrew
    Forum Moderator
    Posted 8 months ago #

    I'm not sure I understand your issue.
    You deleted this image from your post, but I can still see that image in your post: http://awesomescreenshot.com/0c8200nl05 .

  10. idearius
    Member
    Posted 8 months ago #

    I reverted the changes using the WP history :-)

  11. idearius
    Member
    Posted 7 months ago #

    Any news, Andrew? Wen?

  12. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Could you go back to deactivating ALL plugins and switching to the default theme?

  13. idearius
    Member
    Posted 7 months ago #

    Already did that, and had to reposition all widgets afterwards.
    Want me to do it all over again?

  14. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    This page you referenced above:

    http://www.educacionrural.org/?p=2384

    The image there shows up fine for me - this one:

    http://www.educacionrural.org/wp-content/uploads/Invitacionmec-1024x835.jpg

    What browser are you using? Have you cleared your browser cache?

  15. idearius
    Member
    Posted 7 months ago #

    That is a post that was made when WP was OK.

    That was only an example of a post that didn't accept images anymore. It's the same if you try to insert images to any other post, being new or old.

    It's not a client side problem. We tried with various computers and browsers.

    Is the reference to that post clearer now?

  16. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Have you checked that there is no anti-hotlinking enabled on your server?

    Have you checked the file permissions?

    Have you checked with your hosting company?

  17. idearius
    Member
    Posted 7 months ago #

    Just checked the hotlinking setting and it was enabled. Not sure how can that avoid the code referencing the image to be inserted in a post or page, but I disabled it anyway. Tried inserting an image and it didn't work.

    File permissions are all 0644 and folders 0755 (checked WP root, uploads, themes, plugins, etc.).

    With my hosting company I haven't checked yet. Will try one more thing that I'm thinking about right now and if that doesn't work will write them to see if they have any ideas...

Reply

You must log in to post.

About this Topic