WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] cant import XML file to wordpress (7 posts)

  1. mujdin
    Member
    Posted 4 years ago #

    few days ago i installed wordpress on my pc so i can play with it and see what i can do with it. I could import XML file which comtaind all posts from my old blog. I Could do that without problem. Now i have installed wordpress on a server and now i cant import same XML file. I get this error message "" Before you can upload your import file, you will need to fix the following error:

    Unable to create directory /home/a4716714/public_html/wp-content/uploads/2010/01. Is its parent directory writable by the server? ""

    Could someone help me?

  2. Micah Cooksey

    Posted 4 years ago #

    It looks like a permissions error, but it's interesting that it would be placing the file in your uploads folder. Are you importing it via Tools >> Import? Which platform are you importing from? You can try changing the permissions of those folders to 755 and see if that helps.

  3. mujdin
    Member
    Posted 4 years ago #

    im using Tools >> Import >> WordPress

    it worked great when i had it installed on my computer

    i dont know how to do that. change to folder 755

  4. Micah Cooksey

    Posted 4 years ago #

    Sorry for the ambiguity. To change your folder's permissions to 755, you need an FTP client. Using it, log in to your hosting server, select the folder you would like to change, and depending on the exact client, there are various ways to change the file permissions. Read the documentation for your specific client to learn how to do that.

    At any rate, change the following files to 755: WP-Content, Uploads, and then any folders contained in the uploads folder.
    Note: Do not change any files to 755, only the folders mentioned above.

    Is it possible that the old blog was an extremely old version of WordPress that might not translate well?

  5. mujdin
    Member
    Posted 4 years ago #

    i tried to change but i can only change to 0775

    its not a wordpress blog i had. i dont know what platform they are using but i dont understand why i could import when i had wp on my computer but i cant now when i have it on a webhost

  6. henkholland
    Member
    Posted 4 years ago #

    On an XML import the file is temporarily placed on the server in your uploads directory.
    The error text: "...Unable to create directory /home/a4716714/public_html/wp-content/uploads/2010/01 ..." means:
    a. you have a setting to store uploads in folders based on year/month (check Dashboard/Settings/Miscellenious)
    b. due to the folder uploads/ not being 0777 or due to the fact that your host has safe-mode enabled, WP cannot create a new year/month folder.

    So,
    1. Untick the setting year/month and set/chmod uploads to 0755 or 0777
    2. Try again to import the xml file

  7. mujdin
    Member
    Posted 4 years ago #

    thx alot
    it works now

Topic Closed

This topic has been closed to new replies.

About this Topic