WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't Import WP File (6 posts)

  1. PDM100
    Member
    Posted 1 year ago #

    My WP site was recently moved to a different sever. It is up and running, but that copy is now a week out of date. I have exported a newer copy, but when I try to import it using the built-in importer, I get the error message "Unable to create directory uploads/2013/03. Is its parent directory writable by the server?"

    I assume it means the directory wp-content/uploads. I have changed the permissions on both wp-content and uploads to 777. I even tried adding the directory wp-content/uploads/2013/03 manually. It didn't work.

    If I set the parent directory to anything more than 770, I get an internal server error. I don't what else to try. Any suggestions would be appreciated.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  3. PDM100
    Member
    Posted 1 year ago #

    Thanks for the suggestion. I tried each of those, but it still didn't work.

    I'm running WP under a subdirectory. I added a "wp-content" directory to the root, but that didn't work either.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    I'm running WP under a subdirectory.

    That won't matter in the slightest.

    I added a "wp-content" directory to the root, but that didn't work either.

    That doesn't surprise me. Get rid if it. :-)

    Did you create the uploads folder manually too?

  5. PDM100
    Member
    Posted 1 year ago #

    Thanks for the help, esmi, I appreciate it.

    Searching another form, I was able to locate the problem and fix it. I ran the options.php file under the wp-admin directory. The Upload_Path was for some reason set to my old server. I changed the path to just "wp-content/uploads". Saved the file, and then was able to import my file.

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Glad to hear that you got it sorted. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic