WordPress.org

Ready to get started?Download WordPress

Forums

Can't import WordPress WXR files (25 posts)

  1. Lorven
    Member
    Posted 4 years ago #

    I'm trying to move my WordPress blog from one server to another. I've set up the WordPress installation on the new server, and exported a WXR file from my original server. However, when I tell the new server to import the file, using the Tools->Import tool, I don't get any error messages, but it never imports anything.

    It gets past the screen where I can map existing users, but when I click to start the process, the page acts like it's doing something, but then just loads a blank import page and doesn't actually do anything. I've tried with several different WXR files, ranging from around 450k to a little under 2MB. These files represent different date ranges on my original blog.

    Does anyone know what might be happening, or how I can get the import to work? I've done several imports in the past and all of them worked fine, so I can't figure out why I can't get this one working.

    Thanks in advance for any help!

  2. mdisanto
    Member
    Posted 4 years ago #

    I have the exact same issue.

  3. Mikolak
    Member
    Posted 4 years ago #

    It seems like there's a lot of importing issues in the newest build.
    I can't import either

  4. mdisanto
    Member
    Posted 4 years ago #

    After messing with it for a while I have some more information. It seems to just stop execution after a similar (but not the same) amount of progress on each attempt

    To isolate the problem I tried making a smaller import xml file. I'm importing a ton of tags so I removed all of the post <items> and just left the categories/tags in.

    The tags are in alphabetical order in the xml file and after the import stopped I checked my Post Tags to see how far it made it. I refreshed the database and tried again and checked again, and it stopped on the same letter of the alphabet but made it slightly further (by 4 or 5 tags). Each time it will run for about 10 seconds before I get the blank Import screen and progress is halted.

    This suggests that it's some timeout issue with execution on the server. I tried changing the following php.ini values

    post_max_size = 64M
    upload_max_filesize = 64M
    max_execution_time = 600
    memory_limit = 64M

    The changes are reporting to have taken effect but there's no difference in the import. Are there any other values that I should be increasing or do you have any other ideas as to why this might be happening?

  5. Mikolak
    Member
    Posted 4 years ago #

    I just downgraded to 2.9 and it still isn't working

  6. mdisanto
    Member
    Posted 4 years ago #

    yah I tried it on 2.8.5 and same result

  7. RangerPretzel
    Member
    Posted 4 years ago #

    My friend has a popular WordPress blog on WordPress's site and she's trying to move her site over to hosting on another hosting provider with her own domain name, etc.

    We've got the WordPress PHP software installed and even altered the php.ini file so that it raises the upload limit to 64MB (per mdisanto's recommendation.) And I've verified that when we do the WXR import, the WXR/XML file actually ends up in the "uploads" directory, but once it finishes uploading, nothing happens. We never reach the "users" screen.

    Any updates on this issue?

  8. RangerPretzel
    Member
    Posted 4 years ago #

    Btw, she's uploading a 31MB file.

  9. RangerPretzel
    Member
    Posted 4 years ago #

    Ok, so I created a shortened version (750KB) of the WXR file and it uploads quickly and gives me the "users" screen where I assign the entries to the admin and then click "submit". It does its thing for a few seconds and says "done".

    But when I check the Posts? Still nothing.

  10. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    Check with these options:

    * Break the WordPress WXR file into smaller pieces by separating the data between a posts and pasting the header into each file.
    * Increase the PHP memory limit in php.ini by changing the memory_limit setting (e.g. memory_limit = 64M ;)
    * Increase the PHP memory limit via .htaccess (e.g. php_value memory_limit 64M)..
    * Increase the PHP memory limit via wp-config.php (e.g. efine(‘WP_MEMORY_LIMIT’, ‘64MB’);)

    More Details....

    Thanks,

    Shane G.

  11. RangerPretzel
    Member
    Posted 4 years ago #

    Hi Shane,
    I already tried breaking the WXR file into smaller ones (as listed above.) It imported the Tags and Categories, but none of the posts.

    php.ini is already modified per mdisanto's recommendation.

    .htaccess does not work for me as the host provider does not run PHP as a module.

    I'll try hacking the wp-config.php file, although the php.ini file should already take care of this...

    Thanks.

  12. RangerPretzel
    Member
    Posted 4 years ago #

    Anyone? Surely, I'm not the only one trying to export from the WordPress website and import into my own host provider running the WordPress software running into this problem. Right?

  13. RangerPretzel
    Member
    Posted 4 years ago #

    Ok guys. I wanted to thank everyone for their support...

    And also, I've come up with a solution of my own. I wrote my own WXR file splitter. It requires a Windows PC and the .NET 2.0 framework (which I think pretty much everyone has installed by now...)

    My file splitter takes any size WXR file (I tested with a 32MB file) and loads it into memory, and then splits it up into many smaller files which are perfect for uploading in small batches.

    You can download it for free from my website: Split WordPress XML RSS (WXR) files

    Cheers!

  14. dlawton
    Member
    Posted 4 years ago #

    struggling with the same problem, my original xml export is 11MB which wordpress chokes on, i used the splitter linked above which works fine, the problem is that there is a lot of data and a lot of attachments and wordpress seems to timeout if each xml file has more than 30 items, although sometimes it just completely doesn't work. basically it looks like i will need to import 200 individual xml files? uhhhh i hope not :( i've tried changing .htaccess, php.ini, defining wordpress memory in wp-config, commenting out wordpress timeout in wp-admin/import/wordpress.php and haven't had any luck. i'm on godaddy and have asked for support but aren't getting any help on this.

  15. dlawton
    Member
    Posted 4 years ago #

    i had to split the xml into 46 smaller xml files, when the import screen times out and stops loading just hit reload and send data and it will continue on, took several hours but it worked

    however, i notice that posts no longer have tags, is this a bug in the import? any solutions to this?

  16. dlawton
    Member
    Posted 4 years ago #

    as someone mentioned elsewhere a good idea is to perform the import on a local install, then export to sql from there

  17. RangerPretzel
    Member
    Posted 4 years ago #

    dlawton is right (and I forgot to mention this), if the smaller WXR files fail or hang during import, you usually can just hit "reload" on your browser and then the "resend" button and it should pick-up from where it left off.

    Also, for users of the 1and1.com service, I found this advice on .htaccess very helpful. It made Imports work better and allowed auto-upgrades to work as well. (previously they wouldn't work without this one line in the .htaccess file.)

  18. renaya
    Member
    Posted 4 years ago #

    We're having the same issues. In our case it's 16MB file. Our PHP.INI is already 64MB. This seems to be a gigantic issue and it doesn't seem as if WordPress is fixing it anytime soon.

    The .htaccess doesn't work for me either. And there are about 1,900 posts which needs uploading so splitting isn't an ideal solution at all. It would take several billable hours which isn't good for anyone.

    Can the Wordpres people PLEASE STEP IN and help us out?

  19. dlawton
    Member
    Posted 4 years ago #

    import it to a local install then export to sql

    the size restriction was much larger on my local install (128M as far as I remember) so maybe it's a server restriction, no idea

  20. joshua strebel
    Member
    Posted 4 years ago #

    Disable all plugins before import.

    A plugin was throwing an error on page load.. was stalling the importer. Would not import more than 1 or 2 items at a time.

    [Fri Mar 26 00:24:44 2010] [error] [client 68.3.**.***] PHP Warning: require_once() [function.require-once]: Filename cannot be empty in /*****/httpdocs/wp-content/plugins/wp-to-twitter/wp-to-twitter.php on line 287, referer: http://****/wp-admin/admin.php?import=wordpress&step=1&_wpnonce=4e75534c93

    I disabled all plugins.. import of over 1000 items worked fine.. took some time, but it all worked.

    Hope it helps.

  21. Ben Tremblay
    Member
    Posted 4 years ago #

    Can someone say when Import was working last?

    I was hoping WXR would be the magic bullet ...
    ... my import from LJ "worked", but it turns out that a lot of posts are missing, so I have to re-do from start.
    (I posted on -hackers ... got reply from 1 guy but basically no sing of interest.)

    FWIW some guys are working on GCode: http://code.google.com/p/google-blog-converters-appengine/ but only Blogger => WP so far.

  22. acrofilo
    Member
    Posted 4 years ago #

    Hopefully my experience will help someone.

    I wanted to export my self hosted wordpress to a new self hosted service. I couldn't even Export the posts using the tools within WP. Nothing got exported.

    So, I found the Advanced Export Plugin and it succeeded in creating a XML with all my data. Now the problem was with importing in the new WP.
    I uploaded the file and got to the screen for mapping authors. Then nothing happened. Just a blank screen.

    I searched for a solution and found a simple one: Edit wp-settings.php, line 13, and change memory from 32 to 64. It worked like a charm.

    I must mention that my XML was only 2.6 mb, so this shouldn't be an issue, but that was the solution.

    These forums have helped me a lot, so hopefully I can help someone too with this tip.

    Greetings!

  23. Ben Tremblay
    Member
    Posted 4 years ago #

  24. jennyd
    Member
    Posted 4 years ago #

    Changing the memory in wp-settings.php was all it needed to work for me as well, acrofilo!

  25. kimehh
    Member
    Posted 3 years ago #

    I know this is SUPER late but, why not try using a WXR File Splitter? Here's the link to the programme: http://www.rangerpretzel.com/content/view/20/19/

    It saved my life!

Topic Closed

This topic has been closed to new replies.

About this Topic