WordPress.org

Ready to get started?Download WordPress

Forums

can't get WP to work at all (8 posts)

  1. XskottX
    Member
    Posted 9 years ago #

    Ok, i pretty much have no idea what i'm doing here. I've looked through the forums and changed some stuff, but i still can't fix my problem. I'm willing to let someone log into my domain (if they want, and can't tell me how to fix it) to fix it. This is how i have my config set up:
    <?php
    /** WordPress's config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings ** //
    define('DB_NAME', 'blog'); // The name of the database
    define('DB_USER', 'frigidxshortcomings@seven3true.com'); // Your MySQL username
    define('DB_PASSWORD', '******'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'EN');
    /* Stop editing */
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    define('ABSPATH', dirname(__FILE__).'/');
    // Get everything else
    require_once(ABSPATH.'wp-settings.php');
    ?>
    and i get this error
    Error establishing a database connection! This probably means that the connection information in your wp-config.php file is incorrect. Double check it and try again.
    * Are you sure you have the correct user/password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?
    WordPress Support Forums
    help? if you want, reply here, or via aim at addictedtohatred

  2. davikrug
    Member
    Posted 9 years ago #

    I thinkyourusername is wrong. instead of @domain.com remove this reupload it and let me know. If you want I can look it if that doesn't work. Also recheck the mysql database name.

  3. XskottX
    Member
    Posted 9 years ago #

    Still doesn't work

  4. Are you uploading this to a webserver (anything but your own computer)? If you are, then the DB_Host is not "localhost". It's whatever URL the MySQL database is at.

  5. shep
    Member
    Posted 9 years ago #

    my config is still localhost on my server and it works fine.
    the problem could be your database name. my host names the databases using my username, so for example it would be shep_wordpress or shep_blog .
    try your username_databasename

  6. XskottX
    Member
    Posted 9 years ago #

    Still can't get it to work. Would anyone want to log into my FTP to see if they can take a look?

  7. XskottX
    Member
    Posted 9 years ago #

    fixed this, but still more problems

  8. Joni
    Member
    Posted 9 years ago #

    What did you fix (and how -- so others can benefit too!) and what are the new problems? (And localhost ALWAYS works on an Apache server -- mine anyway (two different web hosts); I've got 8 domains and skads of MySQL databases on all of them all, and every one of them is "localhost." (And it's local host with Yellowtip on my computer too.)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.