WordPress.org

Ready to get started?Download WordPress

Forums

CF7 AutoResponder Addon
[resolved] Can't get this to work (8 posts)

  1. tdzl
    Member
    Posted 9 months ago #

    I've correctly entered my API kye and list name. I've included the mc-subscribe checkbox, but the emails from my test submissions aren't going into the list.

    I'm seeing calls to the API in my MailChimp dashboard each time I submit the form. Each is displayed with a line that looks like this:

    2013-07-18 13:21:52 GMT
    nope	[IPaddress here]	lists	php	0.153s	MCAPImini/1.3	1.3	n/a

    This is how I know the API is entered correctly. How can I get the emails to go into my list? Also, is there a way to link the name field in my form, to the name field in my MC List?

    Thank you!

    http://wordpress.org/extend/plugins/contact-form-7-autoresponder-addon-plugin/

  2. wpsolutions
    Member
    Plugin Author

    Posted 8 months ago #

    @tdzl,
    Please check if there are any logs being produced by the plugin.

    If any logs have been created there will be a file called cf7_autoresp.log in the plugin's directory.

  3. tdzl
    Member
    Posted 8 months ago #

    No, no log file was generated.

  4. Peter Petreski
    Member
    Posted 8 months ago #

    How many fields do you have in your contact form and what are they?

    Also please ensure that your field names conform to the naming convention as specified in the instructions here:
    http://wpsolutions-hq.com/plugins/contact-form-7-autoresponder-addon/

  5. samfletc
    Member
    Posted 8 months ago #

    Hi,

    I'm having the same problem! API calls in the Mailchimp dashboard and no log files created?

    Name and email fields look like they are all named correctly too!

    Hopefully someone can help.

  6. tdzl
    Member
    Posted 8 months ago #

    Fields:

    Name - [your-name]
    Email - [your-email]
    Message - [your-message]
    Subscribe Checkbox - [mc-subscribe]
    Really Simple Captcha - [captcha-287]

  7. wpsolutions
    Member
    Plugin Author

    Posted 8 months ago #

    Hi @tdzl and @samfletc,
    I just tried some tests again and I was able to confirm that the plugin and mailchimp API are working correctly together. I even tried using list names with and without spaces etc.

    One thing you should verify carefully is if you have entered the listname in the plugin configuration settings to be exactly as it appears in your mailchimp dashboard settings.

  8. wpsolutions
    Member
    Plugin Author

    Posted 7 months ago #

    Another thing to keep in mind regarding your mailchimp list settings:

    if you have "required" fields set in your MailChimp account for that particular list which are in addition to the fields which are sent by the CF7 autoresponder addon, the subscriber will not be added to your list because MailChimp API will be expecting those fields to have some values too.

    So to avoid any problems, simply uncheck the "Required" checkbox in your mailchimp list dashboard for those extra fields and all should be ok.

Reply

You must log in to post.

About this Plugin

About this Topic