WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] can't get table to fix (6 posts)

  1. otakugirl
    Member
    Posted 8 years ago #

    http://www.otakugirl.us/1index.php is the URI of it.

    I can't get the two sides to even up under the image and center. for some reason its pushing the "post" area way out to the right. help! :(

  2. otakugirl
    Member
    Posted 8 years ago #

    bump, sorry

  3. otakugirl
    Member
    Posted 8 years ago #

    can anyone help me? i've tried everything i can think of.

  4. Beel
    Member
    Posted 8 years ago #

    Sorry, "we" don't do windows, err, I mean tables.

  5. TechGnome
    Moderator
    Posted 8 years ago #

    Most people aren't proly going to help because of the use of tables in the layout....

    I took a crack at it anyways and here's what I see.
    There are a number of problems.
    One is the image is in first cell of the first row. I assume that's correct, but the cell is never closed.
    <tr><td>
    <img src="/images/x/shibuyatop.png" alt="Shibuya Dreams">
    --- missing a closing td and tr tag here ---
    <tr>
    <td width="39%" valign="top" align="left">

    Now, because the first cell of the first row takes its size from the image.... all remaining cells in that same first col are going to be that wide.... so the first cell should do a colspan=2 (there's nothing in the second cell anyways. That'll allow it to span the two cols, leaving the remaining rows alone.

    Get those fixed, and you may want to run it through a validator. 95% of all layout problems can be fixed simply by validating the source.

    -tg

  6. Beel
    Member
    Posted 8 years ago #

    I was just looking at the source and that is what I saw, too. I know some tutorials suggest one does not need to close the tr's and td's but I think it is best for compatibility between browsers. The layout in this case is vastly different in IE and FF

Topic Closed

This topic has been closed to new replies.

About this Topic