WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't get shortcodes to work (5 posts)

  1. technonow
    Member
    Posted 4 years ago #

    I'm in the process of setting up a website and I've tried a couple of plugins that use a shortcode but I can't get any of them to work.

    The most recent is the clean-contact contact form plugin that uses the shortcode of [clean-contact]

    I've created a contact page and typed [clean-contact] onto the HTML tag, and I've turned off the comments but the page isn't right.

    The page itself is at http://whatto-do.com/contact/ but if you visit the page you'll see that although the 'name' and other headings are displayed it's actually impossible to type anything in.

    The souce code on the page is as follows:

    <div id="column">
    
    	<div class="post" id="post-10">
    		<h1>Contact</h1>
    		<style  type="text/css" media="screen">.CleanContact { text-align: left; width: 30em; display: block; border:0; padding-top: 1em; }
    .CleanContact input[type="text"] { width: 100%; margin-bottom: .5em; }
    .CleanContact label { clear: none; display: inline; text-align: left; }
    .CleanContact textarea{ width: 100%; height: 15em; margin-bottom: .5em; font-size: 1.2em}
    .CleanContact label em { font-weight: bold; font-style: normal; color: red; }
    .CleanContact_msg { font-weight: bold;  padding: 1em; -moz-border-radius: 5px; -webkit-border-radius: 5px;  }
    .CleanContact_msg.ok{ background-color: #8dff87; border: solid 1px #e6f4d7; color: #000; margin: 2em 0 2em 0;}
    .CleanContact_msg.err{ background-color: #ff9595; border: solid 1px #fff; color: #000;}
    
    </style><script src="http://whatto-do.com/wp-content/plugins/clean-contact/fieldset.js" type="text/javascript"></script><script type="text/javascript">clean_contact_form();</script>
    <noscript><p class="CleanContact_msg err">Sorry, due to anti-spam measures, this contact form requires that javascript be enabled on your browser.</p></noscript>
    <div class="addtoany_share_save_container"><ul class="addtoany_list"><li><a class="a2a_dd addtoany_share_save" href="http://www.addtoany.com/share_save?linkurl=http%3A%2F%2Fwhatto-do.com%2Fcontact%2F&linkname=Contact"><img src="http://whatto-do.com/wp-content/plugins/add-to-any/share_save_171_16.png" width="171" height="16" alt="Share/Bookmark"/></a></li></ul></div><div class="clear"></div>
    					</div>
    
    	</div>

    Anyone any idea what I'm doing wrong?

  2. MichaelH
    Member
    Posted 4 years ago #

  3. technonow
    Member
    Posted 4 years ago #

    Thanks for your prompt reply Michael. Much appreciated.

    I've tried both of these, but with the same result.

    On the actual page, the form shows all the headings such as Your Name, Your Email, Subject, etc., but there is no line on which anyone can type the answers.

    These plugins obviously work for everyone else, but not for me, so it's obviously me that's doing something wrong or have missed something out.

    I've read most of the posts on the subject, and as far as I know I'm doing what I ought to. But I'm obviously wrong and missing something. I don't know what.

    I'm currently trying to use clean-contact at http://whatto-do.com/contact/ and contact form 7 at http://www.my-fix-it.com/contact/ but I can't get either of them to work.

    I've never used shortcodes before. I'm assuming that I only need to download a plugin that uses a shortcode, activate it, and type the shortcode into the HTML of a page. I take it that there isn't something like a 'activate shortcodes' plugin that I also have to install?

    Help!

  4. MichaelH
    Member
    Posted 4 years ago #

    If you are getting contact fields then I don't think it is a shortcode issue. Deactivate all other plugins, switch to the WordPress Default theme and see what happens. Then reactivate plugins one-by-one to see if the problem happens.

  5. technonow
    Member
    Posted 4 years ago #

    Grerat. Thanks for pointing me in the right direction.

    I deactivated all the other plugins and switched to the WP default theme, and I could immediately see the form.

    I activated all the other plugins one by one and I could still see the form.

    I then changed back to the 'Amazing' theme I was using and the form dissapeared. On a closer inspection the form was there, but there was no line surrounding the input boxes so I couldn't see them. Neither would visitors to the site.

    Seems this is a theme problem not a plugin or shortcode problem

    Maybe this forum topic will help someone else in the future with the same problem.

    As for me. I think I'll just try a different theme.

    Thanks again, Michael, for your help. Much appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic