WordPress.org

Ready to get started?Download WordPress

Forums

Can't get permalinks working! (10 posts)

  1. Cenay
    Member
    Posted 6 years ago #

    Please help! (And thanks to anyone taking to the time to respond!)

    I recently moved my blog (cenaynailor.com/mlm) from Blogger to WordPress (cenaynailor.com/blog). Life is good. I manually moved all the posts and placed them in the correct "months", a bit pains-taking, but worth it I thought.

    Now to my problem. I attempted to get my pages moved to permalinks that make telling someone about an article I've written a little easier, but nothing works! I have trapped in using only the original WordPress scheme of domain.com/blog/?p=19 -- which I don't like! What am I doing wrong?

    Everytime I attempt to change the method (using Site Admin | Options | Permalinks | choose Date based and update permalink structure... I get an error when I click on an article that isn't on my home page.

    I even went into each post and edited, made sure the page slug was correct and saved the post again (now with the new permalink structure in place) to no avail.

    Please? Help? Absolute newbie with WordPress, but really want a better link structure for both ease of telling readers in other areas about an article I have written, and for SEO to the search engines.

    Hints? Suggestions? Thanks!

    Cenay' Nailor

  2. moshu
    Member
    Posted 6 years ago #

    SEs don't care about your permalinks. Humans might...
    You may want to read this: Using_Permalinks.

  3. Cenay
    Member
    Posted 6 years ago #

    Thanks... DID read that and I am no closer to a solution. I can't find an .HTACCESS file as a sample to use, can't find one on my server. Not even sure if I need one, although it does appear that I do.

    And while I would hope for SEO benefits (like a single page for a single post, improving ranking), it is really the humans I want to please.

    Thanks though for the post. I guess I am going back to the drawing board. Would HATE to go back to Blogger now that I have "seen the light", but I can't get it to work.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    The .htaccess file should be created when you do "Update Permalinks". If, for whatever reason, WordPress cannot create the file, it will give it to you at the bottom of the screen and tell you to go create it yourself. Scroll down.

    Yes, the .htaccess file is absolutely 100% necessary for "pretty" permalinks to work.

  5. Cenay
    Member
    Posted 6 years ago #

    Updated to the custom option (/index.php/%year%/%monthnum%/%postname%/) and clicked Update Permalink Structure. No error message. Says it successfully updated the structure.

    However, I clicked a heading for one of the pages and I get an error message that the page cannot be found.

    http://cenaynailor.com/blog is the current address, click on any of the links...
    I will leave it broken for right now and check back in a few...

  6. Cenay
    Member
    Posted 6 years ago #

    Okay, gonna go back to the way it was/has to be. I will check back and try again when someone has a suggestion. By the way, these are the things I have tried:
    1) Manually created the .HTAccess file that looks like this. Options +FollowSymlinks
    DirectoryIndex index.php index.php3 index.asp index.htm index.html
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    2) Attempted to update the permissions on this file, but WordPress is saying it is updating. Updated the structure and then downloaded the "changed" file, only to see there were no updates.

    3) Deleted the contents of the file, then updated the permalinks again so it would regenerate it. Empty. Strange.

    Anyway.. time to get back to work. Dang, this is plaguing me tho.

    =(

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Question: Is this running on a Windows with IIS system? If so, then those sort of permalinks won't work without extra effort. Use a Linux server with Apache instead.

  8. Cenay
    Member
    Posted 6 years ago #

    Hmm, I use IX Web Hosting, which does use Windows as the OS. I believe I was told they use Apache (rather than IIS or in addition to, I don't know).

    Do you have a link or instructions what they extra effort is?

    Thanks!

  9. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Cenay: No, I have no specific directions. With IIS, the only solutions to permalinks I know involve commercial products.

    I suggest finding a host that will use standard Linux or unix-type boxes with Apache. Nobody uses Windows with IIS for anything serious.

  10. rjoshicool
    Member
    Posted 5 years ago #

    hi,
    i have tried this thing but still cannot access the desired page using permalinks. I keep on getting this error -

    "The system cannot find the file specified."

    Please help me out

Topic Closed

This topic has been closed to new replies.

About this Topic