WordPress.org

Ready to get started?Download WordPress

Forums

SearchAutocomplete
[resolved] Can't get it to work... (8 posts)

  1. Triseult
    Member
    Posted 4 months ago #

    Hi! This looks like a fantastic plugin; however, I can't figure out how to make it work. Can someone please help?

    My website is: http://www.criticsremote.com

    The plugin is currently activated, but the autocomplete doesn't work. I've set the Search Field Selector to [name="s"], but no dice.

    Thanks!

    https://wordpress.org/plugins/search-autocomplete/

  2. hereswhatidid
    Member
    Plugin Author

    Posted 4 months ago #

    The plugin doesn't appear to be activated. I don't see any of the standard scripts that would included appearing on your site.

  3. Triseult
    Member
    Posted 4 months ago #

    Can you please check again? I may have forgotten to clear the cache between disabling and enabling the plugin to try and figure it out.

    I definitely see some of the plugin's scripts now.

  4. hereswhatidid
    Member
    Plugin Author

    Posted 4 months ago #

    Still not seeing it, sorry

  5. Triseult
    Member
    Posted 4 months ago #

    But... I don't understand. I'm on http://www.criticsremote.com right now, and when I look at the page source, I see the AutoComplete CSS and Javascript being called:

    <link rel='stylesheet' id='SearchAutocomplete-theme-css'  href='http://www.criticsremote.com/wp-content/plugins/search-autocomplete/css/redmond/jquery-ui-1.9.2.custom.min.css' type='text/css' media='all' />
    
    ...
    
    <script type='text/javascript'>
    /* <![CDATA[ */
    var SearchAutocomplete = {"ajaxurl":"http:\/\/www.criticsremote.com\/wp-admin\/admin-ajax.php","fieldName":"[name=\"s\"]","minLength":"3"};
    /* ]]> */
    </script>
    
    <script type='text/javascript' src='http://www.criticsremote.com/wp-content/plugins/search-autocomplete/js/search-autocomplete.min.js'></script>

    The plugin is definitely activated in the Dashboard, too. What are you looking for that's not there?

  6. hereswhatidid
    Member
    Plugin Author

    Posted 4 months ago #

    I see it now. I'll let you know what I find.

  7. hereswhatidid
    Member
    Plugin Author

    Posted 4 months ago #

    It looks like there may be something conflicting with the z-index of the dropdown menu. Try manually setting it to something greater than 10 like so:

    .ui-autocomplete { z-index:30 !important; }

    That should fix the issue.

  8. Triseult
    Member
    Posted 4 months ago #

    Well well! I don't understand why, but that did the trick!! Thank you! :)

Reply

You must log in to post.

About this Plugin

About this Topic