WordPress.org

Ready to get started?Download WordPress

Forums

Can't get into my admin page again...more 500 Internal Server errors....help?? (22 posts)

  1. AnthonyJKenn
    Member
    Posted 1 year ago #

    Seems like my little problem of getting into my Red Garter Club Network blogs and network admin pages is back again...I'm getting the same "500 Internal Server error" pages whenever I attempt to go to the admin page.

    http://redgarterclub.com/RGClubNetwork/wp-admin/network/index.php

    I did read that it may have to do with the .htaccess file that is in my server. Here's how mine looks like (located in my /public_html/RGClubNetwork directory:

    # BEGIN WordPress
    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /RGClubNetwork/
    #If you serve pages from behind a proxy you may want to change 'RewriteCond %{HTTPS} on' to something more sensible
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{HTTPS} on
    RewriteCond %{DOCUMENT_ROOT}/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index-https.html.gz -f
    RewriteRule ^(.*) "/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index-https.html.gz" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{HTTPS} !on
    RewriteCond %{DOCUMENT_ROOT}/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index.html.gz -f
    RewriteRule ^(.*) "/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index.html.gz" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTPS} on
    RewriteCond %{DOCUMENT_ROOT}/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index-https.html -f
    RewriteRule ^(.*) "/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index-https.html" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTPS} !on
    RewriteCond %{DOCUMENT_ROOT}/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index.html -f
    RewriteRule ^(.*) "/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index.html" [L]
    </IfModule>
    
    # END WPSuperCache
    
    RewriteEngine On
    RewriteBase /RGClubNetwork/
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    # END WordPress

    Most of it is added through WP SuperCache, which I do use for all my networks.

    I have also investigated my server error_log file, and I keep discovering this series of error code:

    'backticks'
    [01-Jan-2013 20:11:38] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-zts-20060613/magickwand.so' - /usr/local/lib/php/extensions/no-debug-zts-20060613/magickwand.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [01-Jan-2013 20:11:38] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-zts-20060613/pdo.so' - /usr/local/lib/php/extensions/no-debug-zts-20060613/pdo.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [01-Jan-2013 20:11:38] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-zts-20060613/pdo_sqlite.so' - /usr/local/lib/php/extensions/no-debug-zts-20060613/pdo_sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [01-Jan-2013 20:11:38] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-zts-20060613/sqlite.so' - /usr/local/lib/php/extensions/no-debug-zts-20060613/sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [01-Jan-2013 20:11:38] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-zts-20060613/pdo_mysql.so' - /usr/local/lib/php/extensions/no-debug-zts-20060613/pdo_mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [01-Jan-2013 20:11:38] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-zts-20060613/ixed.5.2.lin' - /usr/local/lib/php/extensions/no-debug-zts-20060613/ixed.5.2.lin: cannot open shared object file: No such file or directory in Unknown on line 0
    'backticks'

    As always, any help would be appreciated. What am I doing wrong to cause this??

  2. Your .htaccess is a little weird (I use w3tc and WP Super Cache too).

    First, that error about pdo_mysql isn't WP, it's PHP. Your webhost should be able to fix that for you.

    As for the .htaccess, you seem to have the Rewrite Base in there twice.

    I would try this:

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    #If you serve pages from behind a proxy you may want to change 'RewriteCond %{HTTPS} on' to something more sensible
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{HTTPS} on
    RewriteCond %{DOCUMENT_ROOT}/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index-https.html.gz -f
    RewriteRule ^(.*) "/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index-https.html.gz" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{HTTPS} !on
    RewriteCond %{DOCUMENT_ROOT}/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index.html.gz -f
    RewriteRule ^(.*) "/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index.html.gz" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTPS} on
    RewriteCond %{DOCUMENT_ROOT}/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index-https.html -f
    RewriteRule ^(.*) "/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index-https.html" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTPS} !on
    RewriteCond %{DOCUMENT_ROOT}/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index.html -f
    RewriteRule ^(.*) "/RGClubNetwork/wp-content/cache/supercache/%{SERVER_NAME}/rgclubnetwork/$1/index.html" [L]
    </IfModule>
    
    # END WPSuperCache
    
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /RGClubNetwork/
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    # END WordPress
  3. AnthonyJKenn
    Member
    Posted 1 year ago #

    Sorry for the delay in responding.

    It worked for a day, but now I'm getting those blasted Internal Server Errors again today.

    I did notice that the system wants to create an empty .htaccess file at the root directory of my server (/public_html). My original .htaccess file is located in the same directory as where my network blog is (/public_html/RGClubNetwork/.htaccess). Is that supposed to happen?? Maybe I should transfer the revised .htaccess file over to my root directory? But, wouldn't that screw up my other blog networks, which are working fine?

  4. It worked for a day, but now I'm getting those blasted Internal Server Errors again today.

    ... What now? Is something being overwritten? It shouldn't 'stop' working unless your server's being overwritten.

    Are you running your site from http://redgarterclub.com/RGClubNetwork/ or http://redgarterclub.com/ ?

  5. AnthonyJKenn
    Member
    Posted 1 year ago #

    I'm actually running it from http://redgarterclub.com/RGClubNetwork (via the wp-admin page).

    Strangely enough, it's now back to running fine without any error pages again. What was funny was that when I went into the index.php file in my /RGClubNetwork subdirectory, I saw this line:

    require('./wp-blog-header.php');

    I first changed the code on that line to

    require('./RGClubNetwork/wp-blog-header.php');

    That did clear things up....for a while, but then the error page showed back up.

    I then went to browse through the index.php code for another WPMS network (AJK-Multisite) that was working without any issues, to see if the offending line was any different from the one at /RGClubNetwork. Turns out, it wasn't, it contained the same original code as the initial index.php page.

    So, I went back and revised the line back to where it was originally.

    require('./wp-blog-header.php');

    Surprisingly, the errors have ceased, and haven't reappeared since. (Knock on wood.)

    Hopefully, when I log out and shut down my system, and reboot tomorrow, I won't get any more error pages. So far...so good.

    Thanks for all your help.

  6. AnthonyJKenn
    Member
    Posted 1 year ago #

    I'm still interested, though, on why the network insists on making its own .htaccess file at the server root directory (./public_html), even though there is a working .htaccess file at the directory where my WPMS network is located (./public_html/RGClubNetwork). It's the latter file where all of the main coding (and the adjustments for WPCache and WPSuperCache) are located; the former file at the root is empty.

  7. It's not the network doing that, honestly, unless you told it to use http://redgarterclub.com/ as your main URL.

    See, you can install WP in http://redgarterclub.com/RGClubNetwork/ and have people use http://redgarterclub.com/ as the main URL.

  8. AnthonyJKenn
    Member
    Posted 1 year ago #

    Nope...I specifically have it set to http://redgarterclub.com/RGClubNetwork, because I want to preserve the main URL for a future website rather than a blog; and also because I have another network (AJK-Multisite) that I use as a backup in case /RGClubNetwork has a failure.

    I also have my old blog (http://redgarterclub.com/SDChronBlog2dot5), that I run as a standalone blog (single blog, not Multisite) for archival purposes.

    A bit much, I know...but it's worked well for me so far.

    So...if it's not the network, then what could it be that's causing the creation of the .htaccess file at the root directory?

  9. Let's be silly. Make a blank .htaccess in root, and set the permissions to 644.

  10. AnthonyJKenn
    Member
    Posted 1 year ago #

    That's kind of the point...I already have one in root; along with the working .htaccess file at my /RGClubNetwork directory. Every time I would delete it (the root .htaccess), a new empty .htaccess file would be generated at the same location.

    In any case, the problem seems to have solved itself again. I can freely access my admin page without any problems now, and I'm getting no error pages so far. I am still getting the same PHP warning endless loop that I mentioned in my original post, though...but thus far it hasn't affected my access to my blog network. Maybe it was just some plugin glitch after all.

    In any event, you've been quite helpful in assisting me in resolving this. Thanks.

  11. AnthonyJKenn
    Member
    Posted 1 year ago #

    Well, guess what?? I logged in this morning, and the Internal Server Error page is back. And, I'm getting the same PHP warning endless loop over and over again, too.

    Looks like I'll have to write a service ticket to HostGator to resolve this, since this doesn't appear to be a WP issue.

  12. AnthonyJKenn
    Member
    Posted 1 year ago #

    ...annnnd, just like that, after going into the index.php file and changing the code like I did before, my admin page is back. Like I said, this is getting a bit frustrating. Help??

  13. AnthonyJKenn
    Member
    Posted 1 year ago #

    Good news!! I am frustrated no longer....the problem is finally solved!!!

    Turns out, it was a PHP error, caused by me setting too liberal permissions for access to my plugins folder. (777 rather than the default 775) My web host (HostGator) reset them to the proper spex, and that stopped both the error messages and the error pages.

    Thanks for putting up with me throughout all this. Ths case is now officially CLOSED. :-)

  14. sonthanhha
    Member
    Posted 1 year ago #

    My site is down. all folders is 755. :(

  15. AnthonyJKenn
    Member
    Posted 1 year ago #

    Let the record reflect that sonthanhha is NOT me; I am the sole administrator of this blog.

    However...the 500 network error pages are unfortunately back again. It seems like I may have a hacker in my midst again.

  16. livemohit
    Member
    Posted 1 year ago #

    Can't get into my admin page again...more 500 Internal Server errors....help??

    changing Permalinks

  17. livemohit
    Member
    Posted 1 year ago #

    Can't get into my admin page

    changing (Settings General Screen)

  18. AnthonyJKenn
    Member
    Posted 1 year ago #

    Never mind....I cleared my browser cache, and I can access my page again.

    The others do not speak for me, or my blogs.

  19. AnthonyJKenn
    Member
    Posted 1 year ago #

    Well....guess what? The 500 Internal Server errors are back, and now they are also plaguing my AJK-Multisite network as well as my RGClubNetwork, too.

    Also...the usual remedies of clearing my browser cache or modding the .htaccess or php.ini files aren't working, either.

    I am at my wits end here now. HELP???

  20. Are they making any server changes on you? If you're not doing anythig, and I believe you!, then what the heck?

  21. AnthonyJKenn
    Member
    Posted 1 year ago #

    OK...I think I've finally (this time!!!) found the problem.

    Because I had allowed my subscription to my original web host (HostGator) to lapse and got it suspended temporarily, I had signed up with another webhost (JustHost.com), and I had the nameservers set to both web hosts simultaneously. I was able to finally resub back to HostGator, so now I have both webhosts running simultaneously.

    I did a check using IntoDNS.com, and found that the nameservers were indeed pointing to both webhosts, and between that, the caching of my blogs (using WP SuperCache) and my browser cache, would apparently be causing the errors.

    HostGator did a diagnostic of my blogs and discovered also that the permissions of some of my WP files were also not oriented correctly; they were set at 777 for executable files; which violates their rules and suPHP protocol. They reset all the relevant file thipermissions over to their recommended 755, which should have resolved all the issues.
    RGCNetwork) is still getting errors. Maybe I should delete or clear WP SuperCache and that would solve the issue??

  22. AnthonyJKenn
    Member
    Posted 1 year ago #

    OOPS..that last paragraph should have read:

    It did so for the AJK-Multisite directory/network, but the other network (RGCNetwork) is still getting errors. Maybe I should delete or clear WP SuperCache and that would solve the issue??

Topic Closed

This topic has been closed to new replies.

About this Topic