WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't get into admin after upgrade to 3.1 (25 posts)

  1. Rob Cubbon
    Member
    Posted 3 years ago #

    I have just upgraded to 3.1 on http://www.iegoa.dreamhosters.com/

    When I try to log in to
    http://www.iegoa.dreamhosters.com/wp-admin

    I get redirected to
    http://www.iegoa.dreamhosters.com/wp-admin/upgrade.php?_wp_http_referer=/wp-admin/

    first with
    Fatal error: Class 'MultiPostThumbnails' not found in Functions.php

    I deleted this line in functions and now I just get a blank screen at
    http://www.iegoa.dreamhosters.com/wp-admin/upgrade.php?_wp_http_referer=/wp-admin/

  2. Rob Cubbon
    Member
    Posted 3 years ago #

    With the help of this post

    http://www.hightechdad.com/2009/06/10/fixing-blank-empty-or-white-wordpress-pages-after-upgrade/

    I am able to get the site working although with error messages.

    I think the problem is using the Multiple Post Thumbnails plug-in with 3.1 it seems not to work.

    I have all the plug-ins deactivated and I'm running 2010:

    But I;m now having these error messages:

    Warning: include_once(/home//iegoa.com/wp-content/plugins/wp-super-cache/wp-cache-phase1.php) [function.include-once]: failed to open stream: No such file or directory in /home//iegoa.com/wp-content/advanced-cache.php on line 8

    Warning: include_once() [function.include]: Failed opening '/home//iegoa.com/wp-content/plugins/wp-super-cache/wp-cache-phase1.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/local/php5/lib/pear') in /home/robcub2/iegoa.com/wp-content/advanced-cache.php on line 8

  3. 123milliseconds
    Member
    Posted 3 years ago #

    >>I have all the plug-ins deactivated

    super cache is not deactivated

    Ask help at their forum

    http://wordpress.org/tags/wp-super-cache

  4. keesiemeijer
    moderator
    Posted 3 years ago #

    try this:
    back up your .htaccess file and rename or delete it from the server.

    from the readme.txt of wp-super-cache

    To manually uninstall:

    1. Turn off caching on the plugin settings page and clear the cache.
    2. Deactivate the plugin on the plugins page.
    3. Remove the WP_CACHE define from wp-config.php. It looks like define( 'WP_CACHE', true );
    4. Remove the Super Cache mod_rewrite rules from your .htaccess file.
    5. Remove the files wp-content/advanced-cache.php and wp-content/wp-cache-config.php
    6. Remove the directory wp-content/cache/
    7. Remove the directory wp-super-cache from your plugins directory.

  5. Rob Cubbon
    Member
    Posted 3 years ago #

    Hi, thank you for your help, 123milliseconds and keesiemeijer, I have done what you say (no such lines in 3 and 4 in wp-config or htaccess) and problem still persists.

    Have opened thread in Super Cache plugin forum, thanks.

    http://wordpress.org/support/topic/plugin-wp-super-cache-error-messages-despite-deactivation-after-31-w-upgrade?replies=1#post-1963561

  6. keesiemeijer
    moderator
    Posted 3 years ago #

    Also read this for troubleshooting: http://wordpress.org/support/topic/troubleshooting-wordpress-31-master-list

    It doesn't have to be the super cache plugin which is causing this trouble.

  7. Rob Cubbon
    Member
    Posted 3 years ago #

    Thank you again, keesiemeijer, I actually don't think I ever had Super Cache plug-in ever activated on that site so I can't understand why I'm getting these error messages about it.

    Maybe I'm better off going back to the previous version of WP and getting rid of Multiple Post Thumbnails Plugin and starting again as that is where I suspect the original problem was.

  8. Rob Cubbon
    Member
    Posted 3 years ago #

    I have deactivated all plug-ins and I'm using 2010 theme and I'm getting this error message

    Warning: include(/home/iegoa.com/wp-content/advanced-cache.php) [function.include]: failed to open stream: No such file or directory in /home/iegoa.com/wp-settings.php on line 60

    Warning: include() [function.include]: Failed opening '/home/iegoa.com/wp-content/advanced-cache.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/local/php5/lib/pear') in /home/iegoa.com/wp-settings.php on line 60

    It doesn't mention Super Cache now so I don't think it's a problem with that. Any ideas?

  9. advanced-cache.php is a WP Super Cache File, actually. So yeah, yeah it is :)

  10. Rob Cubbon
    Member
    Posted 3 years ago #

    Ah, OK, thank you, my bad

    I don't understand it though. I don't have the WP Super Cache plug-in activated nor even in the plug-in directory.

    I've just deleted the following lines from wp-settings.php

    // For an advanced caching plugin to use. Uses a static drop-in because you would only want one.
    if ( WP_CACHE )
    WP_DEBUG ? include( WP_CONTENT_DIR . '/advanced-cache.php' ) : @include( WP_CONTENT_DIR . '/advanced-cache.php' );

    and it's got rid of the error message. I'm sure this is a short-term solution but I'm going to reactivate plug-ins and my old theme now and see how I get on.

  11. WP SuperCache needs to be uninstalled differently from most plugins, as I recall.

  12. Rob Cubbon
    Member
    Posted 3 years ago #

    OK, my bad again.

    The " define( 'WP_CACHE', true );" line was in wp-config.php I just didn't see it. Sorry!

    Now I'm getting other errors when I try to activate other plugins.

    When I activate the "underConstruction" plug-in I get:

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/robcub2/iegoa.com/wp-includes/functions.php on line 3387

    When I activate WPML (WordPress Mult-Lingual) plug-in I get:

    Notice: Undefined index: plugins in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/compatibility-packages/functions-packages.php on line 132
    
    Notice: Undefined index: page in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/compatibility-packages/functions-packages.php on line 20
    
    Notice: Undefined index: site_id in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 1262
    
    Notice: Undefined index: language_details_enen in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/cache.php on line 53
    
    Notice: Undefined index: theme_localization_type in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/functions-string-translation.php on line 277
    
    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/iegoa.com/wp-includes/functions.php on line 3303
    
    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/iegoa.com/wp-includes/functions.php on line 3303
    
    Notice: Undefined index: page in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/language-switcher.php on line 74
    
    Notice: Undefined index: gettext_theme_domain_name in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 4348
    
    Notice: Undefined index: gettext_theme_domain_name in /home/robcub2/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 4348
    
    Notice: Undefined index: gettext_theme_domain_name in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 4348
    
    Notice: Undefined index: gettext_theme_domain_name in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 4348
    
    Notice: Undefined index: gettext_theme_domain_name in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 4348
    
    Notice: Undefined index: gettext_theme_domain_name in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 4348
    
    Notice: Trying to get property of non-object in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/wp-nav-menus/iclNavMenu.class.php on line 155
    
    Notice: Undefined index: action in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/wp-nav-menus/iclNavMenu.class.php on line 155
    
    Notice: Undefined variable: pagenow_ in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 505
    
    Notice: Undefined index: page in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php on line 102
    
    Notice: Undefined index: doc_translation_method in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php on line 108
    
    Notice: Undefined variable: pagenow in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php on line 119
    
    Notice: Undefined index: in_language_en in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/cache.php on line 53
    
    Notice: Undefined index: languages_Array in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/cache.php on line 53
    
    Notice: Undefined index: page in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 740
    
    Notice: Undefined index: gettext_theme_domain_name in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 4348
    
    Notice: Undefined index: strings_language in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/functions-string-translation.php on line 532
    Notice: Undefined index: gettext_theme_domain_name in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 4348
    dir="ltr" lang="en-US">
    Notice: Undefined index: site_id in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 1262
    
    Notice: Undefined variable: page_basename in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 1502
    
    Notice: Undefined variable: page_basename in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 1502
    
    Notice: Undefined index: strings_language in /home/iegoa.com/wp-content/plugins/sitepress-multilingual-cms/inc/functions-string-translation.php on line 532

    Sorry for the quantity.

  13. Rob Cubbon
    Member
    Posted 3 years ago #

    It may well be WPML (WordPress Mult-Lingual) plugin – causing the problems. I'm discussing it on their forum.

    However, underConstruction plug-in is still a problem.

  14. keesiemeijer
    moderator
    Posted 3 years ago #

    If you still think the multiple-post-thumbnails might be the problem I just read this in one of the comments in the troubleshooting-wordpress-31-master-list.

    The "multiple-post-thumbnails" plug-in breaks the WP-install after doing the upgrade to 3.1. The database doesn't upgrade.
    Fix: Rename your theme so the default theme will be loaded. Then you can do the database upgrade. Then delete the second post-thumbnail size in your theme's funcions.php and the call to the function in the theme files. Rename your theme back to the old name and your site should be up and running again. At least this worked for me.

  15. Rob Cubbon
    Member
    Posted 3 years ago #

    Thank you, keesiemeijer, this might help – I have asked Fleetstar a question there. It's still broken for me.

    underConstruction plug-in get error messages even though it works on other 3.1 site I've got.

    WPML is a complete mess and they're releasing another upgrade on Monday. So I'm along way from solving this problem. But thanks for all your help.

  16. FYI - that multiple-post-thumbnails doesn't fix the plugin (which remains broken), but will get your site back up and running.

  17. keesiemeijer
    moderator
    Posted 3 years ago #

    Plugins can also be in conflict with each other and break WordPress (that's why we troubleshoot with all plugins deactivated).
    and did you complete the manual uninstall of wp-super-cache?

    4. Remove the Super Cache mod_rewrite rules from your .htaccess file.
    5. Remove the files wp-content/advanced-cache.php and wp-content/wp-cache-config.php
    6. Remove the directory wp-content/cache/
    7. Remove the directory wp-super-cache from your plugins directory.

    and Delete the wp-super-cache folder in the plugins folder.
    or don't you have these files and folders?

    You can also put these lines back in wp-settings.php or put the original file back. It is never wise to hack core WordPress files.

    if ( WP_CACHE )
    WP_DEBUG ? include( WP_CONTENT_DIR . '/advanced-cache.php' ) : @include( WP_CONTENT_DIR . '/advanced-cache.php' );
  18. Rob Cubbon
    Member
    Posted 3 years ago #

    Thanks, Ipstenu, yes I see that now.

    Yes, keesiemeijer, I did all that. There weren't any mod_rewrite rules in my .htaccess file just the basic WP pretty permalink ones. I did all the deletion in numbers 5 and 6 above. The wp-super-cache folder doesn't exist in my plugins directory.

    All my WordPress files are vanilla 3.1 now as I have deleted define( 'WP_CACHE', true ); from wp-config.php

    I'm not getting any error messages now, but when I activate Under Construction plug-in, when I get the following:

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/robcub2/iegoa.com/wp-includes/functions.php on line 3387

    ... which is really weird as I have it working with other installs of WP 3.1

    And, when I activate the new, premium, version of WPML I get multiple error messages (see above) with my custom theme. But with 2010 and WPML, I get "The plugin generated 756 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin." .. and the plug-in doesn't work properly. (All plug-ins with my custom theme worked perfectly pre 3.1).

    However, they're releasing another WPML upgrade on Monday. But their forum isn't besieged with people with the same problem so I really don't know what went wrong.

    Thank a lot for your help, as always.

  19. firedoghk
    Member
    Posted 3 years ago #

    When I did the auto upgrade to 3.1 the site hung up for a long time, when i clicked on the upgrade link i got the message that wordpress was doing maintenance and to wait.
    My upgrade never continued and now when I click my links to my blog and blog admin the screen remains blank, not even a login screen for admin. I am using wordpress as a plugin on godaddy.com for two of my sites. gateway-english.com/wordpress/ upgraded with no trouble and works fine. I next tried to upgrade doghouse-hk.org/wordpress and that's when the trouble came. I checked on godaddy.com and the wordpress folder is there and all files intact. How can i get this blog back?

  20. firedoghk
    Member
    Posted 3 years ago #

    I now find that the 3.1 upgrade files are all in a sub directory: doghouse-hk.org/wordpress/wp-admin/upgrade/wordpress-3.tmp/wordpress/wp-admin/

  21. Rob Cubbon
    Member
    Posted 3 years ago #

    Have you sorted this issue out, firedoghk, it sounds like an incomplete upgrade but I'm not sure of how to fix it. Have you seen this?
    http://onemansblog.com/2009/07/21/tutorial-what-to-do-when-wordpress-auto-update-fails/

    I just thought I would say for the record that everything is fixed now. I fixed the Multiple Post Thumbnails issue by getting rid of the plug-in

    I fixed the notices appearing when activating UnderConstruction plug-in by changing
    define('WP_DEBUG', true); to define('WP_DEBUG', false); in wp-config.php

    I received a lot of help here to fix the Super Cache issue.

    And, finally, the plug-in developers at WPML (the multi-lingual plug-in) released another version which contained a fix for my issue with it.

    So, 5 days later, everything is back to how it was pre-3.1. Challenging but maybe I learned a little bit. Most of these problems came from plug-ins that where incompatible with the WP upgrade.

    Thanks to everybody that helped

  22. firedoghk
    Member
    Posted 3 years ago #

    Yes thanks robcub, the upgrade got hung up in a server maintenance on wordpress. eventually I tracked down the how to upgrade manually webpage, deleted the wordpress-3.tmp folder and started again by downloading the zip file and following the instructions successfully

  23. SociaMediaClick
    Member
    Posted 2 years ago #

    Hello there,

    I’ve installed the plugin on my website, but when I want to desactivate to publish the website, all my wordpress fail: the web site + the admin dashboard. http://www.socialclick.es
    It also damage my server and others webs hosted on it!

    Ipstenu, I thought you might help me on this! http://profiles.wordpress.org/users/Ipstenu/

    Could you please help me to resolve the issue?
    It’s quite urgent abd problematic for my client.

    Many thanks
    Vincent

  24. SociaMediaClick? Start a new thread. This one is marked resolved already and is 6 months old.

  25. SociaMediaClick
    Member
    Posted 2 years ago #

    ok

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags