WordPress.org

Ready to get started?Download WordPress

Forums

Can't get featured images to show. argh. (2 posts)

  1. camillex
    Member
    Posted 1 year ago #

    Hi there,
    I'm new to wordpress, and I've been trying to get a theme to work pretty much all day. At first I thought featured images weren't showing up because of the particular theme I chose, but I've tried it on a few of them, and nothing happens.

    I've searched the forum and google forever, but I can't find any information that helps me (again, I'm new, so maybe I just don't really know what to look for in the answers).

    I'm currently trying to get it to work on Prana, but I tried Hatch, tdSimple, and Pilot Fish as well, and nothing happens. I host with HostGator... don't know if that makes a difference at all.

    Thanks for any help you can provide. I can't proceed much further without getting this resolved!

  2. Shaun Scovil
    Member
    Posted 1 year ago #

    I looked at the Prana theme and it appears the file you want to edit is called content-single.php. (This should be done in a Child Theme.)

    The original file contents for content-single.php can be seen here: http://themes.svn.wordpress.org/prana/1.1/content-single.php

    Somewhere in there, like after the <h1> tags, you can add:

    <?php if ( has_post_thumbnail() ) { the_post_thumbnail(); } ?>

    See the Codex for more info: http://codex.wordpress.org/Post_Thumbnails

Topic Closed

This topic has been closed to new replies.

About this Topic