WordPress.org

Ready to get started?Download WordPress

Forums

Can't get E-mails Working (15 posts)

  1. roscoparker
    Member
    Posted 1 year ago #

    Hi,

    I'm wondering if anyone can help, I can't get emails to work on the following website http://test.camorg.org/wordpress/contact. Any ideas? I've spoken to the hosting provider who says my mail settings are fine, so I'm puzzled as to why it won't work.

    I'm using Contact Form 7, but I have also tried Fast Secure Contact Form.

    Can anyone help?

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    I think your domain might have expired. Check it.

  3. roscoparker
    Member
    Posted 1 year ago #

    No, domain definitely hasn't expired I checked this

  4. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Click here and see: http://camorg.org/
    Ask Godaddy where you are hosted why your domain shows their page. Before that make sure that you have not placed it for domain parking with Godaddy. Additionally, have you set your DNS?

  5. roscoparker
    Member
    Posted 1 year ago #

    Ah, sorry I made a spelling mistake in the address. It should be
    http://test.camot.org/wordpress/contact sorry my fault

  6. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Your form is online, and displaying quite OK. Again you have to contact Godaddy because the settings at their end is not working. Before that check your own email settings.

  7. roscoparker
    Member
    Posted 1 year ago #

    The site is actually hosted through ASPnethosting. I've spoken to two of their advisors on separate occasions, who have said that the settings are fine at their end. I don't know what else to suggest to them as they just keep saying it must be something to at the plugin end

  8. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    I believe the host's email servers are not set properly, or having problems. Anyway, try reinstalling the contact form plugin and see if it helps. If it does not the problems are at your host's end.

  9. peter achutha
    Member
    Posted 1 year ago #

    I'm using Fast Secure Contact Form by Mike Challis - no problems.

    There are sever points you will have to consider.

    1. Have you activated your mailbox on your host? Just creating a email address in your host will activate it. It may take a few hours for the dns to propagate so come back the next do to do your testing. If you do not have an email address registered in your mailbox some host will block all emails from going out.

    2. Ensure all fields in the contact form are filled up eg 'from', 'reply to' ... as some hosts will not send the emails out if there are blank fields.

    3. Ensure that your from email address is from your domain. For example if your domain name is mydoamin.com and you use an 'from' email address of another domain name like sales@myothersite.com chances are many hosts will block from going out (prevent spamming or hijacking).

    4. Install an SMTP plugin. If you are sending emails to a Google Apps hosted email you will need to install an SMTP plugin with SMTP host set as smtp.gmail.com, port 465, Secure connection prefix set to ssl.

    5. Some host firewall will block the emails from forms from going out. You need to request them to disable the block.

    Check these out and let me know.

  10. roscoparker
    Member
    Posted 1 year ago #

    Hi Peter,

    1. Mailbox is definitely active
    2. I filled in all of the main fields. In FS secure contact form there are 20-30 fields that you can fill in, but I've made sure that from: reply to:, etc... are all complete
    3. Email is from my domain
    4. I have WP-Mail-SMTP installed
    5. Checked with my host and they say everything looks fine

    It's very frustrating. I've set-up various other WordPress sites using Contact Forms and never had this problem before.

    I'm not sure if it's something to do with the theme I am using http://320press.com/wpbs/?

  11. peter achutha
    Member
    Posted 1 year ago #

    That is a good idea to check on. You could change the theme to Twenty Ten to check if it is email related. I am using Atahualpa theme and Configure SMTP for my SMTP plugin and do not have any problems. You could also try switching to Configure SMTP and test with your current theme. If it is theme related you may want to feed back to the theme developers.

    DNS Check with pingdom.com (http://dnscheck.pingdom.com/?domain=camot.org)came back with:-
    --------
    Could not find reverse address for 213.229.109.155 (155.109.229.213.in-addr.arpa.).

    PTR record(s) for the address could not be found in the .arpa-zone. (ip6.arpa. for IPv6 addresses and in-addr.arpa. for IPv4).

    Name server ns3.aspnethosting.co.uk (213.229.109.155) not authoritative for camot.org.

    another test at pingdom.com (test results http://tools.pingdom.com/ping/?target=camot.org&o=2&id=6263595 ) shows ping test ok.

    The name server does not answer authoritatively to queries for the tested domain. This is probably due to misconfiguration, usually the name server is not set up to serve the tested domain.
    ns4.aspnethosting.co.uk.

    Could not find reverse address for 213.229.119.98 (98.119.229.213.in-addr.arpa.).

    PTR record(s) for the address could not be found in the .arpa-zone. (ip6.arpa. for IPv6 addresses and in-addr.arpa. for IPv4).

    --------
    You can see the results of the DNS test at http://dnscheck.pingdom.com/?domain=camot.org&timestamp=1339611882 which you can feed back to your host tech support. It is failing to deliver email.

    The other two test at http://tools.pingdom.com/fpt/ were ok. I would suggest your host tech support fix the problems before you do any more testing / checking.

  12. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    @Peter,
    I too wasted a lot of time by using the wrong URL posted at the top. When seeking guidance members should at least quote their correct URLs

  13. peter achutha
    Member
    Posted 1 year ago #

    Yeah, don't worry about it. I have edited the above message when I caught my error. So it looks like roscoparker's host server is failing to deliver emails. Please do feedback to them the test results at http://dnscheck.pingdom.com/?domain=camot.org&timestamp=1339611882

  14. peter achutha
    Member
    Posted 1 year ago #

    Actually, @Krishna, members should make it a habit of providing their URL's because sometimes looking at a website can make it quicker to figure out the real problem. Thanks.

  15. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    @Peter,
    The result shows several problems. See:

    http://dnscheck.pingdom.com/?domain=camot.org

    I think this issue is to be taken up with the host, no solution can be found in this forum for this.

Topic Closed

This topic has been closed to new replies.

About this Topic