WordPress.org

Ready to get started?Download WordPress

Forums

Can't get background color to show in wrapper (3 posts)

  1. ornmnt
    Member
    Posted 4 years ago #

    Hello,

    I wonder if someone might be able to help me out with a problem I'm having; I think it must be something pretty simple that I'm missing or ignorant of.

    I am trying to have a background image beneath the main content of the site. In the theme I am using, this is all contained in the #wrapper tag. So I assumed that I could just put the code for the background image in the body tag, and then set the #wrapper background color to white. This didn't seem to work out as I expected--nothing seems to happen at all to the background of #wrapper. I've tried everything and I can't seem to get it to work. I know it's possible of course; it's just something that I'm missing. Here is a simple example of what I'm talking about in the theme A Dream To Host 2.3 (http://demo.artofblog.com), i.e. gray gradient background with the white area above.

    [Code section moderated - please use a pastebin as per the Forum Rules]

    Thanks so much for any help you can offer--I really appreciate it!

  2. ornmnt
    Member
    Posted 4 years ago #

    Sorry, I didn't know about the pastebin policy and I can't find a way to modify the original post so I'll just post this as a comment.

    Here is a link to the code for the stylesheet and the main index template:

    http://wordpress.pastebin.ca/1811621

    Again, if anyone could offer any clues it would be greatly appreciated. I'm guessing it must have something to do with some CSS conflicts or omissions...

  3. nyunyu
    Member
    Posted 4 years ago #

    See here:

Topic Closed

This topic has been closed to new replies.

About this Topic