WordPress.org

Ready to get started?Download WordPress

Forums

Posts in Page
[resolved] Can't find pagination anywhere (8 posts)

  1. soret
    Member
    Posted 1 year ago #

    Hello!

    First of all, congratulations on your plugin. I was struggling horribly to add posts into a page template by code after giving up on searching everywhere for something like this. I was almost done (I only needed to add CSS styling) when I found this... You can imagine how happy I was.

    Anyway, what I wanted to do was add a category of posts in a page. As you obviously know, this is really easy with your plugin... But, I really need a pagination. I set the default amount of posts to 5, and added 6 posts into a category to test it on a page, and could not see the "Older posts" link anywhere, nor could I find a way to add it manually after trying everything (like <?php twentytwelve_content_nav( 'nav-below' ); ?>). I went into the default blog of my site, and I could see the "Older posts" link. I even activated the PageNavi plugin and worked great... But I still couldn't see it on my test page with the shortcode of this plugin.

    I searched and found out that it wasn't possible a few months ago, but that you finally added the possibility to do it. One user was even complaining that it was set to default. However, I can't find anywhere an option to toggle it on. Is there something that I'm doing wrong?

    Thank you very much in advance!

    http://wordpress.org/extend/plugins/posts-in-page/

  2. Eric Amundson
    Volunteer Moderator
    Plugin Author

    Posted 1 year ago #

    Hey soret,

    Per this page:
    http://wordpress.org/extend/plugins/posts-in-page/installation/

    Try adding: paginate='yes' to your shortcode.

    That should do it.

    Hope that helps.
    Eric

  3. soret
    Member
    Posted 1 year ago #

    Omg... Guess I didn't look hard enough. Sorry for your trouble.

    However, I noticed that the link of the "next" button is not ok. The page that the shortcode is in, is a level 2 page (I mean, for instance, "mydomain.com/level1/leve2"), but the link sends me to "mydomain.com/level2/?page=2", skipping the parent page. If I manually add the parent page in the URL, then I can see the posts...

    Thanks again so much in advance

  4. Eric Amundson
    Volunteer Moderator
    Plugin Author

    Posted 1 year ago #

    soret,

    Are you using Pretty Permalinks under Settings in the Dashboard? If not, try turning them on and see if that helps.

    e

  5. soret
    Member
    Posted 1 year ago #

    I'm not entirely sure, because my WordPress is in Spanish. Under the "Permalinks" settings, I have selected the post name type of URL. Here is a link to my test page. That is where the "next" link is. Notice how the parent page "ejemplos" is not in the link.

    Thank you again for all your fast replies!

  6. Eric Amundson
    Volunteer Moderator
    Plugin Author

    Posted 1 year ago #

    What is the exact shortcode you're using now, soret?

  7. soret
    Member
    Posted 1 year ago #

    The exact code is [ic_add_posts paginate='yes' category='ejemplos-de-chapa'], being "ejemplos-de-chapa" the slug of a category I created and the one where the posts are assigned to.

  8. soret
    Member
    Posted 1 year ago #

    Hello again!

    I just wanted to say that the link to the testing site no longer works, just in case you were planning on checking it from this point on. I'm working around solutions myself, but still don't get it right.

    As a feature request, it would be AWESOME for the plugin to work with the WP-PageNavi plugin. In my humble opinion, I think that is the only think missing.

    Therefore, for that and for your great support and quick reply, you have my 5 stars.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic