WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't Expand Custom Menu Widgets or Create Custom Menu (13 posts)

  1. agfreesafety
    Member
    Posted 1 year ago #

    Hi! I'm using the Blogotype theme for this site, and when I'm in the Dashboard, I'm unable to make a custom menu.

    There's more insight on my issue in this forum post from a short while ago.

    When I drag things over to the white space in the upper right hand corner of the screen, the widgets don't stay.

    I was told that I needed to select something from the widgets themselves first, but when I click on them, nothing happens.

    I use Firefox most of the time, but this issue occurs even when I switch to other browsers.

    So my questions are:

    1. Do I need to be able to expand the menu widgets before I'm able to place select pages in the menu of the site?

    2. What do I need to do to be able to build a custom menu?

    Thanks!

  2. agfreesafety
    Member
    Posted 1 year ago #

    This WordPress forum says that this was a known issue that was fixed in 3.3.1, but I have 3.4.1 installed.

  3. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress 3.4.1.

    And why aren't you using WordPress 3.4.2?

  4. agfreesafety
    Member
    Posted 1 year ago #

    And why aren't you using WordPress 3.4.2?

    I'm nervous to upgrade sometimes, out of fear that it'll break something. I'll try that now.

    switching to the Twenty Eleven theme to rule out any theme-specific problems.

    I tried that, didn't work.

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    I tried that as well.

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    And resetting the plugins folder?

  6. agfreesafety
    Member
    Posted 1 year ago #

    I now have 3.4.2, and when I move the "Pages" widget over to the white space on the right for the custom menu, the widget pops back to it's place on the left, and doesn't sit in the custom menu.

  7. agfreesafety
    Member
    Posted 1 year ago #

    And resetting the plugins folder?

    I'll give that a shot right now.

  8. agfreesafety
    Member
    Posted 1 year ago #

    That did it! You rock!!!

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    Excellent! :-)

  10. agfreesafety
    Member
    Posted 1 year ago #

    OK, one last question... When I click the "Theme Locations" drop-down, nothing happens. After reading this instructional page, my interpretation is that this is where I go to activate my custom menu. Am I right?

    This is weird, because I could've sworn I saw (somewhere) in my Dashboard the ability to select different menus, but I can't remember where it was.

  11. agfreesafety
    Member
    Posted 1 year ago #

    nevermind, I figured it out. I had to select "Menu" in the right pane in order to select my new menu from the "theme locations" drop down.

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    Apart from the fact that you're consulting the wrong documentation for a self-hosted site (see custom menus instead), this is completely theme-dependant. It could be that your current theme simply doesn't fully support custom menus. Switching temporarily to the Twenty Eleven theme should confirm this.

  13. agfreesafety
    Member
    Posted 1 year ago #

    Thanks esmi, I really appreciate your help

Topic Closed

This topic has been closed to new replies.

About this Topic