WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't Enable XML-RPC Posting (20 posts)

  1. lilkeith07
    Member
    Posted 5 years ago #

    I installed a new version of WordPress on a subdomain (history.keithkeirstead.com). I was going through the options enabling and applying the ones that I wanted. When I got to enabling XML-RPC posting I checked the box and then clicked save changes. This gave me a 404 error. It directs me from /wp_admin/options_writing.php to /wp-admin/options.php and displays an error like a missing blog post. I am able to enable the atom publishing just fine, but not the XML-RPC. Does anybody know how to fix this? Or whats causing the problem? Thanks!

  2. louwd123
    Member
    Posted 5 years ago #

    Hi, I've got the same problem than lilkeith here on top. Also a subdomain, worship.bergtee.co.za. After I clicked Save Changes on the bottom of the Settings/writing screen it then goes to All Settings page. Some of the fields says SERIALISED DATA. Then when i click on Save Changes
    the following is given:

    Forbidden
    You don't have permission to access /wp-admin/options.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I am the administrator of the site, so I shouldn't have troubles with any access rights(?) Well please help, coz it's very frustrating. And it's only on the Settings/Writing options. Accessed the different plugin settings and Media Settings without any problems.

    Thanks, Louw

  3. rossedwards
    Member
    Posted 5 years ago #

    +1

    Same problem enabling XML-RPC (i.e. I can't!) but on a top-level blog. I've tried disabling all plugins, and even reverted to the most basic of themes (default), just in case it was doing something funny.

    Still no luck, and all Googles point here.

    <sniff>

  4. rossedwards
    Member
    Posted 5 years ago #

    OK, fixed my problem (can't enable XML-RPC). I launched phpMyAdmin and looked at the options table.

    I then manually set the value of enable_xmlrpc to 1, then refreshed my cache.

    All working now, but what a PITA!

  5. lilkeith07
    Member
    Posted 5 years ago #

    OK, fixed my problem (can't enable XML-RPC). I launched phpMyAdmin and looked at the options table.

    I then manually set the value of enable_xmlrpc to 1, then refreshed my cache.

    All working now, but what a PITA!

    Yes this worked for me! Thank you so much!

  6. louwd123
    Member
    Posted 5 years ago #

    Hi guys, I managed to enable it in the above mentioned way and when I enter the settings-writing options it shows that it is enabled. I unfortunately still can't access the blog with any client, Raven/moblog(mobile),post2blog. Raven is the only one that provides details about the problem. It still says forbidden to access the xmlrpc.php . Even if i just type the address http://worship.bergtee.co.za/xmlrpc.php I get a forbidden message. I'm starting to think that it is the site management software that is blocking access to it. Can anyone shed some light on this matter? thanks again, Louw

    zoundry.blogpub.xmlrpc.xmlrpcserverimpl.ZXmlRpcException: {ZBlogServerException['blogger.getUsersBlogs' type:XMLRPC Protocol Error, code:403 msg:Forbidden(worship.bergtee.co.za/xmlrpc.php)]}

  7. memoryimprintstudio
    Member
    Posted 5 years ago #

    login your wordpress as admin, go to setting/writing, under Remote publishing. Enable XML-RPC as explained in following. You should good to go.

    To post to WordPress from a desktop blogging client or remote website that uses the Atom Publishing Protocol or one of the XML-RPC publishing interfaces you must enable them below.

    Atom Publishing Protocol: Enable the Atom Publishing Protocol.
    XML-RPC: Enable the WordPress, Movable Type, MetaWeblog and Blogger XML-RPC publishing protocols.

    Tony
    ----------------
    http://www.memoryimprintstudio.com

  8. bmetcalf
    Member
    Posted 5 years ago #

    i'm having the same problem. my blog is installed in a subdirectory on a root domain. i try to push the ENABLE checkbox from the settings/writing category, and i receive an error message every time. i am not familiar with myphpadmin, can someone explain how i would go about using this to modify the setting manually? or is there another method i need to use?

    i am trying to enable this function to use the "wordpress for iphone" app.

  9. Joseph Scott
    Member
    Posted 5 years ago #

    What's the error message?

    A few things to try to help pin down where the problem might be:
    - Disable all plugins and try to enable XML-RPC again
    - If it starts working again enable one plugin at a time and go back after each one to try and enable XML-RPC. This should indicate which plugin is causing the problem

    - If it still doesn't work switch to the default theme and try to enable XML-RPC again

    We need to gather enough information to reproduce this problem, until then we are just shooting in the dark.

  10. bmetcalf
    Member
    Posted 5 years ago #

    thanks for the reply joseph! the error message was:
    -----------------
    "Not Acceptable

    An appropriate representation of the requested resource /brandonmetcalf/wp-admin/options.php could not be found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."
    -----------------

    i will try to go through and disable the plugins first and see if that works.

    before i change the theme, i have a couple questions. 1. if i change the theme, will it save all my options so that i can switch back to it and have it all be the same? 2. if it is the theme that is preventing me from enabling this option, does that mean i won't be able to use this theme at all? or will i be able to enable it, then switch back to this theme and have everything work that way?

    thanks in advance for the replies!

  11. Joseph Scott
    Member
    Posted 5 years ago #

    That 404 error makes it sound like an error in the setup of the web server. Are you able to save/update any options on that page?

    Your theme should be saving options in the database, so that shouldn't be a problem.

    If it is a problem with the theme then you should contact the theme author to let him/her know that it's causing problems.

  12. bmetcalf
    Member
    Posted 5 years ago #

    well, it wasn't the theme either.

    i can change some of the options on the settings page. for example, i was able to enable the atom publishing protocol (the option right above the xml one).

    any ideas?

  13. Joseph Scott
    Member
    Posted 5 years ago #

    That is exceptionally odd. Is there anything in your web server error logs to hint at what's going on?

  14. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    I'll give you odds that it's mod_security interfering.

    A lot of hosts have poor setups for mod_security. Many of these actively block anything with "xmlrpc" in it. So when it tries to send the name of the option to enable, wham, blocked.

    My advice: Beat your host about the head with a trout until they capitulate.

  15. Joseph Scott
    Member
    Posted 5 years ago #

    If hosts have setup mod_security to blog anything with 'xmlrpc' in it that would be very frustrating.

    @bmetcalf - if this turns out to be the case then give them a double dose of Otto42's advice.

  16. bmetcalf
    Member
    Posted 5 years ago #

    i just sent an email to our server host to see what's up. will keep you guys posted on the result! thanks for everyones help.

  17. inpencil
    Member
    Posted 5 years ago #

    Did this ever get resolved? I'm having the same problem. Enable xml-rpc is checked in wordpress - I also manually checked in the options-writing.php file, in it i find "enable_xmlrpc" checked as "1".

    I'm using myweblog (mac application). Here's the error code i'm getting:

    '<?xml version="1.0"?>
    <methodResponse>
    <fault>
    <value>
    <struct>
    <member>
    <name>faultCode</name>
    <value><int>405</int></value>
    </member>
    <member>
    <name>faultString</name>
    <value><string>XML-RPC services are disabled on this blog. An admin user can enable them at http://inpencilmusic.com/wordpress/wp-admin/options-writing.php</string></value&gt;
    </member>
    </struct>
    </value>
    </fault>
    </methodResponse>'

    It says it's disabled, but I've enabled it in wordpress, and also checked manually, no joy!!

    I have an open ticket with my webhost to see if it is a mod_security issue, so will let you know.

  18. Joseph Scott
    Member
    Posted 5 years ago #

    @inpencil
    I don't think yours is a case of mod_security problems since it did return a valid XML-RPC response. What we need to figure out is why your WP blog would still think XML-RPC has been turned off if you have it enabled in wp-admin. Have you checked the database to see what the option value is? Do you have any caching plugins installed that might be providing stale data?

  19. inpencil
    Member
    Posted 5 years ago #

    @josephscott

    Thanks for the suggestions, strangely, it seems to have fixed itself! I'm not sure what I did, but everything works A-OK now. I did disable a bunch of plug-ins - first try produced no results, but also deleted plugins manually off the server, and maybe that did the trick. Thanks again. Resolved on my end. Hope everyone else gets it up and running.

  20. Joseph Scott
    Member
    Posted 5 years ago #

    Good to hear. May have been a rogue plugin then causing the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags