WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Can't empty meta description (6 posts)

  1. Megmug
    Member
    Posted 6 months ago #

    Hi All,

    I've entered a meta description at some pages on my website using the Yoast SEO plugin.

    No I wan't to remove the whole description and let Google pick a right one, but the Yoast plugin won't let me! :-(

    I can change the meta description to 1 character, but if I totally remove the description and press update. The old description automaticly shows up again!

    Anyone had the same problem? Or can help me with this?

    Thanks in advance!

    Best Regards,

    Gerard

    http://wordpress.org/plugins/wordpress-seo/

  2. iceteax
    Member
    Posted 6 months ago #

    Hi,

    yes, same problem here. WordPress 3.8 and latest WordPress SEO. It is not only Metadescription but all WordPress Seo fields cannot be set to empty.

    Regards
    Dennis

  3. rlamb2
    Member
    Posted 6 months ago #

    For the description, try setting it to a space. Yoast currently has a check in place for various empty values, but a space will get through. This I found yesterday when testing some things.

    WordPress seems to handle single space meta fields as needing to be emptied and just saves it without that space, or at the very least, doesn't output the space in the backend.

    I haven't tested, so I can't guarantee that Yoast won't just try to give an empty meta description for those pages though. If it works the way I think it will though, it'll determine the description you entered to be empty and generate one for you again.

    Hope that helped!

  4. rlamb2
    Member
    Posted 6 months ago #

    Finally, it looks like they've been made aware and fixed it. We're all just waiting on a plugin update. :)

    https://github.com/Yoast/wordpress-seo/commit/af26999e07d7635422545aaaf224be4a5b9b8d1e

  5. Megmug
    Member
    Posted 6 months ago #

    Thx Dennis & rlamb2 !

  6. iceteax
    Member
    Posted 6 months ago #

    Works now again with the latest Update from today! Solved for me, thx.

Reply

You must log in to post.

About this Plugin

About this Topic