WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't edit theme files after upgrade to 2.8. "Update file" redirects to homepage (12 posts)

  1. Z
    Member
    Posted 5 years ago #

    I've never had a problem with editing my theme files before, but now that I've upgraded WordPress to 2.8, I'm having a weird issue. When I try to edit a theme file such as "header.php" and hit "update file", the browser redirects me to my blog's homepage and doesn't save the changes to the file.

    I checked to see if the files were chmoded differently, but they're not - all are writeable, so I am not sure what the problem could be.

    Is anyone else having this issue? It's extremely annoying to have to log in to FTP to edit a theme file... any help would be MUCH appreciated!

  2. Z
    Member
    Posted 5 years ago #

    I finally figured out the cause of this issue - by deactivating all my plugins and reactivating them one by one, it appears to be "WordPress Firewall" that's causing this problem in 2.8. Deactivating it makes my site work again.

  3. seoegghead
    Member
    Posted 5 years ago #

    Collegefashion:

    Sorry to hear you had problems with the plugin. You probably just need to whitelist the theme editor, though.

    Let me know if you want to try this out and I can help you.

  4. Matt B.
    Member
    Posted 5 years ago #

    Hi collegefashion,

    You just need to whitelist your IP on the plugin's options page. You'll then be able to edit your themes as usual.

  5. mike58
    Member
    Posted 4 years ago #

    someone has a tip on this....

    when I add images to a gallery in the plugin NextGen Gallery this Warning comes up.
    the Add Images function executes alright and the images goes right into the gallery - so there is really no problem - but what shall I do with the warning?
    what does it mean?

    Warning: preg_match() expects parameter 2 to be string, array given in /home/.../wp-content/plugins/wordpress-firewall/wordpress-firewall.php on line 169

    this is line 169: if(preg_match($regex, $file['name'])){
    (copied from wordpress-firewall/wordpress-firewall.php)

    best wishes

    mike58

  6. beautyjunkiesunite
    Member
    Posted 4 years ago #

    Hey everyone!

    I'm having a similar problem, since upgrading to 2.8-- my theme editor displays old theme file versions of my header.php, footer.php, etc. and doesn't update my changes. But my sidebar is perfectly okay! I have to go into the FTP to change everything else, and those changes are never reflected in my WP theme editor. I have changed permissions and disabled plugins after combing through the forums looking for solutions, my files are all also writeable. My theme also shows up as my current theme with what looks like no problem. What am I missing here everyone? Thanks in advance for your suggestions!

    Amber

  7. flixbda1
    Member
    Posted 4 years ago #

    @beautyjunkieunite, I am having the same problem I thought I was going crazy. I didn't have anything to compare the problem to since I am new to wordpress. Is the solution to downgrade to the previous version of wordpress?

  8. beautyjunkiesunite
    Member
    Posted 4 years ago #

    Hi Flixbda,

    I was thinking the same thing too, but since I'm still relatively new to navigating my way around, I have no idea how to downgrade either!

    :)Amber

  9. beautyjunkiesunite
    Member
    Posted 4 years ago #

    But then again, I've read that going back to 2.7 isn't such a great idea afterall due to potential hacks... I guess if there's no other way around this for the time being I'll have to deal with it and hope it's fixed on the next update!

  10. Janetfl
    Member
    Posted 4 years ago #

    dtc,

    You seem to know what you are talking about.

    How do you whitelist your own ip?

    The updates I save in my sidebar are not showing online. I think this may be similar to this thread.

    Janet
    http://greenesrelease.com

  11. Matt B.
    Member
    Posted 4 years ago #

    Hi Janetfl,

    Here's a little walk-through :
    1- prior to editing templates, go to
    /wp-admin/options-general.php?page=wordpress-firewall.php
    2- whitelist your IP : simply copy the one shown, paste it in the field and save
    3- you can now edit your files without being flagged as potentially dangerous

    Cheers

  12. kvnl888
    Member
    Posted 4 years ago #

    solved my problem too.
    ----
    my blog http://www.lotog.com

Topic Closed

This topic has been closed to new replies.

About this Topic