WordPress.org

Ready to get started?Download WordPress

Forums

Can't edit some posts after 2.7 upgrade (5 posts)

  1. VFHwebdev
    Member
    Posted 5 years ago #

    I just upgraded to 2.7. There are several posts I can no longer edit. When I click the 'edit' link for these posts on the "Edit Posts" page, I get a text field with the title of the post, and no other fields.

    There's no permalink, no post content, no excerpt, no nothing.

    Just to be clear, I'm not seeing empty fields. There are no fields for these elements at all.

    Any help would be greatly appreciated.

  2. VFHwebdev
    Member
    Posted 5 years ago #

    I've figured out what's making this happen and it seems to be a bug in 2.7.

    All my posts with long titles and therefore long permalinks are having this problem.

    I tested it and the limit is 30 characters in the permalink.

    With 30 characters in the permalink everything functions as normal. With 31 characters, you can't edit the post anymore.

    Is there a separate forum for posting bugs? Or someone I could email this to?

  3. livelearncreate
    Member
    Posted 5 years ago #

    Is there any fix for this 30 character limit yet????

  4. MarkRH
    Member
    Posted 5 years ago #

    Uhhh... there's no 30 character limit that I've ever come across. Last post I made has a 67 character long title that I can edit fine. I'm running version 2.7. Maybe some other plug-in interfering?

  5. livelearncreate
    Member
    Posted 5 years ago #

    I have posts that are being written by an user (Editor) and I get this when I try to click on and edit any of their posts:

    Fatal error: Call to undefined function: normalize_whitespace() in /nfs/c03/h03/mnt/55208/domains/proximitymagazine.com/html/wp-admin/edit-form-advanced.php on line 49

    If I used the "Quick Edit" tab and shorten or even leave the permalink alone and click "Update Post" then I can edit it normally. Otherwise I get the above message.

    Anyone have any suggestions?
    I'm using Akismet, Event Calendar, PHPEnkoder, and WPAuto Upgrade Plugin's but I don't see how any of these are causing this.

    Also, there is no "normalize_whitespace()" on line 49 of wp-admin/edit-form-advanced.php that I can find.

    Please help.

Topic Closed

This topic has been closed to new replies.

About this Topic