WordPress.org

Ready to get started?Download WordPress

Forums

Can't edit pages using 'Visual' Option in 2.8? (51 posts)

  1. reader51
    Member
    Posted 5 years ago #

    My site displays properly to the world, but the admin thing is really wonky. azaozz: I just need to add define( 'CONCATENATE_SCRIPTS', false );??

    I'll give it a try a bit later.
    The link to my site is: http://lucidcontent.com

  2. Andrew Ozz
    WordPress Dev
    Posted 5 years ago #

    @reader51 it seems that wp-inclides/js/tinymce/wp-tinymce.js.gz file is missing on your install. Thin is the compressed version of the editor (77KB) that makes it load quite faster (the uncompressed is 255KB).

    It is possible there are other files missing too, perhaps delete wp-admin and wp-includes and upload fresh copies from freshly extracted install package.

  3. reader51
    Member
    Posted 5 years ago #

    how matey, how?

  4. Andrew Ozz
    WordPress Dev
    Posted 5 years ago #

    How to replace the two directories? With FTP (Filezilla?). There are more troubleshooting instructions http://wordpress.org/support/topic/279132?replies=13

  5. reader51
    Member
    Posted 5 years ago #

    Some people also reported success redoing the upgrade via Tools->Upgrade->Re-install automatically, then clearing the browser cache.

    Yay! It worked! Thanks azaozz! You pointed me there!

  6. yourmessagehere
    Member
    Posted 5 years ago #

    @azaozz - I deleted and replaced both folders but still need the 'define( 'CONCATENATE_SCRIPTS', false )' string - is that right?
    @reader51 - did the re-install do it or was it the bit of script (I have not yet tried re-installing)

  7. fotdmike1
    Member
    Posted 5 years ago #

    I had exactly the same problem after upgrading. Running Firefox 3.0.10

    Tried adding that
    define( 'CONCATENATE_SCRIPTS', false );
    to the config file, cleared the browser cache, and now works a treat.
    (Also deleted and replaced the unedited config file rather than just overwriting)

    Thanks azaozz!

  8. reader51
    Member
    Posted 5 years ago #

    To: yourmessagehere -- it was the reinstall that did it. Took about 5 seconds and poof! All fixed. Try it!

  9. tomgibson
    Member
    Posted 5 years ago #

    Thanks for everyone's comments.

    The one that worked for me was from azaozz (thanks!):

    Namely, adding define( 'CONCATENATE_SCRIPTS', false ); to the wp-config.php file. I added it after the defines for the database.

    There's a bit more information here http://wordpress.org/support/topic/279132 see #5.

    Tom @tomwgibson

  10. Jay Greathouse
    Member
    Posted 5 years ago #

    I downloaded 2.8 zip file directly from http://wordpress.org/download/ and checked tinymce directory and it is 'missing' files that I've now added to my blogs:
    tiny_mce_config.php
    tiny_mce_ext.js
    tiny_mce_gzip.php
    wordpress.css

    I got those files by using the WAU (WordPress Automatic Upgrade) plug in but I had to compare 3 different installs (3 different blogs) to get them all.

    define( 'CONCATENATE_SCRIPTS', false ); would make WordPress admin run slower, so after I made sure all the files were in place I commented it out and everything still works.

    here is the list of files & directories I now have in tinymce/
    blank.htm
    langs (directory)
    license.txt
    plugins (directory)
    themes (directory)
    tiny_mce_config.php
    tiny_mce_ext.js
    tiny_mce_gzip.php
    tiny_mce_popup.js
    tiny_mce.js
    utils (directory)
    wordpress.css
    wp-mce-help.php
    wp-tinymce.js
    wp-tinymce.js.gz
    wp-tinymce.php

    total count = 16 files & directories

    all of this is from a similar thread at:
    http://wordpress.org/support/topic/279476

  11. nochance
    Member
    Posted 5 years ago #

    Had exactly the same problem as all you guy's

    adding the define( 'CONCATENATE_SCRIPTS', false );
    worked, but slowed down wordpress

    the fix was simple for me, I downloaded version 2.8.1 (beta), and copied the wp-tinymce.js.gz to my tinymce folder of wordpress.

    Removed define( 'CONCATENATE_SCRIPTS', false ); and now works fine without any further editing of the wp-config.php

  12. yourmessagehere
    Member
    Posted 5 years ago #

    @ reader51 - tried it, but still need "define( 'CONCATENATE_SCRIPTS', false )". Thanks for the feedback though!
    @ nochance - wp-tinymce.js.gz is a zip file right? Did you re-install via Tools > Upgrade > Re-install automatically? Or is pasting/uploading enough?

  13. Celenco
    Member
    Posted 5 years ago #

    azaozz, Thanks for helping me out....Your advise fixed my WP problems.

  14. trishf
    Member
    Posted 5 years ago #

    @azzozz - thank you very much - adding to code
    define( 'CONCATENATE_SCRIPTS', false ); fixed my immediate problem. Will monitor to see if it slows anything down as reported by @nochance, but just glad to be able to do visual edit again.

    Much appreciated

  15. KonaGirl
    Member
    Posted 5 years ago #

    I have tried everything and still can't get the visual to work. It is not in the theme, either as it doesn't work in any of them including the default, Kubrick theme. I am not using Gears and the box "Disable the visual editor when writing" in Your Profile is not checked. I have reinstalled it,and deactivated all plugins, and reinstalled again. Still nothing.

    I am so disgusted. I had just nuked my whole blog because of being hacked for the 5th time with viruses! Here I am trying desperately to get a new, clean version up and running and can't add a post or a page.

    @azzozz The only thing I haven't done yet is to try adding the code
    define( 'CONCATENATE_SCRIPTS', false ). I am not a techie and don't understand where exactly I should be putting this code without screwing everything else up.

    Thanks for any details you are willing to give .

  16. KonaGirl
    Member
    Posted 5 years ago #

    I don't know what happened as I didn't do anything else. I was waiting for a response to my last post. All of a sudden the visual came on and I was able to get in a post. I am working on a page now and so far it seems to be working now too?????

    I have no clue. Your guess will be as good as any 'cause I sure don't have one.

  17. jodith
    Member
    Posted 4 years ago #

    OK, I've got this happening, but only on *one* page. It's been working fine. Did several hours of work this morning, saving after every few changes to the page. Now, after one save, I've got this problem on that page, and it won't show the page revision history (my thought was maybe I needed to undo the last change). All of my other pages are fine. The visual editor is working without issue.

    Any ideas? I'm really hoping I don't have to restore the page from my last backup. The loss of about 6 hours of work will make me cry. *sniff, sniff*

    Edit to Add: Oh, yeah, and the spacing on the page is wrong when you view it. Had used soft returns in many places, and now spacing is like hard returns.

  18. chardixon
    Member
    Posted 4 years ago #

    Thanks so much for the - define( 'CONCATENATE_SCRIPTS', false );
    That solved all the problems I was having, at least for the moment. I wil now go check the tiny files.

  19. marilynch
    Member
    Posted 4 years ago #

    Hmmm...since you people are having the blank-screen-with-red-streaks problem too, this may be related to my posted question 11-11-09, "Only HTML, no VISUAL display of post after restore."

    My head swims at all the responses to this forum question, but I appreciate the ideas very much; maybe something here will solve my mystery. Thanks.

  20. macting2001@yahoo.com
    Member
    Posted 4 years ago #

    what is i already installed my new theme and worked on it
    i dont want to lose it
    where do i update? define( 'CONCATENATE_SCRIPTS', false );

    i already added: wp-tinymce.js.gz

  21. zer0one
    Member
    Posted 4 years ago #

    Fixed Mine... I couldnt see any editor tools or the option to switch from Visual to HTML. after trying a few things like re-uploading, reinstalling, it finally came back when I went into my user account clicked "ON" the option "Disable the visual editor when writing" saved and then clicked it back "off" again and saved.

    Apparently this kick started the visual editor back into gear for me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.