WordPress.org

Ready to get started?Download WordPress

Forums

Can't Edit Pages from Blog View (6 posts)

  1. smartyd
    Member
    Posted 10 months ago #

    Why is there no edit icon for static pages in the blog view (the public side) as there used to be? Blog posts still have the edit icon, but pages don't. This means my translation plugin (Transposh) can't work as it should for static pages, as all translation edits have to occur from the blog view instead of the editor dashboard.
    I tried switching themes to see if I could edit my translation of the About Me page, but it's the same for the Twenty-something theme.
    I need to be able to edit my static pages from the front of the blog, not just from the WP dashboard.
    Anyone know of a fix?
    Thanks
    http://www.diypics.com
    Marty

  2. esmi
    Forum Moderator
    Posted 10 months ago #

    Blog posts still have the edit icon, but pages don't.

    This is controlled by your current theme. Where did you download it from?

  3. smartyd
    Member
    Posted 10 months ago #

    I'm using Suffusion 4.4.6. But I also tried Twenty Thirteen and the same problem exists with that.

  4. lettergrade
    Member
    Posted 10 months ago #

    In 2013, the 'Edit' link appears under the page, rather than under the title (the way it does in posts). Maybe you missed it for that reason. Perhaps check again?

  5. smartyd
    Member
    Posted 10 months ago #

    I did check and it's not there. This should be a WP issue, right? Is it because I have comments turned off?

  6. esmi
    Forum Moderator
    Posted 10 months ago #

    No. It's theme-specific.

Reply

You must log in to post.

About this Topic