WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Can't Edit or Update and existing Post with JetPack Active (7 posts)

  1. tmcsween
    Member
    Posted 9 months ago #

    I love JetPack and use it on several self hosted blogs. But I have run into a major stumbling block.

    Anytime I try to edit an existing post, clicking the Update button does nothing. This even happens sometimes when I am trying to Publish a new post that has been previously saved.

    If I exit the article and edit it again, WordPress shows that there is an automatic backup that is newer than the current article.

    The only work around I have found is to deactivate JetPack, update the post, and reactivate JetPack. This is happening on several of my websites.

    http://wordpress.org/plugins/jetpack/

  2. Wastabik
    Member
    Posted 9 months ago #

    Do you get a 404 error when you update or publish a post?

  3. tmcsween
    Member
    Posted 9 months ago #

    No. Nothing happens. When I click Update or Publish, normally a small wait symbol appears to the left of the button. In this case the button does nothing and acts like it was never clicked.

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    Could you open your browser's Javascript Console, and check if an error appears when you click the Update button?
    http://webmasters.stackexchange.com/questions/8525/how-to-open-the-javascript-console-in-different-browsers

    If so, could you copy this error here?

    You might also want to try to disable the Spelling and Grammar module, to make sure the problem is not linked to that particular module. You can follow the instructions here to learn how to disable a Jetpack module:
    http://jetpack.me/support/#turn-off-jetpack-modules

    Thanks!

  5. tmcsween
    Member
    Posted 9 months ago #

    Thanks for the response Jeremy. No errors shown when I click Update. But, I think you may have hit on the issue with the Spelling and Grammar module.

    As soon as I disable the first two options for Automatic Proofreading, the issue goes away. I was able to leave the remaining grammar boxes checked.

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    As soon as I disable the first two options for Automatic Proofreading, the issue goes away. I was able to leave the remaining grammar boxes checked.

    Your hosting provider might be limiting the number of outgoing requests your site makes to our spellchecker service. Could you contact them, and ask them if they limit the number of requests to WordPress.com or afterthedeadline.com?

    Thanks!

  7. tmcsween
    Member
    Posted 9 months ago #

    I'll check and let you know. I currently have this occurring on blogs on two different hosts (DreamHost and 1and1).

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.