WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Can't edit any pages or posts after 3.5 everything is blank? (33 posts)

  1. unlockmystic
    Member
    Posted 1 year ago #

    After upgrading to wordpress 3.5 I can't edit any of my pages or posts. When I click on "edit page" or "edit post" the edit text box is completely blank and the word count says '0' even though I put content in there previously and there IS content on the page but it is not showing up. I also cannot type anything inside the blank box or click on the 'text' tab. The website looks the same even after clearing the cache and clearing my browser cache, but I just can't edit anything. Here's a picture of the problem (it looks like this on all my pages and posts)http://i49.tinypic.com/15p0869.jpg
    My website is http://www.unlockmystic.com. Thanks for the help and taking the time to read this, I really really appreciate it.

  2. Have you read through http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list yet and, if so, what debugging steps have you already tried?

  3. TruePleasures
    Member
    Posted 1 year ago #

    I'm having the same issue. Also, none of the categories such as "Tools" or "Settings" in my dash no longer show a pop-out of subcategories to pick from. I can even click some tabs in various plugin editing pages or interact with some of them. I've deactivated all of them and cleared my cache, but that hasn't worked.

  4. unlockmystic
    Member
    Posted 1 year ago #

    Yes, I read it, I've tried:

    - upgrading all plugins
    - upgrading all themes
    - switching to twenty twelve and back
    - switching to twenty eleven and back
    - deactivating all plugins (problem was still there after all plugins deactivated)
    - clearing wp super cache
    - clearing browser cache

    I still cannot edit anything on my pages b/c it appears as blank.

  5. unlockmystic
    Member
    Posted 1 year ago #

    ^ ( I'm almost getting the 'no drop down of submenus' problem as TruePleasures) ^

  6. TruePleasures
    Member
    Posted 1 year ago #

    Unlockmystic,

    Are you also having issues replying to comments and such? I can't do that either..

  7. unlockmystic
    Member
    Posted 1 year ago #

    no, I can reply to comments.

  8. unlockmystic
    Member
    Posted 1 year ago #

    Hey, TruePleasures, I fixed my problem if you are still looking for the answer. It was caused by a plugin called Bulletproof security. I found the answer on this earlier thread. Cheers!

  9. amazone.fec
    Member
    Posted 1 year ago #

    i do have the same probles.... cant edit HTML and word count 0.....

  10. rossebow
    Member
    Posted 1 year ago #

    I'm having the same problem with edit posts. The word count doesn't update when i add new text and changes don't go through. I've looked in the DB and the revisions all have the exact same text no matter what changes I make.

  11. rossebow
    Member
    Posted 1 year ago #

    actually just noticed word count is working but edits aren't working.

  12. rossebow
    Member
    Posted 1 year ago #

    I am not using Bulletproof security by the way!

  13. felixstowe.property.news
    Member
    Posted 1 year ago #

    For me I cannot use the media uploader from within a post since upgrading to 3.5. When I click on 'add media', nothing happens.

    I can upload an image to the image library, but not attach it to anything.

    Also, although I usually only use text with creating a post, I notice I cannot use the visual option.

    All plugins are up do date.

  14. Marcelusive
    Member
    Posted 1 year ago #

    I cannot add any posts to my blog or alter the widgets. I deactivated all plugins and erased all bit Jetpack and Disqus. I am very frustrated. I also deleted all themes except for the twenty ten twenty eleven and twenty twelve. My current theme is Atahualupa. I'm not very tech savvy so I can't figure out how to downgrade.

    Any suggestions?

  15. rossebow
    Member
    Posted 1 year ago #

    Right, I can make text updates through the Visual editor but any changes through the Text editor don't hold.

    I'm also getting these JS erros:

    Two of these on every page: Uncaught TypeError: Cannot read property 'length' of undefined

    And this on the Edit Post page:

    Uncaught TypeError: Object [object Object] has no method 'uniqueId'

  16. rossebow
    Member
    Posted 1 year ago #

    Just realised this has been marked as resolved! so i've started a new thread.

  17. caseyctg
    Member
    Posted 1 year ago #

    I fixed this same bug by manually updating wordpress. I believe there was an issue with the autoupgrade feature. Try manually replacing your wordpress files and see if that works for you. It fixed my issues.

  18. sanderbaks
    Member
    Posted 1 year ago #

    Add one line to the WP_Config.php.. Worked for me:

    define('SCRIPT_DEBUG', true);

    Add that line right before:

    /* That's all, stop editing! Happy blogging. */

    Not my solution, I just found it somewhere..

  19. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    No! That is a server-specific fix for a very specific issue. Please do not post it as a solution to everything.

  20. felixstowe.property.news
    Member
    Posted 1 year ago #

    I followed advice elsewhere on this forum and added

    define('CONCATENATE_SCRIPTS', false );

    to the wp-config.php file just before require_once(ABSPATH . 'wp-settings.php')

    That solved the issue.

  21. mictro
    Member
    Posted 1 year ago #

    I've also had the same issue on AndroidsChick.com

    It was driving me crazy....I've done the step by step deactivating plugins and testing.... and on my installation it was the

    Widget Logic Visual plug in! Once deactivated everything was back to normal! :)

    Now I have to find a replacement for the Widget Logic plug in since all my Widgets are visible!

    Hope this helps someone in solving this horrible issue.... :)

  22. KrisArgent
    Member
    Posted 1 year ago #

    what sanderbaks said. ;-)

    Adding
    define('SCRIPT_DEBUG', true);
    to my WP_config.php file stopped all that jazz...

    Sure glad I didn't have to do all the big drastic steps.
    My site was not working in any browser.
    Now it does! :-)

  23. caseyctg
    Member
    Posted 1 year ago #

    SCRIPT_DEBUG is a related constant that will force WordPress to use the "dev" versions of core CSS and Javascript files rather than the minified versions that are normally loaded. This is useful when you are testing modifications to any built-in .js or .css files. Default is false.

    define('SCRIPT_DEBUG', true);

    by adding this to your wp-config file, you are essentially just using the un-minified versions of javascripts and css. So it seems to me, the core of the problem is in fact within the css and javascript. BUT, if you add that line of code to your config file, you've just added extra file size to your scripts and css. The question then is how much extra file size does it add by adding that line of code? Not a huge issue for most, but when dealing with SEO, file size and load speed are a big deal, and adding un-minified scripting can make a large difference.

  24. mikegomak
    Member
    Posted 1 year ago #

    Ive deleted all plugins and removed fully un-necessary plugins and still have this issue. Can anybody recommend what looks like the best and cleanest solution to avoid the extra file size issue using the SCRIPT_DEBUG method above?

  25. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @mikgomak - please start your own thread rather than posting in an old one that is already marked resolved.

  26. shaimun
    Member
    Posted 1 year ago #

    Hi - I have a similar problem on my 3.5.
    When opening up a edit page or post, safari takes tooooo long to load.
    Any changes made to the text or cannot be updated. It shows this error:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@how-to-lose-weight-naturally-and-fast.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

  27. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @shaimun - please start your own thread if you need help. This one is old and marked resolved - you won't get help here.

  28. shaimun
    Member
    Posted 1 year ago #

    @WPyogi - How do I create a new thread? I cannot find the link - I'm having a bad day today :)

  29. juusan
    Member
    Posted 1 year ago #

    Removing all the BulletProof garbage from the .htaccess file worked for me, too.

    From the other thread:

    I think I found the cause.

    I'm using the BulletProof Security plugin, and even though I disabled the plugin, it leaves the .htaccess file full of "Bulletproofing". When I changed the .htaccess file back to "Default Mode" and activated it, the JQuery error disappeared and the admin screen worked.

    Sounds like BulletProof Security is the issue.

  30. nghipro
    Member
    Posted 1 year ago #

    felixstowe.property.news
    Member
    Posted 2 months ago #

    I followed advice elsewhere on this forum and added

    define('CONCATENATE_SCRIPTS', false );

    to the wp-config.php file just before require_once(ABSPATH . 'wp-settings.php')

    That solved the issue.

    => this help me can edit, click "add pic/media..."

    thanks,

Topic Closed

This topic has been closed to new replies.

About this Topic