WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] can't drag widgets, edit posts, etc. in 3.5 (14 posts)

  1. Gretchen Louise
    Member
    Posted 1 year ago #

    After the upgrade, I couldn't drag or edit widgets, edit posts, or even select all the posts on one page by clicking the top check mark box. I had the widget dragging issue even in a fresh install with no plugins. Turning on script debugging solved the issues for me. My question is whether it's okay to leave script debugging on until there's an update? Thank you!

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 1 year ago #

    It would be better to find the underlying cause of the problem. If you like, I can take a look at your site directly with the script debugging disabled, so as to see the problem for myself.

    Email me login information at otto@wordpress.org and I'll gladly take a look for you.

  3. Gretchen Louise
    Member
    Posted 1 year ago #

    Thank you, Otto. I just emailed you.

  4. quantaweb
    Member
    Posted 1 year ago #

    I had the same problem you had. Are you using (or have you ever used) the Bulletproof Security plugin?

    Bulletproof Security puts an .htaccess in the wp-admin folder that will prevent widgets from working correctly in 3.5.

    Here's the link where I found that info: http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    After deleting the .htaccess file that Bulletproof Security added in my wp-admin folder, all was well.

  5. lyndonr
    Member
    Posted 1 year ago #

    Same issue here. At first I thought it was browser-specific, but that doesn't seem to be the case.

    I have no .htaccess files in my admin folder and I've removed everything from my root .htaccess except wordpress's stuff. I do not have mod_pagespeed enabled.

    My current thought is that it's CDN's (cloudflare) optimization settings.

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 1 year ago #

    For reference, gretchenlouise's problem turned out to be a couple of rules in the "PerishablePress 5G Blacklist", which had been added to her .htaccess file.

    I added this information to the master list, along with a fix.

  7. Gretchen Louise
    Member
    Posted 1 year ago #

    I had the 5G blacklist on one site, and the BulletProof security install on my primary domain was apparently affecting the subdomain of the fresh install I did. So it was the square bracket issue both places.

    Many thanks to Otto for his troubleshooting! It's the first major issue I've ever had with upgrading WP.

  8. svehex
    Member
    Posted 1 year ago #

    Same issue here, upgraded today. I'm running a multisite with 7 sites, and it seems to be affecting all of them. Everything was working perfectly before I upgraded. It's a relatively new install. I use Wordfence, so I don't have the .htaccess in wp-admin, and I don't use the pershable 5G blacklist or BulletProof security.

    My site is at heksebua.com

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    As per the Forum Welcome, please post your own topic. Your problem - despite any similarity in symptoms - is likely to be completely different.

  10. lyndonr
    Member
    Posted 1 year ago #

    Ahh yes, that was a known issue in the 3.5 troubleshooting master list, however I'm not using that.

    I just disabled cloudflare to no effect. Now I'm really puzzled.

    again, my .htaccess is totally clean. I suspect it's something being done on the hosting level.

  11. lyndonr
    Member
    Posted 1 year ago #

    Thank you esmi, you are correct. I will start a new topic.

  12. Corza
    Member
    Posted 1 year ago #

    My culprit was BulletProof Security Plugin leaving behind the affected htaccess file. all fixed now . thanks quantaweb.

  13. svehex
    Member
    Posted 1 year ago #

    My culprit was Widget Logic Visual

  14. slgramacho
    Member
    Posted 1 year ago #

    In my case it was Installer by OnTheGoSystems. Deactivated it and now I can edit my widgets section.

Topic Closed

This topic has been closed to new replies.

About this Topic