WordPress.org

Ready to get started?Download WordPress

Forums

can't do step 3 on installation (7 posts)

  1. v2006
    Member
    Posted 7 years ago #

    When installing I can do step 1 and step 2, receive the un and pw but when I go to step 3 it just presents a list of ffiles

    ie http://www.homes-montgomery-county-maryland.com/blog/wp-admin/

    I use SmartFTP and FireFox.

    Please advise

  2. moshu
    Member
    Posted 7 years ago #

    For the mment: add index.php at the end of the URL above.
    Next: talk to your host "to make index.php a valid index file".

  3. v2006
    Member
    Posted 7 years ago #

    Thanks for the swift response

    it works when adding index.php.
    When I try to access homes-montgomery-county-maryland.com/blog/ I get the same list again unless I place index.php at the end.

    Is is a web host problem?

  4. moshu
    Member
    Posted 7 years ago #

    Is is a web host problem?

    Yes, so don't waste time here - contact your host ASAP as I said above!

  5. v2006
    Member
    Posted 7 years ago #

    thanks...any idea why I could successfully install WP blogs on this same server previously?

    ie homes-anne-arundel.com/blog/

  6. MichaelH
    Member
    Posted 7 years ago #

    Who's your host. Some hosts, ixwebhosting comes to mind, have server settings for each and every domain.

  7. Brian Layman
    Member
    Posted 7 years ago #

    This is something that can be done by either the server configuration, virtual server configuration or by the .htaccess files. In all of these places it is the DirectoryIndex setting.

    Yours probably looks similar to:
    DirectoryIndex index.html

    Talk to your host, the current setting is WRONG for a server with PHP installed. You need to get this fixed soon.

    I actually recommend that you fix this on your own first and formost. The bottom most setting is .htaccess this will override the server settings and put your settings in for the current directory tree.

    So, put a file called .htaccess in your BLOG directory and add this as the first line (Edit the file if it already exists):
    DirectoryIndex index.php index.htm index.html

    Here's the official documentation:
    http://httpd.apache.org/docs/2.0/mod/mod_dir.html#directoryindex

    You really don't want people browsing all of your php folders. Personally, I would have them turn off the directory listing too. You should just give a 403 if there is no index file...

Topic Closed

This topic has been closed to new replies.

About this Topic