WordPress.org

Ready to get started?Download WordPress

Forums

Google Analytics for WordPress
Can't dismiss "Help improve Google Analytics for WordPress" message (17 posts)

  1. devrap
    Member
    Posted 1 year ago #

    Ugh, this message is so intrusive and can't be dismissed. I've gone in and changed my GA for WP settings and resaved, and no matter what I do, this message remains on the top left--the "Do not allow tracking" button doesn't dismiss it. Horrible! I'm about to use a different plugin.

    http://wordpress.org/extend/plugins/google-analytics-for-wordpress/

  2. richardhovdsven
    Member
    Posted 1 year ago #

    Ahhh. Have the same problem. Please release an fix.

  3. richardhovdsven
    Member
    Posted 1 year ago #

    Until fix: Add this in the bottom of your /wp-admin/index.php, so it wont bother you as long.

    You probably already know this already, but just in case:

    <style>
    #wp-pointer-0 {
    display:none !important;
    }
    </style>

    Edit: /wp-admin/admin-footer.php is the correct file to put this in.

  4. devrap
    Member
    Posted 1 year ago #

    Thanks so much for the tip, richardhovdsven!

    I'm wondering why this isn't a more prominent problem on the forums. Are you by any chance running SEO Yoast as well? I wonder if this only happens for those who are using both Google Analytics for WordPress and SEO Yoast plugins together.

    SEO Yoast has a similar problem, but re-saving settings there dismisses the SEO message window (then showing the Google Analytics one).

  5. Grimpond
    Member
    Posted 1 year ago #

    While we are talking about it... why does clicking 'no thanks' to tracking send me to the settings page?

    That is just mind-bogglingly annoying..! and a waste of time?

    G

  6. Jos Klever
    Member
    Posted 1 year ago #

    The message is also shown to non-admin-users, who can't change this setting. It makes it very hard to use the dashboard for them.

  7. Daniel J. Lewis
    Member
    Posted 1 year ago #

    Horrible. HORRIBLE! This has prevented users of my multisite from posting until I and only I login to every single site and click "No thanks."

    There are better ways this should have been handled. Like standard ways that plugins post a notification in the dashboard.

  8. I click 'do not allow' and it closes right away, no issues with the latest version. I also tested with running both Yoast's plugins at the same time on a fresh install of WP. I was not able to reproduce the dismissal error.

    I grant you it's annoying, but it's not against the rules at this time.

  9. Daniel J. Lewis
    Member
    Posted 1 year ago #

    Clicking "do not allow" doesn't work for anyone other than admins, and it prevents usability of a site. On Multisites, anyone other than a super-admin doesn't seem able to click "do not allow."

    And clicking "do not allow" annoyingly redirects to the settings page for Google Analytics for WordPress.

  10. bitoolean
    Member
    Posted 1 year ago #

    I'm not using multisite, although I am using a handful of good plugins which haven't caused issues on the admin side before though.

    The "help improve" message always shows, there's only one button (to deny sharing of statistical data), it has a fixed position at coordinates 0, 0 and clicking the button doesn't do anything.

    I'm just learning PHP and I may not understand the code well, but could there be something wrong with the following conditional?
    if ( !isset( $options['tracking_popup'] ) && !isset( $_GET['allow_tracking'] ) )

    I've recently updated to WP 3.4.1 as well.

    EDIT: As an alternative temporary fix, I've edited the class-pointer.php, by commenting out the whole content of the enqueue() function. That portion is responsible with displaying the box on the admin panel.

  11. richardhovdsven
    Member
    Posted 1 year ago #

    Hi, in my case it was not possible to move the window, click the button and what every i did, it would not disapear.
    Still have the same problem, but then again, its not there.

  12. Okay, I was finally able to reproduce this. Yep, non admins can't click away.

    FWIW, it's still not against the rules, but it is a bug. Which I'll make sure is reported.

  13. akomakom
    Member
    Posted 1 year ago #

    I am admin, and I can't dismiss it (it comes back on reload). Not pretty.

  14. yowzer
    Member
    Posted 1 year ago #

    Editing line 28 of the class-pointer.php file is the best workaround that I've found.

    #add_action( 'admin_print_footer_scripts', array( $this, 'tracking_request' ) );
    add_action( 'admin_print_footer_scripts', array( $this ) );

    The only thing that eliminates is printing the tracking request.

  15. salsatrips
    Member
    Posted 1 year ago #

    same bug!

  16. jautin
    Member
    Posted 1 year ago #

    It's very nice of richardhovdsven to have provided a pseudo-fix. Alas for me, I haven't a clue what he's talking about. Can anyone translate it into non-programmer English for the Luddite masses? Thanks!

  17. devrap
    Member
    Posted 1 year ago #

    Hey, yowzer--well done. This solution fixed it! And as it pertains only to this plug-in script, it doesn't affect potentially important warning messages from other plug-ins, so is definitely a preferred solution.

    I have no idea why Yoast has not attended to this really intrusive bug. I sent email as well, just to ensure the author was aware, but never heard back.

    Many thanks for locating the culprit and providing a great solution for blocking it. (Though it will need to be re-edited, no doubt, after each future upgrade unless/until it's dealt with from the author.)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic