WordPress.org

Ready to get started?Download WordPress

Forums

Can't disable SAFE_MODE now what? (3 posts)

  1. Niemi
    Member
    Posted 6 years ago #

    I'm trying to activate WP Super Cache but I get this error:

    Warning! PHP safe mode enabled!

    You may experience problems running this plugin because SAFE MODE is enabled. Your server is set up to check the owner of PHP scripts before allowing them to read and write files.

    You or an administrator may be able to make it work by changing the group owner of the plugin scripts to match that of the web server user. The group owner of the wp-content/cache/ directory must also be changed. See the safe mode manual page for further details.

    Warning: mkdir() [function.mkdir]: Unable to access /var/www/kreativpotens.dk/public_html/wp-content/cache/ in /var/www/kreativpotens.dk/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 706
    Error: Your cache directory (/var/www/kreativpotens.dk/public_html/wp-content/cache/) did not exist and couldn't be created by the web server.
    Check permissions.
    Cannot continue... fix previous problems and retry.

    It's my host's policy to have SAFE_MODE turned on, so what can I do?

  2. Niemi
    Member
    Posted 6 years ago #

    Ok, I didn't have the cache folder (wp-content/cache) which halted the installation. Now I was allowed to enable it, but it still tells me that it's not quite good that SAFE_MODE is enabled.

    Should it do me any harm, or will I just have to wait and see?

  3. Niemi
    Member
    Posted 6 years ago #

    It seems to work quite all right after all.

Topic Closed

This topic has been closed to new replies.

About this Topic