WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Can't disable Facebook Open Graph (10 posts)

  1. creativelevity
    Member
    Posted 1 year ago #

    WordPress version: 3.5.1
    WordPress SEO version: 1.4.4

    I did this: In WP SEO, on the Social settings, I unchecked "Add OpenGraph meta data" and clicked "Save Settings." I have toggled the setting back and forth to test it. No different results. When I disable the plugin the open graph tags go away. I am not inserting open graph meta with any other plugin or in my template. I have triple checked.

    I expected the plugin to do this: To not add any open graph meta tags to my site's head when the above setting is unchecked.

    Instead it did this: Open graph meta tags remain unchanged no matter if the setting is checked or not.

    Thanks for any help!

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Checo
    Member
    Posted 1 year ago #

    Hi,

    I have the same problem. I want to disable Facebook OpenGraph meta data and when I uncheck "Add OpenGraph meta data" at the "Social" section, all OG meta tags remain.

    Also using WP 3.5.1 and WP SEO Plugin 1.4.4.

    Any help on how to disable FB OP would be greatly appreciated.

  3. Tommy White
    Member
    Posted 1 year ago #

    I have the same problem and would like to find a way to resolve it, short of switching to another SEO plugin.

  4. Checo
    Member
    Posted 1 year ago #

    Hi guys,

    I solved this problem by copying on a notepad all my WordPress SEO configuration and going to the SEO/Dashboard and click the "Reset Default Settings" button.

    I had to re-configure everything again (reason why I copied all the settings before reseting it) but it's now working just fine.

    Hope this helps! :)

  5. Tommy White
    Member
    Posted 1 year ago #

    Tried resetting but it did nothing for me :(

    With default settings it still adds the meta tags for Facebook.

  6. Tommy White
    Member
    Posted 1 year ago #

    Anyone else have a solution? Maybe a way to disable it with a custom function? I posted this same problem 5 weeks ago and also tried contacting them directly several days ago..

  7. Tommy White
    Member
    Posted 1 year ago #

    Well after months of trying to get support on what causes this, it happens on every site I own, with or without other plugins installed, I just decided to disable the call to insert the graph manually from wp-seo.php at or around line 77. This disables Facebook, Twitter and Breadcrumbs I beleive. Either way it works where it wouldn't work before.

  8. eminentstyle
    Member
    Posted 1 year ago #

    I am having the same problem here. Toggling the check box makes no difference as to whether Open Graph is disabled. Its always on.

  9. Tommy White
    Member
    Posted 1 year ago #

    I found a better way to resolve this since there doesn't seem to be any support. in class-opengraph.php somewhere around line 37 is the call to insert all the facebook meta tags. I removed these calls and it works as intended now, since I have a custom function that does this, and have tried for months to reach someone at Yoast. Hope this helps someone!

  10. JS Morisset
    Member
    Posted 7 months ago #

    Try adding the following to your functions.php file:

    global $wpseo_og, $wpseo_twitter;
    remove_action( 'wpseo_head', array( $wpseo_og, 'opengraph' ), 30 );
    remove_action( 'wpseo_head', array( $wpseo_twitter, 'twitter' ), 40 );

    js.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic