WordPress.org

Ready to get started?Download WordPress

Forums

Can't Delete Posts? (35 posts)

  1. lordryan
    Member
    Posted 7 years ago #

    Hello...i'm having an issue where i can't delete posts from the control panel. It visually disappears but when i try to go to another area of the cp it says "are you sure you want to navigate away from this page?"....when i do the post shows up again when i go back to "edit posts"...any suggestions?

  2. wordsetc
    Member
    Posted 7 years ago #

    This is just the problem I'm searching the forums for an answer to. I recently upgraded 3 of my blogs to 2.1 and only one of them doesn't work. I've tried emptying the cache, using FireFox and IE 7 and various other things. I can't delete either a post or a page and can't add a category either. I can add pages and posts however. Any ideas?

  3. thecitydesk
    Member
    Posted 7 years ago #

    Exactly the same problem here. It won't let me do much to edit new ones, either.

  4. geekninja
    Member
    Posted 7 years ago #

    I'm having the same problem deleting Pages.

    Is anyone at WP doing anything about this issue?

  5. bargainquest
    Member
    Posted 7 years ago #

    Glad I'm not the only one. I just switched to WordPress and I haven't even been able to delete the Hello World post(it just comes right back), or edit it (I save changes and it just erases them). New posts only save my headlines, not my text.

  6. hacktic
    Member
    Posted 7 years ago #

    Same problem here.
    I also can't create categories.

  7. incrementalist
    Member
    Posted 7 years ago #

    I'm experiencing this (can't delete posts or add categories) too, on a brand-new install that I did using Dreamhost's 1-click installation. It seems like maybe some of the fancy AJAX operations are failing silently. I don't know how to fix it, but here are some workarounds:

    • For categories, the "Category Manager" plugin (available here) will let you edit categories.
    • To delete a post, go to the "edit" page for that post, and then click the "Delete" button under the text field.
  8. miletjs
    Member
    Posted 7 years ago #

    same here

  9. miletjs
    Member
    Posted 7 years ago #

    incrementalist, I want a permanent solution not a workaround.

    I hope WordPress team will update their 2.1 soon as it appears to have more problems than 2.0.5 meaning I can get to appreciate 2.0.5 more than 2.1 because of these "bugs"

  10. gil
    Member
    Posted 7 years ago #

    I don't know if it's related, but running WP2.1 on IE6 on W98, when I get the Manage Posts screen up, and try to put the mouse on an EDIT or DELETE button, all the posts scroll down before I can click the button, and they do it again and again if I chase them. I fancy it's some smart mouseover code, but it didn't happen on the previous version.

  11. gil
    Member
    Posted 7 years ago #

    Well, strike that one from the record... Updating my elderly IE6 to SP1 did the trick.

  12. trojanloy
    Member
    Posted 7 years ago #

    I had this problem (or a slight variation of it) too, after upgrading from 1.5.2 directly to 2.1. I reverted to my backups, then tried upgrading incrementally from 1.5.2 to 2.0 to 2.0.7 to 2.1. That solved the problem.

    You can see my help ticket here.

    If you have pre-upgrade backups, I would suggest reverting to the prior version and re-upgrading incrementally. Of course, you'd lose any comments and posts that were added to the database since the original upgrade, but if you have access to MySQL through phpMyAdmin or whatever, it would be pretty easy to move those over into the re-upgraded database.

    Alternatively, over on this thread, elpis2000 proposed a solution involving the wp_options table in MySQL. I don't know whether it works, as I've already fixed the problem on my blog through the incremental-upgrade method, but you might want to try it.

    For what it's worth, there's also discussion of this topic here. I agree that WordPress really needs to address this -- it does seem to be a common, if not universal, problem in non-incremental upgrades to WordPress 2.1, and there's nothing in the documentation suggesting that you need to upgrade incrementally. So WP needs to either diagnose & fix the problem, or else at the very least, add a warning to its upgrade instructions telling people to upgrade incrementally.

  13. AtomicFusion
    Member
    Posted 7 years ago #

    I think I found a solution (at least it worked perfectly for me, and it makes some sense).
    Let me tell you first the scenario I had:
    - WordPress 2.1, fresh install
    - K2 theme (0.9.5 RC1)
    - Server: Win2003 / IIS 6 / PHP 5.2.1 / MySQL 5.0.22
    The problem I had: When deleting a post from the Admin > Manage section, the entry disappeared but after a refresh, the post was still there.

    I noticed that this only happened when K2 was active, so I traced the problem deep down to the file prototype.js, which wasn't being loaded from the core WP files if K2 was selected.

    It would be wise to backup the files involved, just in case something goes wrong.
    So, open the file wp-content/themes/k2/js/prototype.js.php and delete everything except for the first php tag (the one that looks something like

    <?php
    	// check to see if the user has enabled
               gzip compression....
    
    ... some more code here (about 15 lines)...
    
    	header('Content-Type: text/javascript;
                    charset: UTF-8');
    ?>

    Now, copy the entire contents of wp-includes/js/prototype.js to the end of your recently modified prototype.js.php file. Now save/put the file back on the server.

    Now, go to the admin > manage posts area, clear your browser's cache (or press CTRL+F5 on Internet Explorer, so you force a complete refresh). The delete buttons should be working now (worked for me).

  14. miletjs
    Member
    Posted 7 years ago #

    i dont think that is applicable in my problem because i dont have k2 theme installed but i still encounter the problem

  15. Trahald
    Member
    Posted 7 years ago #

    I'm having this problem too. WP 2.1.1, new install. Things were working fine earlier in the week, but now there's lots of problems.

    In IE, the admin stylesheet doesn't seem to work at all. I can delete posts, but the WYSIWYG editor doesn't allow me to input anything.

    In FireFox, the stylesheet works fine, but I can't switch over to the code view when writing a post. And while I can post new posts and the post title will register, anything I type into the WYSIWYG won't - the posts will be blank. Also I can't delete posts.

    I deleted my cookies and restarted my browsers but the problems persist in both browsers.

  16. Belle
    Member
    Posted 7 years ago #

    I'm noticing the same thing happening. I'm working off of a fresh install of WP 2.1.2, and as I tweak things, I occasionally add a test post to see the result. The trick mentioned above (Edit the post, and delete it there) works, but it is awkward and totally non-intuitive. I wouldn't care so much for myself, but I'm designing the blog for another to write in, and my goal is to make his writing experience as hassle-free as possible.

    A fix on this would be appreciated.

  17. glendude
    Member
    Posted 7 years ago #

    i had the same problem. turned off lightbox plugin and everything worked again!! definately has something to do with that prototype.js file!

  18. fansoftech
    Member
    Posted 7 years ago #

    I seemed to have been having this same issue. Deleting a post visually worked but, refresh the Manage posts page and the post magically re-appeared.

    However, I fixed the issue by disabling each of my plugins, created a variety of new temporary posts, and then deleted the new posts one-by-one after reactivating plugins one-by-one. This method of elimination allowed me to find that there was a plugin, Google Sitemaps 2.7.1, that was creating this issue. This plugin, btw, was also causing a blank page to appear after creating a new post...I think. Anyways, if any of you are running this plugin, you might try disabling it. If not this plugin, then you might try the same method of elimination with your other plugins. Post back if my explanation didn't make sense.

    Thanks,
    J

  19. pierreyann
    Member
    Posted 7 years ago #

    i just installed wordpress 2.2 from scratch and i'm experiencing the same problem. no theme or anything, imported my blog from blogger and can't delete the "hello world" posts . (except with what incrementalist suggested, which is handy right now but a not quite useful in the long run...).

  20. Grooverider
    Member
    Posted 7 years ago #

    Same here. Fresh 2.2 install with fantastico. Can't do nothing. Remove posts, comments, add users, etc.
    Anyone with a step by step (for dummies) solution?
    2.1 worked like charm. :(

  21. v2006
    Member
    Posted 7 years ago #

    I'm experiencing the same with 2.2
    Is there any solution in the forums...I could not find any?

  22. Marcel Brinkkemper
    Member
    Posted 7 years ago #

    In the Manage page, the list is updated by Ajax script. A problem there is that a lot of servers block the headers of the updated lines.
    try to add a .htaccess file in your wp-admin folder with the following lines:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>
  23. pascoedj
    Member
    Posted 7 years ago #

    macbrink, I don't understand your .htaccess solution and would like to know more before I change my .htaccess in case of a security problem.

    The Google Sitemaps plugin is definitely causing this problem in my WP install as well, so a better solution than deactivating the plugin every time I want to delete a post would be nice.

  24. sideiron
    Member
    Posted 7 years ago #

  25. seoras
    Member
    Posted 7 years ago #

    macbrink,
    your solution to add an .htaccess file to the wp-admin folder with

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    did the trick for me. My WP 2.2 was completely screwed up, Dashboard was a mess showing the index page all over the place, I couldn't edit posts, delete or create categories and sometimes was thrown out to the admin login screen for no apparent reason. I don't fully understand the fix but I know it's a problem with Ajax and some servers. I spent a lot of time blaming my host for this but they couldn't supply an explanation.
    Thanks.
    Seoras

  26. DevilSun
    Member
    Posted 7 years ago #

    Я знаю и вам не скажу!!!!

  27. kallywag
    Member
    Posted 6 years ago #

    @sideiron: the solution you linked to from itmilk.com worked for me as well.

    summary: make sure the URL you have set for wordpress(and blog) in the 'Options' tab is the same as the URL you may have your .htaccess file redirecting to.

    For me, I was redirecting http://www.domain.com to domain.com, but in the 'Options' tab I had my WordPress URL set as http://www.domain.com, which was throwing off the AJAX script for deleting posts/pages.

  28. bugster
    Member
    Posted 6 years ago #

    you guys saved my butt. The itmilk.com solution worked for me.

    My blog is scheduled to go live tomorrow and found this bug today. 60 authors all raring to go. I would have been dead meat if I couldn't get this working.

    Whew.

  29. rsrchandran
    Member
    Posted 6 years ago #

    Thanks a lot guys, itmik.com solution worked for me too, as i wasnt able to delete posts or categories

  30. dfgarkitekt
    Member
    Posted 6 years ago #

    I too couldn't post, edit, delete, and sometimes, even log in to WP.

    As summarized by Kallywag, I was re-directing to http://www.domain.com in my .htaccess file, and the Fantastico (automatic) install of WordPress had input the non-www version of the URL under 'Options'.

    Once I put the correct url in there, all functionality was restored.

Topic Closed

This topic has been closed to new replies.

About this Topic