WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Can't create Permalinks (5 posts)

  1. Daluxe
    Member
    Posted 2 years ago #

    Hi all!
    I'm totally new here although I'm using WordPress for a couple of years now.

    I just installed the NextGen Gallery Plugin (1.8.2) on my WordPress 3.2.1 Setup and everything works fine but the permalink structure... When I try to use permalinks in the plugin-settings the Checkbox disables itself after creating the permalinks (I don't even know, if permalinks where created correctly)... in the F.A.Q. section it says that I've to update my permalink structure after enabling the permalinks but I don't really know what I've to do, so I just set the file permissions of my .htaccess file to 666 so the Script may change the rewrite rules automatically. When I tried to use albums without linking to the gallery it said something like http://www.domain.com/sitename/?album=2&gallery=1

    Is there a problem with the plugin in WP 3.2.1 or does I missed to do some settings correct?

    cheers
    Daluxe

  2. alexz
    Member
    Posted 2 years ago #

    According to a blog post, it was a bug that it was impossible to create permalinks if you have the /%postname%/ (like I have) or /%category%/%postname%/ structure on WordPress, don't know if it's resolved yet. Do you have this structure for your WordPress platform?

    I have also asked the question here http://wordpress.org/support/topic/the-permalink-bug-resolved.

  3. Daluxe
    Member
    Posted 2 years ago #

    Hi alexz!

    I tried both /%postname%/ and /%category%/%postname%/ and neither of those worked... I'll give it another try and keep you informed... the post says that this issue has been resolved with the new update...

  4. alexz
    Member
    Posted 2 years ago #

    Thanks!

    Does other structures than you mentioned work for you?

    I haven't tried because I wouldn't like to confuse a Google-crawler if it came by.

  5. Daluxe
    Member
    Posted 2 years ago #

    I tried a few different structures but none of them worked... I just solved the thing with setting the links manually. Maybe Alex will have a solution for this issue...

    You could solve the google problem with some 301 redirects though :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.