WordPress.org

Ready to get started?Download WordPress

Forums

Participants Database
[resolved] Can't create new participants (16 posts)

  1. niutak
    Member
    Posted 1 year ago #

    I added a new participant today, hit submit and just get an error on a new page that states the below.

    Not Found !
    The page you are looking for is not here. Please try a different search or go back to the home page.

    http://wordpress.org/extend/plugins/participants-database/

  2. niutak
    Member
    Posted 1 year ago #

    I went back in and went section by section and then saved. Data fields saved ok, pics saved ok, it has something to do with the website url's. I have fields for Website, Twitter, Facebook and Other. I entered the first three without issue but when I added another Facebook link for the field listed as Other and save it, it gives me that error mentioned in my previous post. Does the database block similar type url's?

  3. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    How do you have the "Other" field set up (the field type, default, etc.) and what exactly were you trying to save in it?

    You should be able to save any link you want, it doesn't check for similarity...

  4. niutak
    Member
    Posted 1 year ago #

    It's listed as Other, has a open box to add a URL and another open box to Name the field similar to the illustration below. I have this the same for Website, Twitter, Facebook and Other and they have always worked before with no issue but trying to enter another Facebook URL and tried naming it Other and Facebook but it still just errors out per my first post above.

    Website URL box Name box

    Twitter URL box Name box

    Facebook URL box Name box

    Other URL box Name box

  5. niutak
    Member
    Posted 1 year ago #

    It seems to be occurring with other fields as well and seems random. I have a field for fighter records. I have twelve total, I updated 9 with no issue and then when trying to add just one number to the last three I get the same error from when I tried to save a link. So it's not just links, it's something else that is failing.

  6. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    niutak,

    Next time it happens, copy the URL in the location bar of your browser and post it here. I need to see what URL it's trying to reach.

  7. niutak
    Member
    Posted 1 year ago #

    When I tried saving only two extra characters in one field the error url is http://www.babesofmma.com/wp-admin/admin.php?page=participants-database-edit_participant&action=edit&id=1330 with message "Not found, The page you are looking for is not here. Please try a different search or go back to the home page."

    I tried the other participant which I had the link not saving and same not found 404 error message with url http://www.babesofmma.com/wp-admin/admin.php?page=participants-database-edit_participant&action=edit&id=1346

  8. niutak
    Member
    Posted 1 year ago #

    I just added a new participant today and same thing as the previous one, everything added fine but when I tried to enter the fourth and last URL section it errored out. Never had the issue before and strange.

  9. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    I'm still looking at this. Haven't been able to see the problem yet.

  10. niutak
    Member
    Posted 1 year ago #

    No problem, take your time and enjoy the holidays. I posed the question to my webhost support to.

    So far I can't update the last URL field for two participants, can't update pictures on one participant and can't add two characters to one field for three participants.

  11. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    niutak,

    I have an update to the plugin coming out that might solve your issue. However, the only way I'm going to be able to debug this, I think, is if you send me a login to see for myself what the issue is. If you're willing, email it to me and I'll have a look.

  12. niutak
    Member
    Posted 1 year ago #

    What is your email address and I will create an admin login for you. Will try to create it tonight or sometime tomorrow. Thanks for all the help.

  13. xnau
    Member
    Plugin Author

    Posted 1 year ago #

  14. niutak
    Member
    Posted 1 year ago #

    Great, I will create an admin login shortly and then email the info over to you in the next 5-10 minutes or so.

  15. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    So, for anyone who is having a similar problem, it seems to be due to a security rule getting triggered by the submission. The fix for this is to create a special exception in the configuration for mod_security (an Apache module) so the script can save the record.

    Check these forum posts for more information:
    http://wordpress.org/support/topic/404-not-found-eror-when-saving-post-with-hyperlink-added?replies=21
    http://wordpress.org/support/topic/mod_security-for-wordpress?replies=15

    In most cases, your hosting tech support will need to be contacted to set this up.

  16. niutak
    Member
    Posted 1 year ago #

    ModSecurity was the issue and thanks again for all the help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic