WordPress.org

Ready to get started?Download WordPress

Forums

Can't Create Line Breaks ARGH!! (21 posts)

  1. ateegarden
    Member
    Posted 5 years ago #

    I haven't been able to create line breaks in my paragraphs in ANY of the themes I've uploaded.

    Completely aggravating because I've read everything word press has on it and none of it helps my problem. Everything is one big massive paragraph and when I create bullet points they end up all the way over to the extreme left hand side of the page and again...look like crap.

    Help! lol.

  2. Guzzo
    Member
    Posted 5 years ago #

    What's your URL?

  3. ateegarden
    Member
    Posted 5 years ago #

    Sorry Guzzo it's http://www.newwayofwealth.com/blog

    I haven't posted anything on it because the lines won't break and it's all just a mass of stuff.

  4. ninah
    Member
    Posted 5 years ago #

    I'm having the same difficulty...one big blob of text, with no line breaks. Url is
    http://www.careermanagementalliance.com/blog/wp-admin/post.php?action=edit&post=396.
    While you're at it, can you explain why I can't get live hyperlinks? They appear as blue text but don't link. I'm following the correct steps but to no avail!

    Thanks for any help

  5. iridiax
    Member
    Posted 5 years ago #

    Try using the default theme that comes with WordPress, does the problem go away? If so, then the problem is your theme.

    Try disabling all of your plugins, does the problem go away? If so, then the problem is due to a plugin.

    Validate both your website and css. Errors in either can really mess up proper display.

  6. editormule
    Member
    Posted 5 years ago #

    I've been all over this forum for days and there is no fix. Every possible solution has been initiated to no avail.

    So, get this ya'll-- the following fixes do not work. They do not solve the no paragraph or line breaks in WP:
    Disabling plug-ins does not work.
    Disabling WYSIWIG does not work.
    Default WordPress theme does not work.
    Using Safari, Opera, Firefox, IE6-7 does not fix it.
    Validating website and CSS does not fix it.
    Adding p {
    margin: 0;
    padding: 5;
    margin-top: 5px;
    } to CSS does not fix it.
    Adding tinyMCE fix: editor_plugin_script.js from sourceforge does not fix it.

    Am I missing any other suggestions offered here that don't work?

    Googling "no paragraph breaks in wordpress" does not offer a fix that works.

    The lesson is: If your WordPress blog inserts paragraph breaks, do not upgrade, update, change themes or fiddle in any way, with your blog.

    WordWhore

  7. editormule
    Member
    Posted 5 years ago #

    FOUND A WAY AROUND THE PARAGRAPH LINE BREAK PROBLEM!!

    I copied the text out of Word document. Then I opened a new (empty) Google document, pasted the Word text into the document text area. No line breaks BUT
    when I go in and manually add line breaks for paragraphs-- they stay in place.

    Select All
    Copy
    Paste into WYSIWIG Word Clipboard
    Click Insert

    It works.
    Save the page and the line breaks remain.

    Tried the same technique in POST without using the WYSIWIG Word Clipboard and the line breaks remain in place!!

    Party at my house! Hope this works for other people. Please post here if it works or if it is fubarred. We need to solve this problem some way or another.

    WordWhore

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    You know, you might get more help if we understood what the heck you were talking about...

    What do you mean by "line breaks"? Please define what you're trying to do and we'll tell you how to do it.

  9. MoonbatWingnut
    Member
    Posted 5 years ago #

    Otto -

    I'm not the original poster, but I've experienced this as well.

    It seems to come and go. Inserting < br / > (properly formatted, it works fine here if I write it correctly!) or "<p>" doesn't have the expected effect, the white space is collapsed. I had it on one of my pages and then apparently did something that made the problem go away. I suspect there's something in the theme CSS that is doing it to "<p>", but it's odd that < br / > would just flat out stop working.

    TW

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Are you inserting multiple BR's in a row or something like that? Because WordPress very intentionally removes multiples of those in a row. Those are not the correct semantic way to make vertical spacing.

  11. MoonbatWingnut
    Member
    Posted 5 years ago #

    Yeah, that's how I've been doing several blanks lines made with breaks. It works, and not. What's the best way to create several lines of blank space?

  12. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Well, ideally, you wouldn't do that. This is the web. It's not like traditional publishing.

    See, on the internet, we have this thing called separation of content from presentation. Your "content" is the text itself, with little to no formatting. It's generally supposed to be fairly barren. The "presentation" then describes how to display that content.

    Why? Because when you separate the presentation from the content, then you can display the content in different ways. What if I don't want to see your content on the webpage? What if I use a feed reader? What if your content is syndicated to another website? The whole point is to make your content very plain, in order to enable it to be displayed anywhere and then presented according to where it is displayed.

    Adding vertical blank space is more a function of presentation. It's also something you probably don't want to be displayed everywhere. What about in a feed? What about if the content is presented on another site (you never know when you will want to migrate your content elsewhere)?

    So, the question really becomes not how to add this space, but why you want to add it. Is it to separate posts? Do you want the paragraphs to be further apart? Define what your goal here is, not how you wish to achieve that goal. Because what is the "right" way to do it highly depends on exactly what it is that you are trying to do.

  13. MoonbatWingnut
    Member
    Posted 5 years ago #

    Okay, thanks. I hadn't thought of it as separating content and presentation, but you're right. I was originally doing it for 'dramatic effect' on a single page. But it could just as easily be done with a couple of CSS style rules. Which is what I will do next time...

  14. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Anyway, the most obvious way to do it is to create a break with a specific height. For a 4 line break, you could put in <br style="height:4em" /> for example.

    But that should be used sparingly.

  15. mxmai
    Member
    Posted 5 years ago #

    if you use the TinyMCE Advanced plugin, there's an option to disable wordpress removing your extra line breaks. been fiddling around with this for a couple of hours now and that seems to be the simplest workaround.

  16. vdubplate
    Member
    Posted 5 years ago #

    Ok, so I to have been having this problem. I think word press's editor handles the formatting in a rather strange way obviously.

    So what I did and figured out accidentally is this: once I had everything formatted in html in the html editor, I went to the regular editor and saw my post looked like it was rendered correctly but once I tested it it still didn't displace the line breaks so I put my cursor in front to the first character of the second paragraph and I hit backspace until I was connected to the second paragraph and I hit enter once and tested again. I had a line break.

    So if you hit enter more than once it's not going to work. If you rely on p tags to give you a line break thats not going to work and either will break tags.

    This has been a big waste of time trying to figure this out. Hope this helps the next guy out.

  17. vdubplate
    Member
    Posted 5 years ago #

    Ok, so I wrote that last comment and when I went back to post another comment it didn't work, so then I tried this and it worked fine:

    <p style="align: left"></p>

    That seemed to work because if you just add a
    or <p></p> wordpress deletes those out automaticly.

  18. bertac
    Member
    Posted 5 years ago #

    All solutions I read here are about adding <p> tags etc. But that's not why we have a graphical editor. We have tinyMCE. If a blogger, without any knowledge of HTML want to add a piece of text, they start typing in the tinyMCE editor and hit enter at a certain moment. You would expect that WordPrss/tinyMCE adds a closing P and a new opening P tag. But this does not happen. At least, not while editing the page in FireFox. The browser Safari leaves the P tags alone, but FireFox removes them.
    So, solutions above are not working for me.
    Does anybody experience the same problem?
    We're using WordPress 2.7

  19. rhalpha
    Member
    Posted 5 years ago #

    I had this problem for a long time then finally solved it. I described it here:

    http://rubayathasan.com/wordpress/plugin/enabling-line-break-in-wordpress/

  20. FracturedFrame
    Member
    Posted 5 years ago #

    I pasted those last two lines into style.css:

    #main-content p {
    font-family:Arial;
    font-size:14px;
    padding:0;
    margin-top: 1em;
    margin-bottom: 1em;
    }

    Did the trick for me.

  21. mightysmith
    Member
    Posted 5 years ago #

    Hi guys. Here is the thing I have learned.
    is a id tag like any other <p><h1> and wordpress puts them into your code automatically when you insert a line break.

    So this is a CSS issue. Here is an example of one of my stylesheets entries to resolve this:

    br {
    font-size: 28px;
    margin-top: 15px;
    margin-bottom: 15px;
    }

    Works like a freaking charm. ;-)

Topic Closed

This topic has been closed to new replies.

About this Topic