WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't connect to wordpress.com to activate Jetpack (7 posts)

  1. theobroma
    Member
    Posted 2 years ago #

    Hello All,

    I am trying to activate JetPack in my self-hosted blog but when I click on "connect to wordpress.com" I get the following error message:

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32700
    Try connecting again. Error Details: The Jetpack server could not communicate with your site's XML-RPC URL. Please check to make sure http://www.MYDOMAIN.com/xmlrpc.php is working properly. It should show 'XML‑RPC server accepts POST requests only.' on a line by itself when viewed in a browser and should not have any blank links or extra output anywhere.

    My site's XML-RPC URL displays correctly.

    I am not using any caching plugins.

    I have tried connecting when logged in to my wordpress.com account and when logged out, but still get the same error message.

    I've also tried deactivating all plugins, to no avail.

    Anyone else have this problem or know how to fix it?

  2. mentalflush
    Member
    Posted 2 years ago #

    same problem here =/

  3. mentalflush
    Member
    Posted 2 years ago #

    found the solution here... worked for me... turn off the cache and try connect again http://www.shoutmeloud.com/wordpress-solution-your-jetpack-has-a-glitch.html

  4. theobroma
    Member
    Posted 2 years ago #

    I don't use a cache plugin, so that's not the issue for me.

  5. theobroma
    Member
    Posted 2 years ago #

    Here's the fix, thanks to some recent digging around on the Web:

    When viewing http://www.MYDOMAIN.com/xmlrpc.php I saw there was a blank line above the line "XML‑RPC server accepts POST requests only"

    The solution lies in the functions.php file.

    When opened with TextMate, the functions.php file shows two extra blank lines at the bottom of the file.

    I removed these two blank lines and presto, I was able to connect to JetPack!

  6. dentvii
    Member
    Posted 1 year ago #

    Thanks Lutetia, that was indeed the solution to my error as well.

  7. usefulmix
    Member
    Posted 1 year ago #

    For those using self hosted wordpress on nginx and varnish backend, here's a solution to the xml rpc 32700 Jetpack glitch: http://usefulmix.com/wordpress-nginx-varnish-jetpack-xml_rpc-32700-glitch-fix/

Topic Closed

This topic has been closed to new replies.

About this Topic