WordPress.org

Ready to get started?Download WordPress

Forums

Can't connect to server after OS upgrade (3 posts)

  1. crimemon
    Member
    Posted 8 years ago #

    I am running WordPress on my Apache server, or have been, until I upgraded my Mac OS from 104.5 to 10.4.6. I now get an error anytime I go to the root directory of WordPress. The message is that my browser "can't open the page [ ] because it could not connect to the server [ ]."

    I suppose it could have nothing to do with upgrading my OS, I don't know. I am allowed to register at /wp-admin/, but the css formatting is gone and none of the internal WP links work.

    I do have a backup of all my files if that will help.

  2. stewdio
    Member
    Posted 8 years ago #

    What version of apache? With 2.0.x, it may be possible that you need to modify your php.ini, or it's possible that you will have to chmod any folders that are 777 to 755.

    It's been a while, but I"m assuming php_mod_auth for Apache has had a few security enhancements, and will not allow directorie to be world writable, hence the CHMOD change.

    You could also restart MySQL and Apache with your modules as well.

    Check the changelog for your MAC OS and see what might be affecting your connection to the DB. It's a minor upgrade. You may need to update your modules, apache, php or mysql versions.

    Not much of a help I know, but I hope it points you in the right direction.

  3. crimemon
    Member
    Posted 8 years ago #

    Thank you for responding. I'm afraid I'm in over my head. I went through the MacZealot's direction's for installing WordPress on a Mac again at http://maczealots.com/tutorials/wordpress/ and everything with MySQL and the install was fine until I got to the final step of testing out the blog, at which time it is unable to find the server.

    When I previously installed WordPress I had to change a socket connection discussed at http://docs.info.apple.com/article.html?artnum=301457. It gets at the very issues you raised above. I just have trouble interpreting and doing what they say on that page, and am worried that I'll really screw something up if I try.

    I can't tell what version of Apache I'm running (I ran profiler and could find it on everything else but not Apache). MySQL is 4.0.26.

Topic Closed

This topic has been closed to new replies.

About this Topic